Project

General

Profile

Bug #54240

Kernel Panic in nvme_qpair_reset()

Added by CP None over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

A FreeNAS VM with Intel 900P NVMe drive (passthrough from ESXi) panics during boot, in both the latest STABLE trains 11.1-U6 and 11.2-RC1.

There's a report at https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231070 for what looks like a similar bug, but the last comment says FreeBSD's r338471 has patched up the problem. There's a patch between r338418 and r338471 that ought to fix the issue.

Attached is a panic jpeg.


Related issues

Is duplicate of FreeNAS - Bug #26508: Intel Optane 900p will not work in ESX passthroughClosed: Third party to resolve

History

#1 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Alexander Motin

#2 Updated by Alexander Motin over 2 years ago

  • Is duplicate of Bug #26508: Intel Optane 900p will not work in ESX passthrough added

#3 Updated by Alexander Motin over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

What ESXi version are you using? According to latest reports in #26508 this problem is fixed in ESXi 6.7.

#4 Updated by CP None over 2 years ago

Alexander Motin wrote:

What ESXi version are you using? According to latest reports in #26508 this problem is fixed in ESXi 6.7.

I'm running the latest ESXi 6.7 (VMware ESXi 6.7.0 build-10176752). The problem could be a FreeBSD kernel driver bug since Linux (Arch Linux latest) always boots up in all PCI device orderings just fine.

One comment there suggests that changing PCI device order should help, but it doesn't. Mine crashes even with a single PCI device (the 900P NVMe drive).

What did help was another comment to add the following to /etc/vmware/passthru.map:

8086  2700  d3d0     false

which is to say,

  • resetMethod is set to 'd3d0' instead of the 'flr' which is the default
  • fptShareable is set to 'false' instead of the default 'true'.

Also available in: Atom PDF