Project

General

Profile

Bug #10609

Poor CIFS Speed

Added by Adrian Kisser about 5 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello,

i have the problem, that the transfer speed from and to the Nas is very poor.

At write to the Nas i become approx 60MB/s and at reading from it, it will be approx 65MB/s.

The same, when i config the Drives to a stipe set, or mirror, or Z2. I use a Dell T20 with 16GB ECC Ram and a Xeon 1225v3 CPU, the drives arte two WD Green with 2TB and two Samsung HD204ui with 2TB too.

Former i used as OS MS Server 2012R2 and here ich had approx 95-100 MB/s. So i rekon, the problem lay at the CIFS Service.

Regards

Adrian

nas performance.PNG (362 KB) nas performance.PNG Adrian Kisser, 07/17/2015 02:18 AM
3357

History

#1 Updated by Adrian Kisser about 5 years ago

  • File ixdiagnose.tgz added

#2 Updated by Jordan Hubbard about 5 years ago

  • Assignee set to John Hixson

#3 Updated by Jordan Hubbard about 5 years ago

BRB: can you run iperf to see if this is a networking issue, first off? Danke.

#4 Updated by John Hixson about 5 years ago

  • Status changed from Unscreened to 15
  • Target version set to Unspecified

#5 Updated by Adrian Kisser about 5 years ago

So i had testetd my complete network enviroment for any problems, but find no problems.
The transfer speed between my computers are at 95-100MB/s, so i can say, that is no network problem.

I tried on the FreeNas a stripe, a mirror and a Z2 Volume, with and without encryption, but it will be still at all at 60-65 MB/s.

I think, the cpu (Xeon 1225v3) ist strong enough to made the calculations for the raid, and the memory (16 GiB ECC) is more than sufficient.

So i dont now, what the problem is, especially i had fresh setted up the whole system twice, with the same result.

#6 Updated by Adrian Kisser about 5 years ago

3357

I had attached a Picture, where you can see the network activity and the transfer speed at 5 times.

It is possible the problem are made from the build in network chip from Intel (I217-LM) in the T20?

Under Server 2012R2 the transfer speeds riches approx 90-100 MB/s, so my rekon is, that the drivers implemented into FreeBSD are not perfect fit for that Chip.

#7 Updated by Adrian Kisser about 5 years ago

  • Category changed from 39 to 57
  • % Done changed from 0 to 100

OK! So i had solved the problem while i delete and add the network interface new.

So i think the interface had hanged while the setup process.

I had fresh installed twice the FreeNas and every time i had the same problem.
So now i tried a third time and it works fine for me.

Now i have transfer speeds by approx 100-110 MB/s. :-))

You can now close this Case, except you have further questions.

#8 Updated by Jordan Hubbard about 5 years ago

  • Status changed from 15 to Closed: User Config Issue

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

#10 Updated by Dru Lavigne about 3 years ago

  • File deleted (ixdiagnose.tgz)

#11 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF