Project

General

Profile

Bug #10754

NetBIOS (host) Names Conflict if first seven characters are "freenas" preventing discovery in Windows File Explorer

Added by Art Ferreira about 5 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

#1: Dell Precision 490, 16GB RAM
#2: HPdc5800, 4GB RAM

ChangeLog Required:
No

Description

I installed a 2nd Freenas9.3-Stable-201506292130 server on my home network with NetBIOS / Hostname = freenas2. The freenas2 server would not appear on the "network places" in Windows File Explorer. Tried various workgroup browsing functions, making sure there was only one master domain browser (DMB), but nothing worked. A day later, I noticed a message on server #1 (hostname = freenas) complaining that "freenas2 [server #2]was one of our names." I then changed the hostname and NetBIOS name on Server #2 to "chrisnas." Avoiding the character string "free," did the trick. The servers "freenas" and "chrisnas" were now discoverable with Windows File Explorer. Is this a bug?

History

#1 Updated by John Hixson about 5 years ago

  • Status changed from Unscreened to 15
  • Target version set to Unspecified

Can you please provide debugs for both nodes? system->advanced->"save debug"

#2 Updated by Art Ferreira about 5 years ago

  • File debug-chrisnas-20150727161814.tgz added
  • File debug-freenas-20150727161717.tgz added

debug files are attached per your request

#3 Updated by John Hixson about 5 years ago

I very much doubt that the issue has anything to do with the first 7 characters are the same. I do believe it could be an issue with running jails on your host (binding to all interfaces), or running both local masters in the same workgroup, or any other numbers of issues. It would be more helpful to configure back to the way you had it where it was broken, and then debug it from there. If that's not possible, then I will close this ticket as "cannot reproduce". If you're willing to set it back, I would like to schedule a time when we can do a debugging session using teamviewer.

#4 Updated by Art Ferreira about 5 years ago

Thanks, John, for the reply. For clarity, I will refer to the two Freenas servers as #1 and #2. #1's hostname = freenas, #2's hostname = chrisnas (changed from freenas2). Server #1 has 5 jails installed but only 1 jail (Plex server) was enabled at all times Server#2 was up and running. When #2 was still named freenas2, I set the CIFS auxiliary parameters on #2 to the following:
domain master = no
local master = no
preferred master = no
OS level = 0
After rebooting all systems, #2 was still not discoverable.

Server #2 is being setup and loaded with data for the purpose of moving this server to a new (different network) location. Although I am very interested as to why server #2, when using the hostname, "freenas2," was not discoverable, I think we should closeout this "bug" because it is not worth the time or effort to figure why everything works out with name like "chrisnas2." If I was planning to keep server #2 on my network, then I would be happy to revert the systems back to a state where I could recreate the problem.

#5 Updated by John Hixson about 5 years ago

  • Status changed from 15 to Closed: User Config Issue

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

#7 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-chrisnas-20150727161814.tgz)

#8 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20150727161717.tgz)

Also available in: Atom PDF