Project

General

Profile

Bug #10959

NFSv4 stops working, cannot kill nfsd

Added by Cory Albrecht about 5 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Randomly NFS will just stop working. NFS cannot be stopped via the web gui - those little three bars of the spinner/throbber just keep going forever. When I login to the shell and try "service nfsd stop" it hangs forever. Not even kill -9 works to stop the nfsd process.

Note that I have marked it as seen in FreeNAS-9.3-STABLE-201506292332, however my FreeNAS reports itself as FreeNAS-9.3-STABLE-201506292130 on the System -> Information tab of the webGUI and there are no updates shown as available.

History

#1 Updated by Jordan Hubbard about 5 years ago

  • Assignee set to Xin Li
  • Target version set to 49

#2 Updated by Cory Albrecht about 5 years ago

Cory Albrecht wrote:

Randomly NFS will just stop working. NFS cannot be stopped via the web gui - those little three bars of the spinner/throbber just keep going forever. When I login to the shell and try "service nfsd stop" it hangs forever. Not even kill -9 works to stop the nfsd process.

Note that I have marked it as seen in FreeNAS-9.3-STABLE-201506292332, however my FreeNAS reports itself as FreeNAS-9.3-STABLE-201506292130 on the System -> Information tab of the webGUI and there are no updates shown as available.

And I also just noticed that while on the physical console I am seeing the vnlru, bufdaemon, messages to stop but the webGUI is still responding. Previously I had not touched it, assuming it wasn't working, and ended up ghetting frsutrated at 10 minutes of having seemingly hung after "all buffers synced". But now I've just tried to shut the box down via the web GUI three times and all three times the web gui has come back to the main page.

Until, that is, a whole bunch of "Freed UMA keg ... was not empty ... lost X pages of memory" came up on the CRT. The keyboard is no longer seemingly able to do anything, the bufdaemon, vlnru and syncer shut down messages with their 60 second warnings then repeated 3 more times and after 15 minutes the NAS finally powered off.

#3 Updated by Xin Li about 5 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Cory Albrecht about 5 years ago

Any ideas what might because this? Any logs you need me to copypasta? It's getting rather frustrating. Sometimes it doesn't happen for a few days, and then it happens 3 or for times in a day.

#5 Updated by Xin Li about 5 years ago

Cory Albrecht wrote:

Any ideas what might because this? Any logs you need me to copypasta? It's getting rather frustrating. Sometimes it doesn't happen for a few days, and then it happens 3 or for times in a day.

Well, what you described seems like the system is running out of memory, can you rule out that possibility, or check if that's the case? (the data should be available in the "Reporting" tab, check specifically for swap usage).

#6 Updated by Jordan Hubbard over 4 years ago

  • Assignee changed from Xin Li to Alexander Motin

#7 Updated by Jordan Hubbard over 4 years ago

  • Status changed from Screened to Closed: Cannot reproduce

Timing out and closing - we don't see this or any duplicate reports.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF