Project

General

Profile

Bug #10990

Unable to get network access from inside jails

Added by Justin Jovic about 5 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

HP microserver;
http://www8.hp.com/h20195/v2/getpdf.aspx/c04111079.pdf?ver=17

ChangeLog Required:
No

Description

I am unable to get network access from within a jail. I have manually assigned the Jail IP, let my router's DHCP assign an address, but when trying to ping anything on the network or internet, I get host not found.

History

#1 Updated by John Hixson about 5 years ago

  • Status changed from Unscreened to 15
  • Target version set to Unspecified

Please attach a debug: system->advanced->"save debug"

#2 Updated by Justin Jovic about 5 years ago

  • File debug-freenas-20150816223602..tgz added

Justin Jovic wrote:

I am unable to get network access from within a jail. I have manually assigned the Jail IP, let my router's DHCP assign an address, but when trying to ping anything on the network or internet, I get host not found.

Attached is the debug file. FYI, I just totally reinstalled Freenas and I am having the same issue.

FYI, Freenas is running on the HP microserver, http://www8.hp.com/h20195/v2/getpdf.aspx/c04111079.pdf?ver=17

this is the ifconfig result for the jail

epair1b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:aa:af:00:0d:0b
inet 192.168.1.31 netmask 0xffffff00 broadcast 192.168.1.255
nd6 options=9<PERFORMNUD,IFDISABLED>
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active

#3 Updated by Justin Jovic about 5 years ago

  • Hardware Configuration updated (diff)

#4 Updated by John Hixson about 5 years ago

Justin,

You've manually assigned the jails IP addresses, but have not assigned a gateway. You need to assign a gateway. Also, what does the /etc/resolv.conf look like in your jails? Why aren't you using DHCP?

#5 Updated by Justin Jovic about 5 years ago

  • File debug-freenas-20150818172403..tgz added

John Hixson wrote:

Justin,

You've manually assigned the jails IP addresses, but have not assigned a gateway. You need to assign a gateway. Also, what does the /etc/resolv.conf look like in your jails? Why aren't you using DHCP?

I have tried it with DHCP and it didnt work either.

Here is a new debug with DHCP set on both jails. I can ping 192.168.1.2 (FREENAS main IP), but cant ping the gateway, or anything else from the jails.

#6 Updated by Justin Jovic about 5 years ago

John Hixson wrote:

Justin,

You've manually assigned the jails IP addresses, but have not assigned a gateway. You need to assign a gateway. Also, what does the /etc/resolv.conf look like in your jails? Why aren't you using DHCP?

Here is from one of the jails resolv.conf

root@plexmediaserver_1:/etc # cat resolv.conf
search JJNET
nameserver 192.168.1.1

#7 Updated by Justin Jovic about 5 years ago

John Hixson wrote:

Justin,

You've manually assigned the jails IP addresses, but have not assigned a gateway. You need to assign a gateway. Also, what does the /etc/resolv.conf look like in your jails? Why aren't you using DHCP?

Here is from one of the jails resolv.conf

root@plexmediaserver_1:/etc # cat resolv.conf
search JJNET
nameserver 192.168.1.1

This exact config is shown in the working shell of the root system.

#8 Updated by John Hixson about 5 years ago

Justin,

Can I poke around your system? I have a few ideas and it would be much easier if I could debug this from a shell.

#9 Updated by Justin Jovic about 5 years ago

John Hixson wrote:

Justin,

Can I poke around your system? I have a few ideas and it would be much easier if I could debug this from a shell.

Sure. Web in to jsquaredz.asuscomm.com:xxx
Root
xxx

#10 Updated by John Hixson about 5 years ago

Justin Jovic wrote:

John Hixson wrote:

Justin,

Can I poke around your system? I have a few ideas and it would be much easier if I could debug this from a shell.

Sure. Web in to jsquaredz.asuscomm.com:xxx

Root
xxx

You might want to edit this post and remove this ;-) Yes, this is private, but still better not to put here. You can email me this info: . Can you open up SSH too?

#11 Updated by Justin Jovic about 5 years ago

deleted

#12 Updated by Justin Jovic about 5 years ago

deleted

#13 Updated by John Hixson about 5 years ago

Can you open up ssh access? I need a couple of shells to debug this. We can also use teamviewer if you have it.

#14 Updated by John Hixson about 5 years ago

  • Status changed from 15 to Investigation

I wasn't able to figure out exactly what the issue is, but I suspect it's the network card. I disabled VIMAGE on the jails and things worked fine. I could see packets sent out to the router from the jail, but did not see a reply. The router did not have tcpdump or any other way for me to see what was happening so I couldn't determine why the packets were being dropped.

#15 Updated by Justin Jovic about 5 years ago

John Hixson wrote:

I wasn't able to figure out exactly what the issue is, but I suspect it's the network card. I disabled VIMAGE on the jails and things worked fine. I could see packets sent out to the router from the jail, but did not see a reply. The router did not have tcpdump or any other way for me to see what was happening so I couldn't determine why the packets were being dropped.

Plan to pick up this NIC http://www.amazon.com/Intel-PWLA8492MT-PCI-X-Server-Adapter/dp/B00006HX1V/ref=sr_1_2?s=pc&ie=UTF8&qid=1439941398&sr=1-2&keywords=low+profile+nic&refinements=p_89%3AIntel

Please confirm this will suit your test.

#16 Updated by Justin Jovic about 5 years ago

#17 Updated by Jordan Hubbard about 5 years ago

  • Status changed from Investigation to Closed: User Config Issue

#18 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Seen in changed from Unspecified to N/A

#19 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

#20 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20150816223602..tgz)

#21 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20150818172403..tgz)

#22 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF