Project

General

Profile

Bug #11001

AD groups not updating

Added by Michael Preissner about 5 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

FreeNAS-9.3-STABLE-201506292130 - Recently added a new security group to my AD domain (FreeNAS server is a member, not DC). When trying to change the ownership of a new dataset intended for a CIFS/SMB share, the new group does not appear as a choice. I have tried rebuilding the DS cache, I have rebooted the server. I can see the new group from the command line using wbinfo -g, but the new group never becomes available when editing permissions on a dataset.

History

#1 Updated by Jordan Hubbard about 5 years ago

  • Project changed from 9 to FreeNAS
  • Category changed from 179 to 36
  • Assignee set to John Hixson
  • Target version set to Unspecified
  • Seen in changed from to 9.3.1-STABLE-201508250051

#2 Updated by John Hixson about 5 years ago

  • Status changed from Unscreened to 15

Can you please attach a debug? System->Advanced->"Save Debug". Also, run this from the command line (assuming you have AD enabled):

/usr/local/www/freenasUI/tools/cachetool.py expire
/usr/local/www/freenasUI/tools/cachetool.py fill

And then, see if your group is listed:

/usr/local/www/freenasUI/tools/cachetool.py keys | grep yourgroup

Let me know what you find.

#3 Updated by Michael Preissner about 5 years ago

  • File debug-store-20150831064404..tgz added

Debug attached. The cachetool.py commands had no effect. I still am not seeing the new group I created.

#4 Updated by John Hixson about 5 years ago

Do you have time for me to poke around your system? I see no reason why new groups shouldn't show up after rebuilding the cache.

#5 Updated by Michael Preissner about 5 years ago

Sure. Let me know when you're available and we can set it up.

#6 Updated by John Hixson about 5 years ago

Michael Preissner wrote:

Sure. Let me know when you're available and we can set it up.

I'm fairly flexible. Are you available today?

#7 Updated by Michael Preissner about 5 years ago

Sure, I'm available the rest of the day.

#8 Updated by John Hixson about 5 years ago

Michael Preissner wrote:

Sure, I'm available the rest of the day.

Can you install teamviewer (if you don't already have it installed) ? You can send your teamviewer info to me:

#9 Updated by Michael Preissner about 5 years ago

TV info sent.

#10 Updated by John Hixson about 5 years ago

  • Status changed from 15 to Closed: User Config Issue

The issue here was the new groups that were being added did not have the UNIX attributes configured. Once the attributes were configured everything worked as it should.

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

#12 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-store-20150831064404..tgz)

Also available in: Atom PDF