Project

General

Profile

Bug #11057

Some disks show up in 'View Disks' when they are actually Multipaths

Added by Bjarke Emborg Kragelund about 5 years ago. Updated about 4 years ago.

Status:
Closed: Behaves correctly
Priority:
Nice to have
Assignee:
Josh Paetzel
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Dell PowerEdge R715
FreeNAS-9.3-STABLE-201506292332
2 X AMD Opteron 6320
Memory 128GB
Booting on SD (Dell HW-Mirror)
LSI-9207-8e
2 X DNS-1600
48 X 4TB (24 WD + 24 HGST) NearLine SAS-2

ChangeLog Required:
No

Description

Putting on a new shelf/JBOD with 24 new disks and check that the LSI has dualpath to all disks.

FreeNAS is creating 24 new multipath disk - all OK.. But 2 of the 24 disks ( /dev/daxx ) is also showing up in 'View Disks'.

We have seen this before, where the 'solution' was the following:

- sysctl kern.geom.debugflags=0×10
- dd if=/dev/zero of=/dev/daxx bs=512 count=1
- In the GUI choose to 'Wipe' the disk(s) showing both as a single disk AND part of a multipath.
- Reboot FreeNAS

However, this method still gets us the disks in 'View Disks' as if they are singlepath-disks.

Does anyone have a workarround for this or should we just ignore as they seem to be part of a working multipath?

FreeNAS-Multipaths.png (140 KB) FreeNAS-Multipaths.png The flashing RED is due to a resilver in progress Bjarke Emborg Kragelund, 08/20/2015 06:02 AM
FreeNAS-View_Disks.png (125 KB) FreeNAS-View_Disks.png The flashing RED is due to a resilver in progress Bjarke Emborg Kragelund, 08/20/2015 06:02 AM
3584
3585

History

#1 Updated by Jordan Hubbard about 5 years ago

  • Assignee set to Josh Paetzel

#2 Updated by Josh Paetzel about 5 years ago

  • Status changed from Unscreened to 15

Can you attach a save debug to this please?

#3 Updated by Josh Paetzel about 5 years ago

  • Priority changed from No priority to Nice to have
  • Target version set to Unspecified

#4 Updated by Bjarke Emborg Kragelund about 5 years ago

  • File debug-dr-20150821080500.tgz added

#5 Updated by Josh Paetzel about 5 years ago

  • Status changed from 15 to Investigation

#6 Updated by Josh Paetzel about 5 years ago

  • Status changed from Investigation to 15

The GUI is showing the wrong thing because the database is wrong.

The database is wrong because sync_disks is doing the wrong thing somehow. (not taking the multipath members out of the database)

There are a few options here:

1) ignore it, it is just cosmetic and is not affecting anything.

2) Do database surgury to get rid of the cosmetic blemish. I can send you the commands or do a teamviewer with you.

3) Fix the actual bug that is getting this table out of sync in the first place. Once again teamviewer, not recommended for a production system or a system with live data on it for that matter. I'm not perfect and could cause mayhem. Since we don't have anything to repro this and you've run in to it repeatably, there's likely a real bug here. I spent a while introspecting the code and don't see it though.

#7 Updated by Bjarke Emborg Kragelund about 5 years ago

We are in luck as the JBOD and disks are not part of a pool yet. We will isolate the JBOD and disks on a new head. That way we will not be messing with production data.
Can confirm that it very likely is a cosmetic problem. We created a test-pool with all the 24 multipaths - 4 X RaidZ2 vdevs consisting of 6 disks - no glitches. FreeNAS/BSD and ZFS were all happy.
We are two people working on this, and my colleague - for testing purposes - pulled all the disks and inserted them again - the ones from the new JBOD - and all disks now shows up both as Mulitpath and Single. So reproducing the 'error' should be fairly easy.
I will let you know when you can take a look.
As there is some time-difference between us - and there is no data on the system. AND we trust you :-) Maybe a SSH from your IP would suit us all best? Just a thought.
Let me know if that could be solution?

#8 Updated by Josh Paetzel about 5 years ago

  • File ix2_rsa.pub added

SSH works for me. I've attached my public key. Let me know what user to ssh as via private email to

Put instructions for getting root in the homedir of whatever user I can ssh in in a text file chomd 400

#9 Updated by Josh Paetzel about 5 years ago

  • Status changed from 15 to Closed: Behaves correctly
  • Hardware Configuration updated (diff)

In the end it was the JBOD firmware misrepresenting disks to FreeNAS.

A hard powercycle of everything solved the issue.

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#11 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-dr-20150821080500.tgz)

#12 Updated by Dru Lavigne almost 3 years ago

  • File deleted (ix2_rsa.pub)

Also available in: Atom PDF