Project

General

Profile

Bug #11114

encoding issue in ldap password

Added by Cy Mike about 5 years ago. Updated about 4 years ago.

Status:
Closed: Not Applicable
Priority:
Important
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
TrueNAS - 9.3-STABLE-201506300138
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

improper unicode/encoding can cause traceback in webgui.

when click on directory service ldap tab, traceback is shown... similar to moo.txt file uploaded.

History

#1 Updated by John Hixson about 5 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 186

#2 Updated by John Hixson about 5 years ago

I need to look at this issue. The problem is the password encryption scheme being used for AD, LDAP and NT4 generates some strings that django does not like. In turn, when django is unhappy about said string, tracebacks in the UI occur.

#3 Updated by Cy Mike about 5 years ago

  • Priority changed from No priority to Nice to have

#4 Updated by Cy Mike about 5 years ago

  • Project changed from TrueNAS to FreeNAS
  • Category deleted (42)
  • Target version deleted (186)

#5 Updated by Cy Mike almost 5 years ago

  • Target version set to 261

#6 Updated by Cy Mike almost 5 years ago

  • Category set to 36

#7 Updated by Cy Mike almost 5 years ago

  • Priority changed from Nice to have to Important

is there at least a workaround I can use for this until its resolved? I'm looking to check on this issue on a customer system Friday. We were going to attempt resetting the password and confirm proper connection to ldap without any gui tracebacks.

#8 Updated by John Hixson almost 5 years ago

  • Status changed from Screened to Closed: Not Applicable

It looks like William fixed this with 7959ea29ad6ff597f9a2e8f256627facff43e6de

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 261 to N/A

#10 Updated by Dru Lavigne over 2 years ago

  • File deleted (moo.txt)

Also available in: Atom PDF