Project

General

Profile

Bug #11117

Critical alerts don't clear in web GUI

Added by Dan Brown almost 4 years ago. Updated 6 months ago.

Status:
Closed: Not To Be Fixed
Priority:
No priority
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My HDD temps will occasionally exceed 40 deg C, and when they do, I get an email notification of a critical alert. I then take action to lower the temp (i.e., open the door to the closet where the server is kept), and it goes down nicely. The problem is that the critical alert never disappears from the web GUI. When I log in I get the red warning light. Even after clearing the checkboxes next to the individual warnings, they stay there, even weeks after the issue has been resolved.

Suggested resolutions:

1. At whatever interval FreeNAS re-checks SMART data, if the temperature is now below the threshold value, clear out the alert without any further user intervention.

2. Require acknowledgement in the web GUI of this former critical alert, but once acknowledged, remove the alert.

My preference would be 1--the red warning is to indicate that the server is currently in a critical state, and if the drives have been cooled, then the server is no longer in a critical state. The second option has the advantage of requiring that the user actively acknowledge the problem, but the disadvantage of requiring user intervention to resolve a non-issue. If the second option is chosen, it would be helpful if these alerts noted the date/time when they occurred.


Related issues

Related to FreeNAS - Feature #56421: Indicate in new UI when an alert must be dismissed manuallyPassed Testing

History

#1 Updated by Dan Brown almost 4 years ago

  • File ixdiagnose.tgz added

#3 Updated by Jordan Hubbard almost 4 years ago

  • Assignee set to William Grzybowski
  • Target version set to Unspecified
  • Seen in changed from Unspecified to 9.3-STABLE-201506292332

#4 Updated by William Grzybowski almost 4 years ago

  • Status changed from Unscreened to Screened

#5 Updated by Dan Brown over 3 years ago

  • Private changed from Yes to No

#7 Updated by William Grzybowski over 3 years ago

  • Target version changed from Unspecified to 261

#8 Updated by Jordan Hubbard over 3 years ago

  • Target version changed from 261 to 49

#9 Updated by William Grzybowski over 3 years ago

I dont know if there is anything we can do here, or at least is worth the effort.

These alerts are more like single time events, there is no easy way to check every single event triggered by smart if it has been addressed or not, as far as I can tell.

What we could do however, is changing how events are processed and parsing smartctl periodically.

Thoughts?

#10 Updated by William Grzybowski over 3 years ago

Ping. Jordan?

#11 Updated by Jordan Hubbard over 3 years ago

  • Status changed from Screened to Closed: Not To Be Fixed

I don't think it's worth hacking on this with the current Alert system. Alerts in 10 will be edge rather than level triggered, so we shouldn't see this issue.

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore about 2 years ago

  • Target version changed from 49 to N/A

#13 Updated by Dru Lavigne over 1 year ago

  • File deleted (ixdiagnose.tgz)

#14 Updated by Chris Moore 6 months ago

It sure would have been nice if this had been fixed because it is still an issue. Not specific to drive temp, if anything causes an alert, the only way to make the alert go away is to reboot the system even if what initially triggered the alert has been corrected. For example, a bad hard drive is replaced in a system with hot-swap drive bays. The alert that the, now removed, drive has a fault is still presented even after the replacement drive has finished resilver.

#15 Updated by Dru Lavigne 6 months ago

  • Related to Feature #56421: Indicate in new UI when an alert must be dismissed manually added

#16 Updated by Dru Lavigne 6 months ago

This feature is coming in 11.3.

Also available in: Atom PDF