Project

General

Profile

Bug #11196

Found 3 bugs with template (FreeNAS-9.3-STABLE-201506292332)

Added by Gudo Laubner about 5 years ago. Updated about 4 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
John Hixson
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,
i think i found 3 bugs with templates, all not hard to reproduce.
This is for FreeNAS 9.3-STABLE-201506292332

1: A template name must not contain "("
If it does, one can not create jails with this template.
However the UI input allows to enter "(" as part of a template name. My wild guess is that there's missing quoting or shell escapes somewhere, and "(" is not the only letter to be avoided, however i have not tried.

2: A template with .tgz and .mtree being hosted on an FTP server can not be used to create a jail, if the FTP server is the FreeNAS ftp server (I tried both : using URLs with 127.0.0.1 and with normal IP). The process gets trought to file download of the .tgz file and hangs, when the FreeNAS ftp server receives a NOOP from the client code (extract_tarball ?). The NOOP was seen with tcpdump, after successful login, settings of transfer modes, getting the request for the .tgz file, and after a couple of data packets have been send from the ftp server.

3: A self created template can not be deleted when set to "readonly". In other words, once you check "readonly" and "save", you can never delete the template after, even if you never created a jail based upon it.

Cheers
Guido

History

#1 Updated by John Hixson about 5 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 261

Gudo Laubner wrote:

Hi,
i think i found 3 bugs with templates, all not hard to reproduce.
This is for FreeNAS 9.3-STABLE-201506292332

1: A template name must not contain "("
If it does, one can not create jails with this template.
However the UI input allows to enter "(" as part of a template name. My wild guess is that there's missing quoting or shell escapes somewhere, and "(" is not the only letter to be avoided, however i have not tried.

Understandable and fixable. You can not use '('s for now ;-)

2: A template with .tgz and .mtree being hosted on an FTP server can not be used to create a jail, if the FTP server is the FreeNAS ftp server (I tried both : using URLs with 127.0.0.1 and with normal IP). The process gets trought to file download of the .tgz file and hangs, when the FreeNAS ftp server receives a NOOP from the client code (extract_tarball ?). The NOOP was seen with tcpdump, after successful login, settings of transfer modes, getting the request for the .tgz file, and after a couple of data packets have been send from the ftp server.

I'd like to see this in practice. I've created templates and placed them here locally just fine without issue. There is nothing special about how templates are downloaded. Create one and place it somewhere and tell FreeNAS where to get it and it will. The last time someone made this claim, they wrote their own little server and it had some issue I can't recall, but it was not on our end.

3: A self created template can not be deleted when set to "readonly". In other words, once you check "readonly" and "save", you can never delete the template after, even if you never created a jail based upon it.

This is intentional. That is why it is read-only ;-)

Cheers
Guido

#2 Updated by John Hixson about 5 years ago

  • Status changed from Screened to Closed: Cannot reproduce

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 261 to N/A

Also available in: Atom PDF