Project

General

Profile

Bug #11241

Unable to delete dataset in 9.3.1

Added by Brad Alexander about 5 years ago. Updated about 3 years ago.

Status:
Closed: Insufficient Info
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have a dataset called sends. It is specifically for ZFS sends from my PC-BSD box(es). I was able to delete all of the subordnate datasets (e.g. sends/hostname.example.com/var/tmp), however, when I highlight sends/hostname.example.com or sends and click the delete snapshot icon, the background of the GUI turns red, and a white "Loading..." icon comes up in the center of the screen, as expected. However, it stays that way instead of the option to delete the snapshot coming up.

Nothing in the logs. With the subordinate datasets, the logs showed:

notifier: starting collectd.
notifier: stopping collectd.
notifier: Waiting for PIDS: xxxxx

and then the process would complete.

History

#1 Updated by Jordan Hubbard about 5 years ago

  • Category changed from 3 to 2
  • Assignee set to William Grzybowski
  • Priority changed from No priority to Important
  • Target version set to 261

#2 Updated by William Grzybowski about 5 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from Important to Nice to have

Can you paste the output of "ps auxww" and "procstat -kk -a" when its happening?

#3 Updated by Brad Alexander about 5 years ago

  • File procinfo.txt added

Here are the files.

#4 Updated by William Grzybowski about 5 years ago

It did not reveal anything. What about /var/log/debug.log ?

#5 Updated by Brad Alexander about 5 years ago

  • File debug.log added

Here is the debug log. I attempted to delete the dataset again on 2 Sep at 07:54.

#6 Updated by Jordan Hubbard about 5 years ago

BRB: Are you talking about a snapshot or a dataset?

#7 Updated by Brad Alexander about 5 years ago

I have a dataset that I was using to collect pc-bsd zfs snapshots that I set up through life preserver. Unfortunately, the default way snapshots are configured on freenas, the dataset which was receiving the ZFS snapshots from the pc-bsd box was also being snapshotted. I changed the snapshot policy to a per-dataset model (see ticket number 11245), but when I tried to delete and recreate that particular dataset, I was unable to delete it. So the short answer is I could not delete the dataset.

#8 Updated by William Grzybowski almost 5 years ago

  • Target version changed from 261 to Unspecified

Sorry we let the issue rot.

What happens when you try to delete from CLI?

#9 Updated by William Grzybowski almost 5 years ago

  • Status changed from Screened to 15

#10 Updated by William Grzybowski almost 5 years ago

  • Status changed from 15 to Closed: Insufficient Info

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

#12 Updated by Dru Lavigne almost 3 years ago

  • File deleted (procinfo.txt)

#13 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug.log)

Also available in: Atom PDF