Project

General

Profile

Bug #11274

zpool Showing incorrect size

Added by Jason Blodgett about 5 years ago. Updated about 3 years ago.

Status:
Closed: Behaves correctly
Priority:
No priority
Assignee:
Xin Li
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm using 6 x 4TB WD Reds in this machine. The system is showing an incorrect size on the zpool. It shows me as having 21.8 TB of space using 6 x 4TB WD Reds. The 21.8TB figure seems to add up to the total number of space on all the drives. 21.8/6 = 3.63333 GB. That sounds about right to me for total raw storage, but in a RaidZ2 that's roughly 14.5 TB.

I set up a Raidz2 on a fresh install of FreeNAS 9.3-STABLE-201506292332. I've set it up with and without the initial wizard, all with same results. I've also tried updating to FreeNAS 9.3-STABLE-201508250051 before I set up the zpool. I get the same results either way.

The command line and web GUI all show the same thing.

Here's the output of zpool list

NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT
datapool 21.8T 1.22T 20.5T - 3% 5% 1.00x ONLINE /mnt
freenas-boot 14.5G 699M 13.8G - - 4% 1.00x ONLINE -

Here's the output of zpool status

pool: datapool
state: ONLINE
scan: none requested
config:
NAME                                            STATE     READ WRITE CKSUM
datapool ONLINE 0 0 0
raidz2-0 ONLINE 0 0 0
gptid/289b97e7-4cf5-11e5-9fbc-0cc47a72093a ONLINE 0 0 0
gptid/28ff6429-4cf5-11e5-9fbc-0cc47a72093a ONLINE 0 0 0
gptid/29627420-4cf5-11e5-9fbc-0cc47a72093a ONLINE 0 0 0
gptid/29c47921-4cf5-11e5-9fbc-0cc47a72093a ONLINE 0 0 0
gptid/2a26c443-4cf5-11e5-9fbc-0cc47a72093a ONLINE 0 0 0
gptid/2a870bed-4cf5-11e5-9fbc-0cc47a72093a ONLINE 0 0 0

errors: No known data errors

pool: freenas-boot
state: ONLINE
scan: none requested
config:
NAME        STATE     READ WRITE CKSUM
freenas-boot ONLINE 0 0 0
da0p2 ONLINE 0 0 0

errors: No known data errors

Finally, the output of zfs list

NAME USED AVAIL REFER MOUNTPOINT
datapool 834G 13.2T 208K /mnt/datapool
datapool/.system 25.4M 13.2T 208K legacy
datapool/.system/configs-f1ae6c68bbe041c7bb38cadeec088781 192K 13.2T 192K legacy
datapool/.system/cores 192K 13.2T 192K legacy
datapool/.system/rrd-f1ae6c68bbe041c7bb38cadeec088781 192K 13.2T 192K legacy
datapool/.system/samba4 21.3M 13.2T 5.78M legacy
datapool/.system/syslog-f1ae6c68bbe041c7bb38cadeec088781 2.75M 13.2T 751K legacy
datapool/Backups 192K 13.2T 192K /mnt/datapool/Backups
datapool/Composition 231G 13.2T 231G /mnt/datapool/Composition
datapool/Documents 11.3G 13.2T 11.3G /mnt/datapool/Documents
datapool/Downloads 267G 13.2T 265G /mnt/datapool/Downloads
datapool/Music 17.2G 13.2T 17.2G /mnt/datapool/Music
datapool/Other 61.7G 13.2T 61.7G /mnt/datapool/Other
datapool/Pictures 127G 13.2T 127G /mnt/datapool/Pictures
datapool/Stream 88.5G 13.2T 88.5G /mnt/datapool/Stream
datapool/Videos 29.7G 13.2T 29.7G /mnt/datapool/Videos
datapool/jails 192K 13.2T 192K /mnt/datapool/jails
freenas-boot 698M 13.4G 31K none
freenas-boot/ROOT 684M 13.4G 25K none
freenas-boot/ROOT/FreeNAS-9.3-STABLE-201508250051 684M 13.4G 514M /
freenas-boot/ROOT/Initial-Install 1K 13.4G 508M legacy
freenas-boot/ROOT/Wizard-2015-08-27_12:53:16 1K 13.4G 510M /
freenas-boot/ROOT/default 40K 13.4G 508M legacy
freenas-boot/grub 13.6M 13.4G 6.79M legacy

You'll notice the available space here shows a more realistic number.

FreeNAS-Storage-Volume-snip.PNG (25 KB) FreeNAS-Storage-Volume-snip.PNG Jason Blodgett, 09/01/2015 11:58 AM
FreeNAS-Volume-Status-snip.PNG (10 KB) FreeNAS-Volume-Status-snip.PNG Jason Blodgett, 09/01/2015 11:58 AM
3728
3729

History

#1 Updated by Jason Blodgett about 5 years ago

  • File ixdiagnose.tgz added

#4 Updated by Xin Li about 5 years ago

  • Status changed from Unscreened to Closed: Behaves correctly

This is not a bug. If you are interested in this topic please read:

https://docs.oracle.com/cd/E26502_01/html/E29007/gbbti.html

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Seen in changed from Unspecified to N/A

#6 Updated by Dru Lavigne about 3 years ago

  • File deleted (ixdiagnose.tgz)

#7 Updated by Dru Lavigne about 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

Also available in: Atom PDF