Project

General

Profile

Bug #1165

GUI upgrade 8.0.2->8.0.3

Added by Jeff Rizzo over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Important
Assignee:
-
Category:
GUI (new)
Target version:
-
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When doing a 'firmware upgrade' on an x64 install of 8.0.2 release, the GUI stalls at the uploading stage indefinitely.

jpaetzel indicates it looks like the failure is in the 'upload new image' stage, and asked for a tcpdump to be attached (I will). The browser is Google Chrome 16.0.912.63 running on [[MacOS]] 10.6.8.

The tcpdump attached was gathered from the point of clicking "settings->advanced->firmware update", for about 10 minutes. The command line was:

tcpdump -s 1518 -w /mnt/big/downloads/dumpfile host 10.187.0.30 and port 80

Please don't hesitate to request more info. Since the box itself is running stably, I'll try to leave it up for a while to help gather info.

History

#1 Updated by Jeff Rizzo over 7 years ago

The file was too big to attach. It can be downloaded from:

http://www.tastylime.net/netbsd/dumpfile.xz

#2 Updated by William Grzybowski over 7 years ago

Looks like lighttpd is returning a 413 - entity too large for the upload...

Could you check whether the symlink /var/tmp/firmware is pointing out to the correct volume after selecting the temporary place in step 1 of Firmware Update screen?

And if it does, do you have enough free space?

#3 Updated by Jeff Rizzo over 7 years ago

[riz@freenas] ~> ls -l /var/tmp/firmware
lrwxr-xr-x 1 root wheel 27 Jan 11 11:03 /var/tmp/firmware@ -> /mnt/big/downloads/.freenas

[riz@freenas] ~> df -h /mnt/big/downloads
Filesystem Size Used Avail Capacity Mounted on
big/downloads 711G 6.7G 704G 1% /mnt/big/downloads

[root@freenas] ~# ls -ld /mnt/big/downloads/.freenas
drwxr-xr-x 2 www www 2 Jan 10 17:12 /mnt/big/downloads/.freenas/

... so, it looks OK to me. There's nothing in the directory.

#4 Updated by Josh Paetzel over 7 years ago

What does
  1. grep server.max-request-size /usr/local/etc/lighttpd/lighttpd.conf

return on the CLI?

#5 Updated by Jeff Rizzo over 7 years ago

Doesn't return anything - no "max-request-size" string in that file.

#6 Updated by William Grzybowski over 7 years ago

I wonder if restarting lighttpd after selecting the temporary destination would make it work, because lighttpd might check the device on startup and when the system boots the symlink does not exist...
That would explain the intermittent issue (some people have enough free space /var/tmp, some doesn't)

#7 Updated by Anonymous over 7 years ago

This issue is probably a duplicate of ticket # 1425.

#8 Updated by William Grzybowski over 7 years ago

  • Status changed from Unscreened to Closed

Several issues related to upgrade have been addressed in 8.2.

This ticket is no longer valid as we have switched from lighttpd to nginx. I believe the issue is fixed.

Also available in: Atom PDF