Project

General

Profile

Bug #11936

UI left pane does not populate

Added by George - almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Critical
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Left UI pane (where it shows the collapsed menus), does not show up. It keeps cycling through the 3 "progress" bars.

/var/log/debug.log shows:

Oct 14 15:13:32 zodiac manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.system.models.Backup'> does not have a ModelForm
Oct 14 15:13:32 zodiac manage.py: [freeadmin.navtree:424] Model Certificate from app freenasUI.system blacklisted, skipping
Oct 14 15:13:32 zodiac manage.py: [freeadmin.navtree:424] Model CertificateAuthority from app freenasUI.system blacklisted, skipping
Oct 14 15:13:32 zodiac manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.system.models.CertificateBase'> does not have a ModelForm
Oct 14 15:13:32 zodiac manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Oct 14 15:13:32 zodiac manage.py: [freeadmin.navtree:424] Model NTPServer from app freenasUI.system blacklisted, skipping
Oct 14 15:13:32 zodiac manage.py: [freeadmin.navtree:424] Model Registration from app freenasUI.system blacklisted, skipping
Oct 14 15:13:32 zodiac manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.storage.models.Volume'> does not have a ModelForm
Oct 14 15:13:32 zodiac manage.py: [freeadmin.site:255] Fatal error while generating the tree json: 'NoneType' object has no attribute 'lower'
Traceback (most recent call last):
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py", line 248, in menu
    navtree.generate(request)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 336, in generate
    self.replace_navs(tree_roots)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 166, in replace_navs
    parent.append_child(opt)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 131, in append_child
    bisect.insort(self._children, tnode)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 89, in __lt__
    return self.name.lower() < other.name.lower()
AttributeError: 'NoneType' object has no attribute 'lower'

It first started happening on a previous OS version (sorry, don't remember which one), but it still persists on 201509282017.


Related issues

Related to FreeNAS - Bug #12153: lost tree menu on left sideClosed: Duplicate2015-11-01
Related to FreeNAS - Bug #12186: Tree view in GUI will not work after upgrade to FreeNAS-9.3-STABLE-201511020249Closed: Duplicate2015-11-02

Associated revisions

Revision 2112927c (diff)
Added by William Grzybowski almost 5 years ago

Make sure name exists before comparing them Ticket: #11936

Revision 16f4ebc2 (diff)
Added by William Grzybowski almost 5 years ago

Make sure name exists before comparing them Ticket: #11936 (cherry picked from commit 2112927c345a3a5dfe2b5996cdd7a11e9c78e028)

Revision 7cbb0738 (diff)
Added by William Grzybowski almost 5 years ago

Make sure name exists before comparing them Ticket: #11936 (cherry picked from commit 2112927c345a3a5dfe2b5996cdd7a11e9c78e028)

Revision 8fa59833 (diff)
Added by William Grzybowski almost 5 years ago

Make sure name exists before comparing them Ticket: #11936 (cherry picked from commit 2112927c345a3a5dfe2b5996cdd7a11e9c78e028)

Revision 9699ef36 (diff)
Added by William Grzybowski almost 5 years ago

Catch exception on tree menu ordering Ticket: #11936

Revision 852e9ff0 (diff)
Added by William Grzybowski almost 5 years ago

Catch exception on tree menu ordering Ticket: #11936 (cherry picked from commit 9699ef36df8c40d8e96e55849fcb72c40aedb5b1)

Revision f08e9145 (diff)
Added by William Grzybowski almost 5 years ago

Catch exception on tree menu ordering Ticket: #11936 (cherry picked from commit 9699ef36df8c40d8e96e55849fcb72c40aedb5b1)

History

#1 Updated by William Grzybowski almost 5 years ago

  • Status changed from Unscreened to Screened
  • Assignee set to William Grzybowski
  • Target version set to Unspecified

Its impossible to tell just by the traceback.

Can you attach your config file?

#2 Updated by George - almost 5 years ago

Does the config file include password and that sort of thing?

Forgot to mention that the debug.log messages show on a page refresh.

#3 Updated by William Grzybowski almost 5 years ago

No, its not supposed to contain unencrypted password.

#4 Updated by George - almost 5 years ago

can I send it to you via email, instead?

#5 Updated by William Grzybowski almost 5 years ago

Yes, william @ ixsystems com

#6 Updated by William Grzybowski almost 5 years ago

  • Status changed from Screened to Ready For Release

#7 Updated by Vaibhav Chauhan almost 5 years ago

  • Target version changed from Unspecified to 261

#8 Updated by Pete Silvester almost 5 years ago

Just to say I'm getting the same issue as of FreeNAS-9.3-STABLE-201510290351 with a very similar error in debug.log:

Oct 29 13:04:19 woodhouse manage.py: [freeadmin.site:255] Fatal error while generating the tree json: 'int' object has no attribute 'lower'
Traceback (most recent call last):
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py", line 248, in menu
navtree.generate(request)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 336, in generate
self.replace_navs(tree_roots)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 166, in replace_navs
parent.append_child(opt)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 133, in append_child
bisect.insort(self._children, tnode)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 91, in lt
return self.gname.lower() < other.gname.lower()
AttributeError: 'int' object has no attribute 'lower'

#9 Updated by William Grzybowski almost 5 years ago

  • Status changed from Ready For Release to Screened

Any chance you can provide ssh access so I can poke at it? (can be over screen/tmux)

#10 Updated by Edward Pi almost 5 years ago

  • Seen in changed from 9.3.1-STABLE-201509282017 to 9.3.1-STABLE-201510290351

I get some similar error with FreeNAS-9.3-STABLE-201510290351

Oct 29 14:53:36 nas manage.py: [freeadmin.navtree:246] Failed to generate navtree for app freenasUI.sharing: 'int' object has no attribute 'lower'

#11 Updated by Pete Silvester almost 5 years ago

Sorry, nothing personal, but I'd rather not give you ssh access to my personal box!

Adding some more debug logging implies that it is one of the object filters within the "freenasUI.sharing.models.CIFS_Share" model that is failing it in my particular case.

I'm not really a python dev, but from a quick look, line 509 of navtree.py is setting the subopt.gname to e.id (which I guess must be an int?) so then the lower() call on gname within the lt operator in tree.py fails.
Maybe something like:

return str(self.gname).lower() < str(other.gname).lower()

would fix it?

#12 Updated by William Grzybowski almost 5 years ago

Yes it would, but I would like to get to the root cause of the issue, not masquerade it.

#13 Updated by Mark L almost 5 years ago

Seeing the same thing here with FreeNAS-9.3-STABLE-201510290351.

debug.log:

Oct 30 10:48:38 Minas-Tirith manage.py: [freeadmin.site:255] Fatal error while generating the tree json: 'int' object has no attribute 'lower'
Traceback (most recent call last):
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py", line 248, in menu
navtree.generate(request)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 336, in generate
self.replace_navs(tree_roots)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 166, in replace_navs
parent.append_child(opt)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 133, in append_child
bisect.insort(self._children, tnode)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 91, in lt
return self.gname.lower() < other.gname.lower()
AttributeError: 'int' object has no attribute 'lower'

#14 Updated by Pete Silvester almost 5 years ago

William Grzybowski wrote:

Yes it would, but I would like to get to the root cause of the issue, not masquerade it.

Sorry, just trying to help! Pretty sure the root cause is that Python is a dynamically-typed language :)

Like I said before, I think the actual root cause is that for the "freenasUI.sharing.models.CIFS_Share" model the menu is creating a couple of entries - one seems to have a blank name with an "id" of 5 (I think it's the home share), and another is one of my named CIFS shares with an "id" of 4. Line 509 of navtree.py is setting the gname of the TreeType object to this aforementioned id of the model (filter?), and when the overridden lt operator in TreeType compares the two, the call to lower() on an integer type causes the exception. It looks like the I've wrapped an str() around the gname assignment on my box, which has at least got my menu back.

Or you could argue that the root cause is using gname to order objects when it's an unpredictable type, or you could argue that the root cause is the CIFS_Share model not providing objects in the format that the admin menu code expects. I don't know, I'm not a FreeNAS dev - I just want to help fix the problem so that those people affected can get their menus back. Please let me know if there's anything else I can do.

#15 Updated by George - almost 5 years ago

Upgrading to the newest release (FreeNAS-9.3-STABLE-201510290351) fixed the issue for me.

I did notice the bug #11936 (this bug) was reported as fixed in the list of issues that were resolved.

Thank you!

#16 Updated by William Grzybowski almost 5 years ago

  • Related to Bug #12153: lost tree menu on left side added

#17 Updated by William Grzybowski almost 5 years ago

  • Priority changed from No priority to Critical

#18 Updated by Tom Mü-Ko almost 5 years ago

4343

Same Problem with FreeNAS-9.3-STABLE-201510290351:

#19 Updated by Tom Mü-Ko almost 5 years ago

Here are the lines from debug.log:

Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:108] Unable to import 'freenasUI.api' 'nav': No module named nav
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:401] App freenasUI.api has no nav.py module, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:108] Unable to import 'freenasUI.freeadmin' 'nav': No module named nav
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:401] App freenasUI.freeadmin has no nav.py module, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.storage.models.Disk'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model ActiveDirectory from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.system.models.CertificateAuthority'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.directoryservice.models.DirectoryServiceBase'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model KerberosKeytab from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.directoryservice.models.KerberosPrincipal'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model KerberosRealm from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model LDAP from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model NIS from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model NT4 from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_ad from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_adex from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_autorid from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.directoryservice.models.idmap_base'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_hash from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_ldap from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_nss from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_rfc2307 from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_rid from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_tdb from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model idmap_tdb2 from app freenasUI.directoryservice blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:108] Unable to import 'freenasUI.support' 'nav': No module named nav
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:401] App freenasUI.support has no nav.py module, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Disk from app freenasUI.storage blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.storage.models.EncryptedDisk'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model MountPoint from app freenasUI.storage blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model ReplRemote from app freenasUI.storage blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Volume from app freenasUI.storage blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [common.warden:402] warden_base.__init__: enter
Nov  2 00:11:10 muenas manage.py: [common.warden:403] warden_base.__init__: cmd = list
Nov  2 00:11:10 muenas manage.py: [common.warden:404] warden_base.__init__: flags = 0x00000001
Nov  2 00:11:10 muenas manage.py: [common.warden:432] warden_base.__init__: args =  -v
Nov  2 00:11:10 muenas manage.py: [common.warden:438] warden_base.__init__: leave
Nov  2 00:11:10 muenas manage.py: [common.warden:444] warden_base.run: enter
Nov  2 00:11:10 muenas manage.py: [common.warden:453] warden_base.cmd = /usr/local/bin/warden list  -v
Nov  2 00:11:10 muenas manage.py: [common.cmd:190] cmd_pipe.__init__: enter
Nov  2 00:11:10 muenas manage.py: [common.cmd:191] cmd_pipe.__init__: cmd = /usr/local/bin/warden list  -v
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/warden list  -v
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = id: 2
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = host: jail02
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = iface: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = ipv4: 192.168.12.252/24
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = alias-ipv4: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = bridge-ipv4: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = alias-bridge-ipv4: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = defaultrouter-ipv4: 192.168.12.254
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = ipv6: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = alias-ipv6: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = bridge-ipv6: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = alias-bridge-ipv6: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = defaultrouter-ipv6: 
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = autostart: Enabled
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = vnet: Enabled
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = nat: Disabled
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = mac: 02:58:68:00:08:0b
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = status: Running
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = type: portjail
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = flags: allow.raw_sockets=true
Nov  2 00:11:10 muenas manage.py: [common.cmd:210] cmd_pipe.__init__: out = 
Nov  2 00:11:10 muenas manage.py: [common.cmd:221] cmd_pipe.__init__: leave
Nov  2 00:11:10 muenas manage.py: [common.warden:462] warden_base.run: leave
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.network.models.Interfaces'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model JailMountPoint from app freenasUI.jails blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model JailTemplate from app freenasUI.jails blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Jails from app freenasUI.jails blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [common.pipesubr:71] Popen()ing: /usr/local/bin/sipcalc em0
Nov  2 00:11:10 muenas manage.py: [middleware.notifier:212] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model CIFS from app freenasUI.services blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.system.models.Certificate'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.storage.models.Disk'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.services.models.FiberChannelToTarget'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.directoryservice.models.KerberosRealm'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model RPCToken from app freenasUI.services blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model iSCSITargetGroups from app freenasUI.services blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model iSCSITargetPortalIP from app freenasUI.services blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model services from app freenasUI.services blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model bsdGroupMembership from app freenasUI.account blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Alias from app freenasUI.network blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.services.models.CIFS'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model LAGGInterface from app freenasUI.network blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model LAGGInterfaceMembers from app freenasUI.network blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12] Traceback (most recent call last):
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12]   File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 241, in generate
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12]     self._generate_app(app, request, tree_roots, childs_of, fstatus)
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12]   File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 514, in _generate_app
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12]     navopt.append_child(subopt)
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12]   File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 133, in append_child
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12]     bisect.insort(self._children, tnode)
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12]   File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 91, in __lt__
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12]     return self.gname.lower() < other.gname.lower()
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:12] AttributeError: 'int' object has no attribute 'lower'
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Available from app freenasUI.plugins blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Configuration from app freenasUI.plugins blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.jails.models.Jails'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.jails.models.JailsConfiguration'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.plugins.models.Kmod'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Plugins from app freenasUI.plugins blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.system.models.Alert'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.system.models.Backup'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Certificate from app freenasUI.system blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model CertificateAuthority from app freenasUI.system blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.system.models.CertificateBase'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.freeadmin.models.Model'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model NTPServer from app freenasUI.system blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:424] Model Registration from app freenasUI.system blacklisted, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:436] Model <class 'freenasUI.storage.models.Volume'> does not have a ModelForm
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:108] Unable to import 'freenasUI.documentation' 'nav': No module named nav
Nov  2 00:11:10 muenas manage.py: [freeadmin.navtree:401] App freenasUI.documentation has no nav.py module, skipping
Nov  2 00:11:10 muenas manage.py: [freeadmin.site:255] Fatal error while generating the tree json: 'int' object has no attribute 'lower'
Traceback (most recent call last):
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py", line 248, in menu
    navtree.generate(request)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 336, in generate
    self.replace_navs(tree_roots)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/navtree.py", line 166, in replace_navs
    parent.append_child(opt)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 133, in append_child
    bisect.insort(self._children, tnode)
  File "/usr/local/www/freenasUI/../freenasUI/freeadmin/tree/tree.py", line 91, in __lt__
    return self.gname.lower() < other.gname.lower()
AttributeError: 'int' object has no attribute 'lower'

#20 Updated by Tom Mü-Ko almost 5 years ago

Another System is working fine after upgrade to 201510290351.

#21 Updated by Edward Pi almost 5 years ago

Researched and found out this is caused if you for example have some shares Without Name (empty Name).

Adding a Name fixes this Problem.

(Error was: manage.py: [freeadmin.navtree:246] Failed to generate navtree for app freenasUI.sharing: 'int' object has no attribute 'lower')

#22 Updated by Mark L almost 5 years ago

  • Seen in changed from 9.3.1-STABLE-201510290351 to 9.3.1-STABLE-201511020249

After still seeing this after upgrading to 201511020249 I then spotted Edward Pi's comment about having shares with an empty name. I had one such share, for some unknown reason a duplicate of a named share. Immediately upon deleting it, my left pane reappeared.

#23 Updated by Gábor ADORJÁNI almost 5 years ago

Same here.

FreeNAS-9.3-STABLE-201509282017 -> fine.
Upgrade yesterday to FreeNAS-9.3-STABLE-201510290351 -> buggy.
Upgraded today to FreeNAS-9.3-STABLE-201511020249 -> still buggy.

Boot back to FreeNAS-9.3-STABLE-201509282017 -> fine again.

Boot back to FreeNAS-9.3-STABLE-201511020249 -> buggy.

Here I checked the shares' names based on Edward's comment. Found one CIFS share without a name, and as soon as I filled in a name and clicked OK, the left panel reappeared.

#24 Updated by William Grzybowski almost 5 years ago

No one claimed that a fix has been incorporated to 201511020249, in fact nothing did. It will be rolled out in the next one.

#25 Updated by Paul Kohout almost 5 years ago

Edward Pi wrote:

Researched and found out this is caused if you for example have some shares Without Name (empty Name).

Adding a Name fixes this Problem.

(Error was: manage.py: [freeadmin.navtree:246] Failed to generate navtree for app freenasUI.sharing: 'int' object has no attribute 'lower')

I had the same problem. Giving a name to the blank CIFS share solved the problem for me. But I'm not sure what caused the blank CIFS share to appear in the first place. See https://forums.freenas.org/index.php?threads/bug-navtree-not-displayed-in-freenasui.38948/ for a related forum post.

#26 Updated by Rene Descard almost 5 years ago

I had the same problem and edited the smb4.conf file in a shell - that's wrong!

To solve the problem;
1. login to the Web-Interface
2. click on "Sharing" (7th symbol from left or 6th from the right hand side)
3. click on "Windows (CIFS)" and check the list of shares
4. click on the share without a name and then on the Edit-button below
5. type a name and click OK
6. Wait a minute and the left pane should reappear

Maybe you use other shares and have to check all of them...

#27 Updated by William Grzybowski almost 5 years ago

  • Status changed from Screened to Ready For Release

#28 Updated by William Grzybowski almost 5 years ago

  • Related to Bug #12186: Tree view in GUI will not work after upgrade to FreeNAS-9.3-STABLE-201511020249 added

#29 Updated by Paul Kohout almost 5 years ago

Also, don't delete the blank share. It is the home share. If you delete it, your home share goes away. :(

#30 Updated by Vaibhav Chauhan almost 5 years ago

  • Status changed from Ready For Release to Resolved

#31 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 261 to N/A

Also available in: Atom PDF