Project

General

Profile

Bug #1234

Replace Disk fails from GUI in 8.0.3-p1 due to inconsistent swap partition size

Added by Ryan - about 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Important
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Replace disk from GUI fails without explanation when using identical 2TB disk.

After doing replace disk from GUI, there is no apparent resilvering activity taking place or message in the GUI about the failure. After trying replace command from the command line, I got the error "disk is too small". When doing a gpart show, I discovered the problem was that 8.0.3-p1 created a 2GB swap partition as opposed to the 1GB swap partition that was created when I initially created my pool from the GUI in version 8.0. So it seems that the GUI needs to check existing swap partition size and makes sure it creates the new one consistent with the size on the other disks. I manually wiped the disk and recreated the partitions and did the replace from the command line using the same command that was issued from the GUI in the log file.

Here is the forum thread with log files etc.

[http://forums.freenas.org/showthread.php?5810-Replace-Disk-fails-from-GUI-in-8-0-3-p1&p=21033#post21033]

History

#1 Updated by Ryan - about 8 years ago

Thanks William :-)

Also available in: Atom PDF