Project

General

Profile

Bug #12397

FreeNAS GUI improperly parsing ECDSA keys when added to user account

Added by Gerad Munsch almost 5 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When adding an "ECDSA"-type SSH2 key to a user's "authorized_keys" file (via the GUI), despite manually adding a linebreak at the end of an SSH2 key of type "RSA" (before the "ECDSA" key), the two separate keys are concatenated into one line, causing neither key to be able to authenticate.

I've attached the raw text output of `cat /root/.ssh/authorized_keys` as well as a screenshot of `grep --color=auto 'ssh\-\|ecdsa' /root/.ssh/authorized_keys` to demonstrate the issue.


Related issues

Related to FreeNAS - Bug #10208: ssh authorized_keys gets corrupted when adding ed25519 keysResolved2015-06-15

History

#1 Updated by Gerad Munsch almost 5 years ago

  • File ixdiagnose.tgz added

#3 Updated by Gerad Munsch almost 5 years ago

  • File root-ssh-authorized_keys.txt added

#4 Updated by Jordan Hubbard almost 5 years ago

  • Assignee set to William Grzybowski
  • Target version set to Unspecified
  • Seen in changed from Unspecified to 9.3.1-STABLE-201511040813

#5 Updated by William Grzybowski almost 5 years ago

  • Status changed from Unscreened to Screened

#6 Updated by William Grzybowski almost 5 years ago

  • Status changed from Screened to 19
  • Private changed from Yes to No

What version are you running? It should have been resolved already.

#7 Updated by William Grzybowski almost 5 years ago

  • Related to Bug #10208: ssh authorized_keys gets corrupted when adding ed25519 keys added

#8 Updated by William Grzybowski almost 5 years ago

  • Status changed from 19 to 15

#9 Updated by William Grzybowski almost 5 years ago

  • Status changed from 15 to Closed: Cannot reproduce

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

#11 Updated by Dru Lavigne almost 3 years ago

  • File deleted (ixdiagnose.tgz)

#12 Updated by Dru Lavigne almost 3 years ago

  • File deleted (root-ssh-authorized_keys.txt)

Also available in: Atom PDF