Project

General

Profile

Bug #12571

LAG Network connectivity fails when adding iSCSI interfaces

Added by Thomas Maerz almost 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Important
Assignee:
Josh Paetzel
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When I assign a new iSCSI network interface, the management network interface stops responding to pings and won't come back up until I reboot. Also, when initially adding the LAG I have sometimes needed a reboot in order to get it to come up properly and accept a DHCP lease.

Steps to reproduce:

  • Install up new FreeNAS install (latest version FreeNAS-9.3-STABLE-201509282017) with 4 supported network cards
  • Configure Link Aggregate Group for 2 network cards
  • LAG does not come up, reboot, LAG comes up, DHCP lease accepted
  • Log into WebUI
  • Add new network interface on separate iSCSI subnet with MTU 9000
  • Dialog stuck on 'Please wait...', WebUI stops responding, LAG stops responding to pings, Switch reports LAG channel Active on both associated ports
  • Reboot, LAG comes up, iSCSI interface works
  • Add second iSCSI interface, reboot, etc.

I have reproduced this issue about 5 or 6 times on 3 different sets of hardware. I can provide whatever logs you'd like.

History

#1 Updated by Thomas Maerz almost 5 years ago

I would like to add that the systems performs perfectly stable once the interfaces are properly set up including coming up every time after reboots, etc.

#2 Updated by Josh Paetzel almost 5 years ago

A save debug would be the first step.

Are there an interfaces that are set for DHCP?

#3 Updated by Thomas Maerz almost 5 years ago

Josh,

The LAG is set up for DHCP, the iSCSI interfaces have static IPs. I will upload a save debug momentarily.

#4 Updated by Thomas Maerz almost 5 years ago

  • File debug-storage2-20151130124921..tgz added

Debug tarball

#5 Updated by Josh Paetzel almost 5 years ago

  • Status changed from Unscreened to Investigation
  • Assignee set to Josh Paetzel
  • Priority changed from No priority to Important
  • Target version set to 261

#6 Updated by Josh Paetzel almost 5 years ago

Is the system you are accessing the GUI from on the same subnet that the FreeNAS box is on?

#7 Updated by Josh Paetzel almost 5 years ago

  • Status changed from Investigation to 15

#8 Updated by Thomas Maerz almost 5 years ago

Josh,

The system I am accessing the GUI from is on the same subnet as the LAG (management interface). The iSCSI subnets are not accessible to the rest of the network or each other. So I have

LAG: 10.0.50.0/24 <--This is the only place I access the GUI, and that subnet is accessible from my management machine.
iSCSI 1: 10.3.0.0/24
iSCSI 2: 10.4.0.0/24

#9 Updated by Josh Paetzel almost 5 years ago

Ok, well that blows away my theory of a route is getting lost.

So, riddle me this.

Do you have remote console on these machines?
If yes, could we do a teamviewer session where you can get the FreeNAS system into the broken state where I can troubleshoot what is wrong on the remote console?

#10 Updated by Jason Brooks almost 5 years ago

Hello,

I can confirm this bug. Please see https://forums.freenas.org/index.php?threads/link-aggregate-group-stops-working-when-adding-other-new-network-interfaces.39574.

rebooting the system builds the lagg interface correctly.

seen in FreeNAS-9.3-STABLE-201511280648

#11 Updated by Josh Paetzel almost 5 years ago

I need access to a system that is exhibiting this behavior. Preferably one with IPMI or serial access so I can see it when it's in it's broken state.

One of the challenges here is I use this config at home (LACP + MPIO for iSCSI) and I am unable to reproduce the problem.

#12 Updated by Thomas Maerz almost 5 years ago

It is going to be a while before I get some downtime, but I will let you know when I do and I can get you into the IPMI shell of the server.

#13 Updated by Jason Brooks almost 5 years ago

Hello,

I can do this: it does it on a test system as well as my live system. I will need to address this monday though: I am about leave for the weekend.

I have had some trouble with directly connecting freenas to the ipmi device, but I think I can at least network you into it...After all, I am also the network admin... :)

--jason

#14 Updated by Josh Paetzel over 4 years ago

Any word on this?

#15 Updated by Thomas Maerz over 4 years ago

I had a mirrored USB failure and experienced this again while setting the system back up. This time I tried configuring the LAGG from the GUI. Same result. I can't show the system in a broken state because this system only has iDRAC express which doesn't have an IPMI remote console feature unless you get iDRAC Enterprise licenses.

#16 Updated by Jordan Hubbard over 4 years ago

  • Target version changed from 261 to 49

This is a couple of months old - setting to FUTURE

#17 Updated by Jordan Hubbard over 4 years ago

  • Status changed from 15 to Closed

Timing out and closing

#18 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

#19 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-storage2-20151130124921..tgz)

Also available in: Atom PDF