Project

General

Profile

Bug #12850

resolvconf does not include IPv4 configuration

Added by shpokas - almost 5 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Here we have functional IPv6 configured along with IPv4.
When jail starts, it's /etc/resolv.conf file has only IPv6 nameserver information, no IPv4 nameservers.
IPv6 is autoconfigured for a jail.

It does not matter if jail is configured with static IPv4 address or DHCP IPv4, /etc/resolv.conf has only IPv6 nameserver information.

This issue looks somewhat similar to 3758, https://bugs.freenas.org/issues/3758

jail resolv.conf file
  1. Generated by resolvconf
    search domain.com
    nameserver 2001:470:de8e::1

FreeNAS host resolv.conf file
search domain.com
nameserver 192.168.17.4
nameserver 192.168.17.1
nameserver 8.8.8.8

I would expect that host resolv.conf file is honored copied to jail as it is stated several times over in FreeNAS forums.
As a workaround I have to edit resolv.conf manually every time a jail is restarted.
Am I correct and can this be fixed, please?

History

#1 Updated by shpokas - almost 5 years ago

  • File ixdiagnose.tgz added

#2 Updated by John Hixson almost 5 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 261

#3 Updated by John Hixson almost 5 years ago

  • Status changed from Screened to 15

Can you post the /etc/resolv.conf for the "test1" jail? /etc/resolv.conf is only copied into the jail when the jail is created. I'm not able to reproduce this here. I have a jail here configured with dhcp for ipv4 and ipv6 autoconfiguration and /etc/resolv.conf has the correct configuration. I've looked at your debug and do see some problems.

#4 Updated by shpokas - almost 5 years ago

Sure, here's /etc/resolv.conf from freshly restarted test1 jail.
[shpokas@test1 ~]$ cat /etc/resolv.conf
  1. Generated by resolvconf
    search vfs.lv
    nameserver 2001:470:de8e::1

Next, I removed /etc/resolv.conf and restarted jail, got the same contents.

#5 Updated by John Hixson almost 5 years ago

shpokas, can I take a look at your system? (we use teamviewer for this).

#6 Updated by shpokas - almost 5 years ago

John Hixson wrote:

shpokas, can I take a look at your system? (we use teamviewer for this).

Yes, you can. Would you like to do it now?
Yu can catch me on Skype, search for username kurbijkurne

#7 Updated by John Hixson almost 5 years ago

shpokas - wrote:

John Hixson wrote:

shpokas, can I take a look at your system? (we use teamviewer for this).

Yes, you can. Would you like to do it now?
Yu can catch me on Skype, search for username kurbijkurne

I am available now. I don't use skype, however. If you would like to do this with teamviewer, please email me your details directly:

#8 Updated by John Hixson over 4 years ago

Are you still available for this?

#9 Updated by shpokas - over 4 years ago

Yes, I am.

#10 Updated by John Hixson over 4 years ago

shpokas - wrote:

Yes, I am.

Let me know a good time to meet up then. You can send your teamviewer details to me directly: . Please reference ticket number in your email.

#11 Updated by John Hixson over 4 years ago

  • Status changed from 15 to Investigation

So the gist of this is that a static IPv4 address is being used while a dynamic IPv6 address is also being used. rtsold is overwriting /etc/resolv.conf with only a IPv6 address. To get around this, we added an entry for the IPv4 DNS address into /etc/resolv.conf and then chflags to schg so that rtsol can't overwrite it. I am going to investigate a more elegant way of doing this (if possible).

#12 Updated by John Hixson over 4 years ago

  • Status changed from Investigation to Closed: User Config Issue

It appears there are ways to accomplish what you want using resolvconf. The workaround works as well.

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 261 to N/A

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Seen in changed from Unspecified to N/A

#15 Updated by Dru Lavigne about 3 years ago

  • File deleted (ixdiagnose.tgz)

#16 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF