Project

General

Profile

Bug #1290

WebGUI confused with similarly named pools

Added by Monarch Dodra over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Expected
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
-
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I want to start by saying this is a pure GUI display problem. The GUI actually still works fine, however it will confuse the shit out of the user. Possibly even think their install is corrupt.

The problem is pretty simple: Volumes from 1 pool show up a second time in another pool. Image attached for explanation. Again, I stress that this is only a visualization problem. The actual right hand side volume pane is perfectly fine.

In my case, I have a "master" pool named "Gungnir", and a slave pool called "Gungnir_BCK". The volumes under Gungnir_BCK show up inside "Gungnir".

My guess is the problem is a simple parser problem:
The volumes under gungnir are (probably) populated with a regex search for "/mnt/Gungnir", so they match all of the "/mnt/Gungnir_BCK" volumes.

I will also add that the problem appears after importing the pools, but only after rebooting.

History

#1 Updated by Monarch Dodra over 9 years ago

I forgot to mention: The volumes inside the _BCK pool are replications. Not sure if that changes anything.

#2 Updated by William Grzybowski over 9 years ago

I believe this is fixed in r10291 and will be available in 8.0.4-RC2 or 8.0.4-RELEASE

Thank you

#3 Updated by Monarch Dodra over 9 years ago

I can confirm the current 8.0.4-Release fixes the issue. Thank you.

Also available in: Atom PDF