Project

General

Profile

Bug #1292

Can't connect with APC Back-UPS Pro

Added by HAL_9000 - over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Important
Assignee:
William Grzybowski
Category:
Middleware
Target version:
-
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

[[FreeNAS]]-8.0.4-BETA2 can't connect with APC Back-UPS Pro.
UPS is connected to serial port /dev/cuau0 using apcsmart driver.
This UPS with exactly the same settings works without problems with [[FreeNAS]] 0.7.5.

From log:

Feb 18 20:08:31 freenas freenasr1930: Executing: /usr/sbin/service ix-ups quietstart
Feb 18 20:08:32 freenas freenasr1930: Executing: /usr/sbin/service nut restart
Feb 18 20:08:32 freenas freenas: nut not running? (check /var/db/nut/upsd.pid).
Feb 18 20:08:32 freenas freenas: Can't uu_lock cuau0: creat error: Permission denied
Feb 18 20:08:32 freenas freenas: Network UPS Tools - APC Smart protocol driver 3.0 (2.6.2)
Feb 18 20:08:32 freenas freenas: APC command table version 3.0
Feb 18 20:08:32 freenas freenas: Driver failed to start (exit status=1)
Feb 18 20:08:32 freenas freenas: Network UPS Tools - UPS driver controller 2.6.2
Feb 18 20:08:32 freenas root: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut
Feb 18 20:08:32 freenas freenas: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut
Feb 18 20:08:32 freenas freenasr1930: Executing: /usr/sbin/service nut_upsmon restart
Feb 18 20:08:32 freenas freenas: nut_upsmon not running? (check /var/db/nut/upsmon.pid).
Feb 18 20:08:32 freenas freenas: Starting nut_upsmon.
Feb 18 20:08:32 freenas freenas: UPS: ups (master) (power value 1)
Feb 18 20:08:32 freenas freenasr1930: Executing: /usr/sbin/service nut_upslog restart
Feb 18 20:08:32 freenas upsmonr3377: UPS [ups]: connect failed: Connection failure: Connection refused
Feb 18 20:08:32 freenas upsmonr3377: Communications with UPS ups lost
Feb 18 20:08:32 freenas freenas: nut_upslog not running? (check /var/db/nut/upslog.pid).
Feb 18 20:08:32 freenas freenas: Starting nut_upslog.
Feb 18 20:08:32 freenas freenas: Warning: initial connect failed: Connection failure: Connection refused
Feb 18 20:08:33 freenas freenasr1930: Executing: /bin/pgrep -F /var/db/nut/upsd.pid upsd
Feb 18 20:08:37 freenas upsmonr3377: UPS [ups]: connect failed: Connection failure: Connection refused
Feb 18 20:08:37 freenas upsmonr3377: UPS ups is unavailable
Feb 18 20:08:42 freenas upsmonr3377: UPS [ups]: connect failed: Connection failure: Connection refused
Feb 18 20:09:12 freenas last message repeated 6 times

History

#1 Updated by William Grzybowski over 9 years ago

What does "ls -l /dev/cuau*" , "ps aux|grep ups", "ls -la /var/db/nut" looks like?

#2 Updated by HAL_9000 - over 9 years ago

Replying to [comment:2 william]:

What does "ls -l /dev/cuau*" , "ps aux|grep ups", "ls -la /var/db/nut" looks like?

[root@freenas] ~# ls -l /dev/cuau*
crw-rw----  1 uucp  dialer    0,  37 Feb 23 18:23 /dev/cuau0
crw-rw----  1 uucp  dialer    0,  38 Feb 23 18:23 /dev/cuau0.init
crw-rw----  1 uucp  dialer    0,  39 Feb 23 18:23 /dev/cuau0.lock
crw-rw----  1 uucp  dialer    0,  43 Feb 23 18:23 /dev/cuau1
crw-rw----  1 uucp  dialer    0,  44 Feb 23 18:23 /dev/cuau1.init
crw-rw----  1 uucp  dialer    0,  45 Feb 23 18:23 /dev/cuau1.lock
[root@freenas] ~# ps aux|grep ups
root    2836  0.0  0.0  3376  1196   0  S+    6:32PM   0:00.00 grep ups
[root@freenas] ~# ls -la /var/db/nut
total 2
drwxrwx---   2 root  uucp   512 Feb 23 18:29 ./
drwxr-xr-x  13 root  wheel  512 Feb 23 18:24 ../
-rw-r--r--   1 root  uucp     5 Feb 23 18:29 upslog.pid
-rw-r--r--   1 root  uucp     5 Feb 23 18:29 upsmon.pid

#3 Updated by William Grzybowski over 9 years ago

I'm not seeing anything wrong with it...
Are you sure it is cuau0 and not cuau1?

#4 Updated by HAL_9000 - over 9 years ago

Replying to [comment:4 william]:

Are you sure it is cuau0 and not cuau1?

I have tried both. Under [[FreeNAS]] 0.7.5 UPS works with /dev/cuau0 perfectly.

#5 Updated by HAL_9000 - over 9 years ago

Went back to 8.0.3 due to some performance problems and UPS issue is gone...

#6 Updated by HAL_9000 - over 9 years ago

In [[FreeNAS]] 8.0.4-RELEASE UPS still does not work :-(

#7 Updated by Anonymous over 9 years ago

I need to look at this before 8.2.0-RELEASE, but the issue is believed to be the devfs rules and the fact that the permissions aren't setup to work with the setuid stuff.

#8 Updated by evan samett over 9 years ago

Noob: Failed to connect - connection refused - with Cyber Power CP 1500 AVR / CP 1500 C
Tried both FN8 drivers. using ugen4.2

messages:
ugen4.2 at usbus4
unknown usb device vendor 0x0764
unknown usb device product 0x0501 uhub 4

#9 Updated by axc27 - over 9 years ago

I have the same problem the original poster "HAL 9000" reported.

I have an APC [[BackUPS]] pro conneted to the serial port. Works fine in 8.0.2, 8.0.3, and 8.0.3-p1 , but the connection is not working in 8.0.4.

did not test 8.0.4-p1 yet, as going back to 8.0.3-p1 gave me some trouble with a non-working web-UI last time ("An unhandled exception was thrown by the application").

I didn't find anything concerning changes in devfs rules in the changelog for 8.0.4-p1, so I assume that it hasn't been fixed yet? (didn't find anything in changelog for 8.0.3-p1 to 8.0.4 that could have caused the problem either)

axc27

#10 Updated by Alexander Suvorov over 9 years ago

Still does not work in 8.2.0-BETA3

#11 Updated by William Grzybowski over 9 years ago

Then help troubleshoot why it doesn't work because the developers do not have serial UPS to try it out and fix the issue ;)

#12 Updated by Alexander Suvorov over 9 years ago

Is there any other solution?
If [[FreeNAS]] does not connect to UPS, in this case is of little use from it :(

#13 Updated by axc27 - over 9 years ago

I am willing to contribute, of course.

just tell me what information is needed, I will try get it for the 8.0.3-p1 and a non-working version 8.0.4(-p1)

I thought the information that it broke in the step from 8.0.3-p1 to 8.0.4 would already help making a diff in the parts concerning devfs and serial port.

I could also try connecting to my UPS in 8.0.4 with an USB-serial adapter...

#14 Updated by William Grzybowski over 9 years ago

I already tried that, there is nothing suspicious in the diff...
It is possible the ports version is different. Does the nut versions diverge between 8.0.3-p1 and 8.0.4?

  1. upsc -v

#15 Updated by Anonymous over 9 years ago

Nope

#16 Updated by axc27 - over 9 years ago

I gathered some information with the 8.0.3-p1 I am currently using and 8.0.4-p1 on a different stick for testing:

[[FreeNAS]] Build: [[FreeNAS]]-8.0.3-RELEASE-p1-x64 (9591)


[Daniel@Datengrab] /# whoami
root

[Daniel@Datengrab] /# ls -l /dev/cuau*
crw-rw----  1 uucp  dialer    0,  43 Apr 23 20:46 /dev/cuau0
crw-rw----  1 uucp  dialer    0,  44 Apr 23 20:43 /dev/cuau0.init
crw-rw----  1 uucp  dialer    0,  45 Apr 23 20:43 /dev/cuau0.lock

[Daniel@Datengrab] /# ps aux|grep ups
uucp        1848  0.0  0.0  8032  1716  ??  Rs    8:44PM   0:00.12 /usr/local/libexec/nut/apcsmart -a ups
uucp        1850  0.0  0.0 10988  2640  ??  Ss    8:44PM   0:00.02 /usr/local/sbin/upsd
uucp        1856  0.0  0.0 12040  2524  ??  Is    8:44PM   0:00.00 /usr/local/bin/upslog -s ups@localhost -l /var/log/ups.log -i 300
root        1862  0.0  0.0 12040  2528  ??  Is    8:44PM   0:00.00 /usr/local/sbin/upsmon localhost
uucp        1864  0.0  0.0 12040  2584  ??  S     8:44PM   0:00.01 /usr/local/sbin/upsmon localhost
root        2851  0.0  0.0  8972  1348   0  RL+   8:46PM   0:00.00 grep ups
[Daniel@Datengrab] /# ls -la /var/db/nut
total 3
drwxrwx---   2 root  uucp   512 Apr 23 20:44 ./
drwxr-xr-x  13 root  wheel  512 Apr 23 20:44 ../
srw-rw----   1 uucp  uucp     0 Apr 23 20:44 apcsmart-ups=
-rw-r--r--   1 uucp  uucp     5 Apr 23 20:44 apcsmart-ups.pid
-rw-r--r--   1 uucp  uucp     5 Apr 23 20:44 upsd.pid
-rw-r--r--   1 root  uucp     5 Apr 23 20:44 upslog.pid
-rw-r--r--   1 root  uucp     5 Apr 23 20:44 upsmon.pid
[Daniel@Datengrab] /# cat /etc/local/nut/ups.conf
[ups]
    driver = apcsmart
    port = /dev/cuau0
    desc = "" 
cable=940-0024C

[Daniel@Datengrab] /# cat /var/log/ups.log
20120423 204413 NA NA NA [WAIT] NA NA
20120423 204914 100.0 224.6 022.7 [OL] NA 50.00
20120423 205413 100.0 221.7 023.4 [OL] NA 50.00
Daniel@Datengrab] /# upsc -v
upsc: illegal option -- v
Network UPS Tools upsc 2.6.2

#17 Updated by axc27 - over 9 years ago

[[FreeNAS]] Build: [[FreeNAS]]-8.0.4-RELEASE-p1-x64

[Daniel@Datengrab] /# whoami
root

[Daniel@Datengrab] /# ls -l /dev/cuau*
crw-rw----  1 uucp  dialer    0,  43 Apr 26 22:38 /dev/cuau0
crw-rw----  1 uucp  dialer    0,  44 Apr 26 22:38 /dev/cuau0.init
crw-rw----  1 uucp  dialer    0,  45 Apr 26 22:38 /dev/cuau0.lock
[Daniel@Datengrab] /# ps aux|grep ups
uucp        1906  0.0  0.0 12040  2504  ??  Ss   10:39PM   0:00.00 /usr/local/bin/upslog -s ups@localhost -l /var/log/ups.log -i 300
root        1912  0.0  0.0 12040  2492  ??  Is   10:39PM   0:00.00 /usr/local/sbin/upsmon localhost
uucp        1914  0.0  0.0 12040  2524  ??  S    10:39PM   0:00.05 /usr/local/sbin/upsmon localhost
root        2841  0.0  0.0  8972  1400   1  S+   10:44PM   0:00.00 grep ups
[Daniel@Datengrab] /# ls -la /var/db/nut
total 2
drwxrwx---   2 root  uucp   512 Apr 26 22:39 ./
drwxr-xr-x  13 root  wheel  512 Apr 26 22:40 ../
-rw-r--r--   1 root  uucp     5 Apr 26 22:39 upslog.pid
-rw-r--r--   1 root  uucp     5 Apr 26 22:39 upsmon.pid
[Daniel@Datengrab] /# cat /etc/local/nut/ups.conf
[ups]
    driver = apcsmart
    port = /dev/cuau0
    desc = "" 
cable=940-0024C
[Daniel@Datengrab] /# cat /var/log/ups.log
20120426 223903 NA NA NA [NA] NA NA
20120426 224403 NA NA NA [NA] NA NA
[Daniel@Datengrab] /# upsc -v
upsc: illegal option -- v
Network UPS Tools upsc 2.6.2

from /var/log/messages:

Apr 26 22:38:51 Datengrab kernel: uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
Apr 26 22:38:51 Datengrab kernel: uart0: [FILTER]

[… snip ...]

Apr 26 22:39:03 Datengrab root: /etc/rc: WARNING: failed precmd routine for nut
Apr 26 22:39:03 Datengrab upsmonr1914: UPS [ups]: connect failed: Connection failure: Connection refused
Apr 26 22:39:03 Datengrab upsmonr1914: Communications with UPS ups lost
Apr 26 22:39:08 Datengrab upsmonr1914: UPS [ups]: connect failed: Connection failure: Connection refused
Apr 26 22:39:08 Datengrab upsmonr1914: UPS ups is unavailable
Apr 26 22:39:12 Datengrab ntpdr1795: time reset +0.300647 s
Apr 26 22:39:13 Datengrab upsmonr1914: UPS [ups]: connect failed: Connection failure: Connection refused
Apr 26 22:39:48 Datengrab last message repeated 7 times
Apr 26 22:41:48 Datengrab last message repeated 24 times
Apr 26 22:43:03 Datengrab last message repeated 15 times

Apr 26 22:43:08 Datengrab upsmonr1914: UPS [ups]: connect failed: Connection failure: Connection refused
Apr 26 22:43:43 Datengrab last message repeated 7 times
Apr 26 22:44:13 Datengrab last message repeated 6 times
Apr 26 22:44:13 Datengrab upsmonr1914: UPS ups is unavailable

Apr 26 22:44:18 Datengrab upsmonr1914: UPS [ups]: connect failed: Connection failure: Connection refused
Apr 26 22:44:48 Datengrab last message repeated 6 times
Apr 26 22:46:23 Datengrab last message repeated 19 times

Apr 26 22:46:28 Datengrab upsmonr1914: UPS [ups]: connect failed: Connection failure: Connection refused
Apr 26 22:47:03 Datengrab last message repeated 7 times

#18 Updated by axc27 - over 9 years ago

ok, learned something while trying to connect the UPS with an usb-serial adapter.
Beforehand: the usb-serial adatpter does not change the situation. works with 8.0.3-p1, does not work with 8.0.4(-p1)

resarting the ups service in 8.0.3-p1:

Apr 27 00:02:48 Datengrab freenasr2075: Executing: /usr/sbin/service ix-ups quietstart
Apr 27 00:02:48 Datengrab freenasr2075: Executing: /usr/sbin/service nut restart
Apr 27 00:02:48 Datengrab freenas: nut not running? (check /var/db/nut/upsd.pid).
Apr 27 00:02:56 Datengrab freenas: Network UPS Tools - UPS driver controller 2.6.2
Apr 27 00:02:56 Datengrab freenas: Starting nut.
Apr 27 00:02:56 Datengrab freenas: listening on 127.0.0.1 port 3493
Apr 27 00:02:56 Datengrab freenas: Connected to UPS [ups]: apcsmart-ups
Apr 27 00:02:56 Datengrab freenasr2075: Executing: /usr/sbin/service nut_upsmon restart
Apr 27 00:02:56 Datengrab freenas: nut_upsmon not running? (check /var/db/nut/upsmon.pid).
Apr 27 00:02:56 Datengrab freenas: Starting nut_upsmon.
Apr 27 00:02:56 Datengrab freenas: UPS: ups (master) (power value 1)
Apr 27 00:02:56 Datengrab freenasr2075: Executing: /usr/sbin/service nut_upslog restart
Apr 27 00:02:56 Datengrab freenas: nut_upslog not running? (check /var/db/nut/upslog.pid).
Apr 27 00:02:56 Datengrab freenas: Starting nut_upslog.
Apr 27 00:02:57 Datengrab freenasr2075: Executing: /bin/pgrep -F /var/db/nut/upsd.pid upsd

resarting the ups service in 8.0.4:

Apr 26 23:56:51 Datengrab freenasr2119: Executing: /usr/sbin/service ix-ups quietstart
Apr 26 23:56:51 Datengrab freenasr2119: Executing: /usr/sbin/service nut restart
Apr 26 23:56:51 Datengrab freenas: nut not running? (check /var/db/nut/upsd.pid).
Apr 26 23:56:51 Datengrab freenas: Can't uu_lock cuau0: creat error: Permission denied
Apr 26 23:56:51 Datengrab freenas: Network UPS Tools - APC Smart protocol driver 3.0 (2.6.2)
Apr 26 23:56:51 Datengrab freenas: APC command table version 3.0
Apr 26 23:56:51 Datengrab freenas: Driver failed to start (exit status=1)
Apr 26 23:56:51 Datengrab freenas: Network UPS Tools - UPS driver controller 2.6.2
Apr 26 23:56:51 Datengrab root: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut
Apr 26 23:56:51 Datengrab freenas: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut
Apr 26 23:56:51 Datengrab freenasr2119: Executing: /usr/sbin/service nut_upsmon restart
Apr 26 23:56:52 Datengrab freenas: Stopping nut_upsmon.
Apr 26 23:56:52 Datengrab upsmonr2955: upsmon parent: read
Apr 26 23:56:52 Datengrab freenas: Starting nut_upsmon.
Apr 26 23:56:52 Datengrab freenas: UPS: ups (master) (power value 1)
Apr 26 23:56:52 Datengrab freenasr2119: Executing: /usr/sbin/service nut_upslog restart
Apr 26 23:56:52 Datengrab upsmonr3335: UPS [ups]: connect failed: Connection failure: Connection refused
Apr 26 23:56:52 Datengrab upsmonr3335: Communications with UPS ups lost
Apr 26 23:56:52 Datengrab freenas: Stopping nut_upslog.
Apr 26 23:56:52 Datengrab freenas: Starting nut_upslog.
Apr 26 23:56:52 Datengrab freenas: Warning: initial connect failed: Connection failure: Connection refused
Apr 26 23:56:52 Datengrab freenasr2119: Executing: /bin/pgrep -F /var/db/nut/upsd.pid upsd
Apr 26 23:56:57 Datengrab upsmonr3335: UPS [ups]: connect failed: Connection failure: Connection refused
Apr 26 23:56:57 Datengrab upsmonr3335: UPS ups is unavailable
Apr 26 23:57:02 Datengrab upsmonr3335: UPS [ups]: connect failed: Connection failure: Connection refused

the critical point is in the precmd routine of /usr/local/etc/rc.d/nut

freenas: Can't uu_lock cuau0: creat error: Permission denied
[...]
root: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut

but its too late now to go dig further for me now, I need some sleep...

just saw that the permission error already pops up in the first entry of this bugreport. so nothing new. but I do now have two working USB sticks, one with 8.0.3-p1 (productive) and one with 8.0.4 and 8.0.4-p1 for testing. If you have an idea which information could help, just tell me, I will try to get it.

might the user of the nut processes be different since 8.0.4?

#19 Updated by William Grzybowski about 9 years ago

nut should be running as uucp on both.
Thanks for the logs but I'm still failing to see where it differs.

#20 Updated by axc27 - about 9 years ago

just had the time to give 8.0.4-p2 a test... not working, same as in 8.0.4 and -p1.

#21 Updated by axc27 - about 9 years ago

had a further look at the init script /usr/local/etc/rc.d/nut

It actually only calls

/usr/local/libexec/nut/upsdrvctl start

in the precmd. running it as root with increased debugging leads to:

8.0.3-p1

[Daniel@Datengrab] /# /usr/local/libexec/nut/upsdrvctl -D start
Network UPS Tools - UPS driver controller 2.6.2
   0.000000     Starting UPS: ups
Network UPS Tools - APC Smart protocol driver 3.0 (2.6.2)
APC command table version 3.0

[Daniel@Datengrab] /# /usr/local/libexec/nut/upsdrvctl -D stop
Network UPS Tools - UPS driver controller 2.6.2
   0.000000     Stopping UPS: ups

8.0.4-p2

[Daniel@Datengrab] /# /usr/local/libexec/nut/upsdrvctl -D start
Network UPS Tools - UPS driver controller 2.6.2
   0.000000     Starting UPS: ups
Network UPS Tools - APC Smart protocol driver 3.0 (2.6.2)
APC command table version 3.0
Can't uu_lock cuau0: creat error: Permission denied
   0.006822     Driver failed to start (exit status=1)

did the build parameters for nut change from 8.0.3 to 8.0.4?

#22 Updated by axc27 - about 9 years ago

did further digging and found the error.

actually googling for "creat error: Permission denied" led to several threads dealing with lock problems under [[FreeBSD]], most of the together with UPS systems... some of them even more than ten years old.

Can't uu_lock cuau0: creat error: Permission denied

doesn't refer to a problem accessing the serial port, but to permission error on writing the lock file. forum posts give the hint to check /var/spool/lock... and indeed, there is the problem:

8.0.3-p1

[Daniel@Datengrab] /> ls -ld /var/spool/lock
drwxrwxr-x  2 uucp  dialer  512 May 15 21:34 /var/spool/lock/

8.0.4-p2

[Daniel@Datengrab] /# ls -ld /var/spool/lock
drwxrwxr-x  2 root  wheel  512 May 15 21:13 /var/spool/lock/

and a quick and dirty hack makes the UPS work under 8.0.4-p2:

after

[Daniel@Datengrab] /# chmod 777 /var/spool/lock
[Daniel@Datengrab] /# ls -ld /var/spool/lock
drwxrwxrwx  2 root  wheel  512 May 15 21:47 /var/spool/lock/

the UPS starts up as normal


May 15 21:49:20 Datengrab freenasr2109: Executing: /usr/sbin/service ix-ups quietstart
May 15 21:49:20 Datengrab freenasr2109: Executing: /usr/sbin/service nut restart
May 15 21:49:20 Datengrab freenas: nut not running? (check /var/db/nut/upsd.pid).
May 15 21:49:29 Datengrab freenas: Network UPS Tools - UPS driver controller 2.6.2
May 15 21:49:29 Datengrab freenas: Starting nut.
May 15 21:49:29 Datengrab freenas: listening on 127.0.0.1 port 3493
May 15 21:49:29 Datengrab freenas: Connected to UPS [ups]: apcsmart-ups
May 15 21:49:29 Datengrab freenasr2109: Executing: /usr/sbin/service nut_upsmon restart
May 15 21:49:29 Datengrab freenas: 
nut_upsmon not running? (check /var/db/nut/upsmon.pid).
May 15 21:49:29 Datengrab freenas: Starting nut_upsmon.
May 15 21:49:29 Datengrab freenas: UPS: ups (master) (power value 1)
May 15 21:49:29 Datengrab freenasr2109: Executing: /usr/sbin/service nut_upslog restart
May 15 21:49:29 Datengrab freenas: nut_upslog not running? (check /var/db/nut/upslog.pid).
May 15 21:49:29 Datengrab freenas: Starting nut_upslog.
May 15 21:49:29 Datengrab freenasr2109: Executing: /bin/pgrep -F /var/db/nut/upsd.pid upsd

and nicely communicates

May 15 21:51:04 Datengrab upsmonr2949: UPS ups on battery
May 15 21:52:29 Datengrab upsmonr2949: UPS ups on line power

small change, large effect...

the nice way also works, setting

chown uucp:dialer /var/spool/lock

as in 8.0.3 and everything is fine.

Just setting the group to dialer is not sufficient, as uucp is not part of the group dialer.

#23 Updated by Alexander Suvorov about 9 years ago

Bravo!!!!

#24 Updated by William Grzybowski about 9 years ago

Ok, now it makes sense.

It regressed in r10022.

I'll work on a fix soon and let you know.

Thank you for digging into this.

#25 Updated by William Grzybowski about 9 years ago

Bug hopefully fixed in r11478 and r11479.

Please give a try in the upcoming 8.2-BETA4 to test it out.

Thanks for everyone involved in tracking this down.

#26 Updated by axc27 - about 9 years ago

just checked in current 8.2.1-ALPHA (r11700) and UPS works fine.

but the fix has not been added to 8.0.4-p3 yet...

Also available in: Atom PDF