Project

General

Profile

Bug #13115

Services failling to restart

Added by RJ Gibson over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Important
Assignee:
Erin Clark
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Attempting to connect to LDAP directory, Either an error has occurred or the service has failed to restart appears. Can successfully run ldapsearch command. Here is the command: ldapsearch -H ldap://ldap.jumpcloud.com:389 -x -b "ou=Users,o=************************,dc=jumpcloud,dc=com" -D "uid=rgibson,ou=Users,o=************************,dc=jumpcloud,dc=com" -w "************" "(objectClass=inetOrgPerson)"

Also I am unable to find any logs that tell me what the error is. I am unable to use the built-in log tool under system.

jumpcloud.chain.pem (1.85 KB) jumpcloud.chain.pem RJ Gibson, 01/11/2016 02:06 PM

Related issues

Is duplicate of FreeNAS - Bug #12927: Cannot enable LDAP anymoreResolved2015-12-27

History

#1 Updated by Josh Paetzel over 4 years ago

  • Is duplicate of Bug #12927: Cannot enable LDAP anymore added

#2 Updated by Josh Paetzel over 4 years ago

  • Status changed from Unscreened to Closed: Duplicate
  • Target version set to 261

The workaround in 12927 will work to get you back up and running.

#3 Updated by RJ Gibson over 4 years ago

Sadly that fix did not seem to work.

#4 Updated by Josh Paetzel over 4 years ago

  • Status changed from Closed: Duplicate to Unscreened
  • Priority changed from No priority to Important

#5 Updated by RJ Gibson over 4 years ago

Jan 11 15:43:41 LNKHOLDSNAS001 ldaptool: [common.freenasldap:197] FreeNAS_LDAP_Directory[ERROR]: An LDAP Exception occured
Jan 11 15:43:41 LNKHOLDSNAS001 ldaptool: [common.freenasldap:202] FreeNAS_LDAP_Directory[ERROR]: info: 'error:14090086:SSL routines:
SSL3_GET_SERVER_CERTIFICATE:certificate verify failed (self signed certificate in certificate chain)'
Jan 11 15:43:41 LNKHOLDSNAS001 ldaptool: [common.freenasldap:207] FreeNAS_LDAP_Directory[ERROR]: desc: 'Connect error'
Jan 11 15:43:41 LNKHOLDSNAS001 manage.py: [middleware.notifier:195] Executing: /usr/sbin/service ix-ldap status
Jan 11 15:43:41 LNKHOLDSNAS001 manage.py: [middleware.notifier:209] Executed: /usr/sbin/service ix-ldap status; returned 1

This is from /var/log/debug.log

The cert is not self signed. I have verified that the CA is shown correctyl through SSL: openssl s_client -connect ldap.jumpcloud.com:636

#6 Updated by John Hixson over 4 years ago

  • Status changed from Unscreened to Investigation

#7 Updated by Jordan Hubbard over 4 years ago

  • Assignee changed from John Hixson to Wojciech Kloska

#8 Updated by Jordan Hubbard over 4 years ago

  • Assignee changed from Wojciech Kloska to Erin Clark

#9 Updated by Erin Clark over 4 years ago

  • Status changed from Investigation to 15

Are you still having problems with this or did you find a way to resolve it? Supposedly this duplicated another issue that was marked for resolved so maybe an update will fix it?

#10 Updated by Jordan Hubbard over 4 years ago

  • Status changed from 15 to Closed

No feedback for 2 weeks - timing out and closing. Likely resolved.

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 261 to N/A

Also available in: Atom PDF