Project

General

Profile

Feature #1344

LOG_CRIT+ messages should be reported to root via alert system

Added by Anonymous over 9 years ago. Updated about 4 years ago.

Status:
Closed: Not To Be Fixed
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

I'd have to doublecheck whether or not samba uses the right severity, but in general any items that are a certain syslog(3) log priority should be passed along to root, so critical items can be tracked (say, disk failure? mps channel droppage? etc) and there will be a proper audit log to help articulate that there's a problem that needs resolving on the host system.

This is a touchy item as it can result in more support emails than necessary, so extensive testing with various failure conditions and soak testing will need to be applied. I do not recommend this for [[FreeNAS]] 8.2.0, but instead 8.3.0.

History

#1 Updated by Jordan Hubbard over 7 years ago

  • Assignee set to William Grzybowski
  • Target version set to 49

Hmm. Are they?

#2 Updated by William Grzybowski over 7 years ago

  • Status changed from Unscreened to Screened

Nope, they are not, but seems like messing with a viper nest.

#3 Updated by Cyber Jock over 7 years ago

Maybe add a checkbox to allow for log priority emails? Right now I haven't seen any conditions that require an email. Most everything I've gotten an email for has been from things such as SMART or UPS which are obvious. Or the problem is self-revealing before you could get the email.

But, this may be useful for people that want to troubleshoot an issue and actually get an email with the log entry containing errors.

#4 Updated by Jordan Hubbard almost 7 years ago

  • Status changed from Screened to Closed: Not To Be Fixed

I don't think there's any real plan (or reasonable notion to follow) for making logged events automatically pass to the alert system. We should improve the alerts rather than try to shoe-horn an inferior mechanism (syslog) into alerts.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF