Project

General

Profile

Bug #13691

Cannot create new boot enviroment

Added by s tnzx over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Important
Assignee:
Sean Fagan
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Got the latest stable release installed, and now there are 2 updates but everytime it says in green "unable to create new boot environment.

I've downgraded, reininstalled latest release, cleaned the boot and removed older versions, but still it keeps saying the same

History

#1 Updated by s tnzx over 4 years ago

  • File ixdiagnose.tgz added

#4 Updated by Sean Fagan over 4 years ago

  • Status changed from Unscreened to 15

Please do "beadm list" from the shell.

I suspect the issue is that the BE in question already exists, and is marked as next-boot. It won't let you delete it in that circumstance. You can fix this by, in the GUI, selecting the currently-mounted boot environment for next reboot, and then deleting the FreeNAS-9.3-STABLE-201602031011 boot environment.

#5 Updated by s tnzx over 4 years ago

I've deleted all old installations, is there a way to install an older 9.3 installation before the latest one to follow your steps?

#6 Updated by Sean Fagan over 4 years ago

If you've deleted everything, this should no longer be an issue. So I think I am not understanding you?

#7 Updated by s tnzx over 4 years ago

5115

I got no older versions in the boot/startup anymore only the latest one

see picture

#8 Updated by Sean Fagan over 4 years ago

Which means there should be no update available, so there should not be a problem. Right?

#9 Updated by s tnzx over 4 years ago

5116

these 2 updates are standing in the waiting line:

#10 Updated by Sean Fagan over 4 years ago

Please do the following from the shell, and cut and paste the output:

beadm list
ls /var/db/system/update
freenas-update -C /var/db/system/update check

#11 Updated by s tnzx over 4 years ago

beadm list
ls /var/db/system/update
freenas-update -C /var/db/system/update check

#12 Updated by s tnzx over 4 years ago

[root@STNZNAS ~]# beadm list
BE Active Mountpoint Space Created
Nickname
FreeNAS-9.3-STABLE-201602031011 NR / 1.0G 2016-02-05 19:14
FreeNAS-9.3-STABLE-201602031011
[root@STNZNAS ~]# ls /var/db/system/update
ChangeLog.txt
MANIFEST
SEQUENCE
SERVER
docs-9.3.1-STABLE-7eaae83.tgz
freenas-pkg-tools-9.3.1-STABLE-dc4105f.tgz
[root@STNZNAS ~]# freenas-update -C /var/db/system/update checkccc

#13 Updated by Sean Fagan over 4 years ago

There's missing output from the "freenas-update -C /var/db/system/update check" command.

#14 Updated by s tnzx over 4 years ago

Is that something I can fix?

thanks for all your help

#15 Updated by Sean Fagan over 4 years ago

When you ran "freenas-update -C /var/db/system/update check" there should have been output.

#16 Updated by s tnzx over 4 years ago

this is the output: bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share
/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'WR
tnEymiBqTEeFcCnRTAp09/ABWEdrmGPaZR5ezYXaY8bowS9ioN9pKYGNX71e+PKlZ050uRLG5ctEA4Ji
Nddt/pkUxAkPp8Zbj6vr38vKQwH0th25n8LVGEYMvZ8Ne64pbBN5ZUFVxSlIAvnwdSMr4O5xMZ5Pz7m+
I+UJS1fx0q+MKzP76t5szYUblC33aRszvWI1vlppMKxRtjKgjmKlk8ACjxIZVw+iyWJInJc04Mcn8xT0
Rwuw3RU8Bj9PjlBEPgLrSv8mLapwzJFFI8FuRInQBgNGICUIgbEPkiltO3NWousddRjwb4GaxmWYi6uZ
S1aYxhBRVIiSYfuohaew==', '-R', '/tmp/tmp70izC9.pem']
Signature check succeeded
TryGetNetworkFile(['https://web.ixsystems.com/updates/ix_crl.pem'])
TryGetNetworkFile(['https://web.ixsystems.com/updates/ix_crl.pem']): Read 1028
bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share
/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'WR
tnEymiBqTEeFcCnRTAp09/ABWEdrmGPaZR5ezYXaY8bowS9ioN9pKYGNX71e+PKlZ050uRLG5ctEA4Ji
Nddt/pkUxAkPp8Zbj6vr38vKQwH0th25n8LVGEYMvZ8Ne64pbBN5ZUFVxSlIAvnwdSMr4O5xMZ5Pz7m+
I+UJS1fx0q+MKzP76t5szYUblC33aRszvWI1vlppMKxRtjKgjmKlk8ACjxIZVw+iyWJInJc04Mcn8xT0
Rwuw3RU8Bj9PjlBEPgLrSv8mLapwzJFFI8FuRInQBgNGICUIgbEPkiltO3NWousddRjwb4GaxmWYi6uZ
S1aYxhBRVIiSYfuohaew==', '-R', '/tmp/tmpzU6xxp.pem']
Signature check succeeded
Upgrade package freenas-pkg-tools 9.3.1-STABLE-1becabb->9.3.1-STABLE-dc4105f
Upgrade package docs 9.3.1-STABLE-1becabb->9.3.1-STABLE-7eaae83
Reboot is (conditionally) not required
[root@STNZNAS ~]#

#17 Updated by Sean Fagan over 4 years ago

Okay. That's not all of the output, it seems, but it's enough.

Next two things to do:

manifest_util    sequence
manifest_util -M /var/db/system/update/MANIFEST sequence

Thanks!

#18 Updated by s tnzx over 4 years ago

[root@STNZNAS ~]# manifest_util sequence
FreeNAS-9.3-STABLE-201602031011
[root@STNZNAS ~]# manifest_util -M /var/db/system/update/MANIFEST sequenc
e
FreeNAS-9.3-STABLE-201602031011
[root@STNZNAS ~]#

is the output when I enter that into the shell

#19 Updated by Sean Fagan over 4 years ago

Okay.

I have no clue how you got into this state. It shouldn't happen. I'll look at improving the error handling here. But what's happening simply shouldn't be happening.

For my purposes, please attach two files from the system: /data/manifest and /var/db/system/update/MANIFEST

You should then be able to do

rm -rf /var/db/system/update
freenas-update -C /var/db/system/update check

and it should say nothing is available.

#20 Updated by s tnzx over 4 years ago

bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share
/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'WR
tnEymiBqTEeFcCnRTAp09/ABWEdrmGPaZR5ezYXaY8bowS9ioN9pKYGNX71e+PKlZ050uRLG5ctEA4Ji
Nddt/pkUxAkPp8Zbj6vr38vKQwH0th25n8LVGEYMvZ8Ne64pbBN5ZUFVxSlIAvnwdSMr4O5xMZ5Pz7m+
I+UJS1fx0q+MKzP76t5szYUblC33aRszvWI1vlppMKxRtjKgjmKlk8ACjxIZVw+iyWJInJc04Mcn8xT0
Rwuw3RU8Bj9PjlBEPgLrSv8mLapwzJFFI8FuRInQBgNGICUIgbEPkiltO3NWousddRjwb4GaxmWYi6uZ
S1aYxhBRVIiSYfuohaew==', '-R', '/tmp/tmpHzDMpm.pem']
Signature check succeeded
TryGetNetworkFile(['https://web.ixsystems.com/updates/ix_crl.pem'])
TryGetNetworkFile(['https://web.ixsystems.com/updates/ix_crl.pem']): Read 1028
bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share
/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'WR
tnEymiBqTEeFcCnRTAp09/ABWEdrmGPaZR5ezYXaY8bowS9ioN9pKYGNX71e+PKlZ050uRLG5ctEA4Ji
Nddt/pkUxAkPp8Zbj6vr38vKQwH0th25n8LVGEYMvZ8Ne64pbBN5ZUFVxSlIAvnwdSMr4O5xMZ5Pz7m+
I+UJS1fx0q+MKzP76t5szYUblC33aRszvWI1vlppMKxRtjKgjmKlk8ACjxIZVw+iyWJInJc04Mcn8xT0
Rwuw3RU8Bj9PjlBEPgLrSv8mLapwzJFFI8FuRInQBgNGICUIgbEPkiltO3NWousddRjwb4GaxmWYi6uZ
S1aYxhBRVIiSYfuohaew==', '-R', '/tmp/tmp6MgsMK.pem']
Signature check succeeded
Upgrade package freenas-pkg-tools 9.3.1-STABLE-1becabb->9.3.1-STABLE-dc4105f
Upgrade package docs 9.3.1-STABLE-1becabb->9.3.1-STABLE-7eaae83
Reboot is (conditionally) not required
[root@STNZNAS ~]#

#21 Updated by s tnzx over 4 years ago

don't know where to find the manifest docs for you

#22 Updated by Sean Fagan over 4 years ago

As I said: /data/manifest and /var/db/system/update/MANIFEST

#23 Updated by s tnzx over 4 years ago

don't know how to reach it and to give it to you, where can I get to that location?

#24 Updated by Sean Fagan over 4 years ago

You will have to copy the files somewhere you can get at them. Either to one of your shares, or via scp.

#25 Updated by s tnzx over 4 years ago

  • File MANIFEST added
  • File manifest_1 added

got them

#26 Updated by Sean Fagan over 4 years ago

  • Status changed from 15 to Investigation

sigh.

Getting a better handle on this.

#27 Updated by Sean Fagan over 4 years ago

  • Priority changed from No priority to Important

Okay, so here's what's going on: the fresh install has a particular set of package versions in it, and that's all it is. The software update that was created from it, however, did some work to minimize update steps. This is all behind the scenes, and I'm waving my hands a bit because it's complicated, but basically what it means is that the SU has a different version of the packages, because the older and newer versions of those packages turned out to be the same.

It's a bug, but not a huge problem, and it isn't a negative concern for you, and the next SU will fix it.

I believe what I'm going to need to do is either add in some support for the multiple versions that are the same, or to simply check the sequence string for the manifest, and do nothing else. I did that for a while, but then we changed it to check the package versions.

Now, if you want to work around it, you can

  1. Clone the current boot environment ("beadm create Temporary")
  2. Activate it ("beadm activate Temporary")
  3. Reboot
  4. Perform the software update.
  5. Reboot
  6. Get rid of the temporary one ("beadm destroy -F Temporary")

There's probably some simpler steps for it as well, but that should work.

And again: it's not really necessary, but I can understand wanting to do so.

#28 Updated by s tnzx over 4 years ago

Super, I'll just wait for the next SU

and thanks for looking into it!

Glad to be of bug service :)

Will keep you informed after the next SU update if all works!

#29 Updated by Jordan Hubbard over 4 years ago

  • Status changed from Investigation to Closed

Timing out and closing - over a month old and apparently fixed?

#30 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Seen in changed from Unspecified to N/A

#31 Updated by Dru Lavigne about 3 years ago

  • File deleted (ixdiagnose.tgz)

#32 Updated by Dru Lavigne about 3 years ago

  • File deleted (MANIFEST)

#33 Updated by Dru Lavigne about 3 years ago

  • File deleted (manifest_1)

#34 Updated by Dru Lavigne about 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

Also available in: Atom PDF