Project

General

Profile

Bug #13919

cann't find my ZFS Volume

Added by tom too over 4 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello,

I hope, that's the right way to tell you my problem. I'm a beginner in freenas. Please help me! I'm desperately!!!

My hardware:
Asus H97M-E
Intel Celeron G1820T
16GB DDR3
4x 3TB Seagate ST3000DM001

I use FreeNAS 9.3.0. Suddenly my freenas doesn't started correctly. A fault appear:

#################
KDB: enter: panic
[ thread pid 0 tid 101190 ]
Stopped at kdb_enter+0x3b: movq $0,0xd0b7d2(%rip)
db> #################

BTW, I have the same fault with my old 9.2 installation.

The 9.3.0 installation could start properly, if I disconnect my 4 HDs. After that, I installed 9.3.0 on new 8GB USB stick. Now, 9.3.0 starts, despite the 4 HDs are connected. But the problem is, that the new installation couldn't found the old volume. I tried "volume import" and select no encryption, but there's no volume appears to import. I know the old volume ID yet. But FreeNAS didn't find it!

What could I do?? FreeNAS must only find my existing ZFS-Volume! Not more.

The 4 harddrives are tested. They are okay. It tested the RAM memory with memtest86. Also OK.

Please, please, please help me!

Thanks in advance, tom.too

History

#1 Updated by tom too over 4 years ago

  • File ixdiagnose.tgz added

#2 Updated by Alexander Motin over 4 years ago

  • Status changed from Unscreened to Screened

Repeatable crashes during pool import usually tell about some pool corruption, most likely caused by using non-ECC RAM. I've looked through the provided debug info, but unfortunately can't see any problem there. Can you try to run `zpool import` command from the command line to see whether ZFS sees your pool? If yes, then what exactly happens when you are trying to import the pool via the WebUI?

#3 Updated by tom too over 4 years ago

Hello,

I have more information.

In standard configuration, FreeNAS 9.3 doesn't find my old volume "RAID_5". There are only 4 single HDs. If I import the last backuped configuration, the volume "RAID_5" appears. But it seems, the volume isn't linked to the hard disks. Can I link this manually?

zpool status
pool: freenas-boot
state: ONLINE
scan: none requested
config:

NAME STATE READ WRITE CKSUM
freens-boot ONLINE 0 0 0
da0p2 ONLINE 0 0 0

errors: No known data errors

#####

"gpart show" shows 4 identical HDs with this partitions:

freebsd-swap (2.0G)
freebsd-zfs (2.7T)

I think, that's correct. My volume wasn't encrypted.

Obviously, the HDs are physical okay, the other hardware too. Suddenly, FreeNAS is missing my ZFS pool. I don't comprehend, that the professional FreeNAS loses the connection between volume and HDs. Can I configure the connection manually again?

Thanks in advance, tom.too

#4 Updated by tom too over 4 years ago

[root@freenas ~]# zpool import
[root@freenas ~]#

The zpool is destroyed? No chance, to recover my data? Can you remote my system by teamviewer? Will that help?

#5 Updated by Alexander Motin over 4 years ago

If pool was destroyed without wiping the disks, you may try `zpool import -D` to show deleted pools.

#6 Updated by Jordan Hubbard over 4 years ago

  • Status changed from Screened to Closed: User Config Issue

Wouldn't a destroyed pool cause zpool status to come back with an error? What does zpool status say now?

In any case, I'm sorry to say that this is the bug tracking system for dealing with actual bugs in FreeNAS, which this is not. Please see the FreeNAS forum for tech support / help with scenarios like this one. Setting to User Configuration Issue.

#7 Updated by tom too over 4 years ago

[root@freenas ~]# zpool import -D
[root@freenas ~]#

###########################

Unfortunately not more...

###########################

zpool status
pool: freenas-boot
state: ONLINE
scan: none requested
config:

NAME STATE READ WRITE CKSUM
freens-boot ONLINE 0 0 0
da0p2 ONLINE 0 0 0

errors: No known data errors

###########################

Regrettably, the (german) user forum couldn't give a reliable statement. I only had the hope, that someone can help me, there knows every detail in FreeNAS.

Your defintive statement is "all data are destroyed"?

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Seen in changed from Unspecified to N/A

#9 Updated by Dru Lavigne about 3 years ago

  • File deleted (ixdiagnose.tgz)

#10 Updated by Dru Lavigne about 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

Also available in: Atom PDF