Project

General

Profile

Bug #141

/data mounted read-only on upgrading

Added by Oebele Drijfhout over 9 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Important
Assignee:
-
Category:
Middleware
Target version:
-
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

On upgrading from 5778 to 5788, the /data partition was mounted read-only, causing the upgrade scripts to fail. This necessitated me to do a full reinstall and, since there's no ZFS import functionality in the GUI yet, throw away all my data. (of course I have a backup, but it's still a pain to copy +3TB).

History

#1 Updated by Josh Paetzel over 9 years ago

  • Status changed from Unscreened to Closed

There's likely an underlying reason why the upgrade failed. 8.0-RC3 contains a volume importer.

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 5 years ago

Commit: 64d4d237716e50cfec50dd66acd6251433d658fd
https://github.com/pcbsd/freebsd-ports/commit/64d4d237716e50cfec50dd66acd6251433d658fd
Author: jmmv <>
Date: 2015-11-23 (Mon, 23 Nov 2015)

Log Message:
-----------
Update devel/kyua to 0.12.

Released on November 22nd, 2015.

This is a huge release and marks a major milestone for Kyua as it finally
implements a long-standing feature request: the ability to execute test
cases in parallel. This is a big deal because test cases are rarely
CPU-bound: running them in parallel yields much faster execution times for
large test suites, allowing faster iteration of changes during development.

As an example: the FreeBSD test suite as of this date contains 3285 test
cases. With sequential execution, a full test suite run takes around 12
minutes to complete, whereas on a 4-core machine with a high level of
parallelism it takes a little over 1 minute.

Implementing parallel execution required rewriting most of Kyua's core and
partly explains explains why there has not been a new release for over a
year. The current implementation is purely subprocess-based, which works
but has some limitations and has resulted in a core that is really complex
and difficult to understand. Future versions will investigate the use of
threads instead for a simplified programming model and additional
parallelization possibilities.

  • Issue #2: Implemented support to execute test cases in parallel when
    invoking `kyua test`. Parallel execution is only enabled when the new
    `parallelism` configuration variable is set to a value greater than `1`.
    The default behavior is still to run tests sequentially because some test
    suites contain test cases with side-effects that might fail when run in
    parallel. To resolve this, the new metadata property `is_exclusive` can
    be set to `true` on a test basis to indicate that the test must be run on
    its own.
  • Known regression: Running `kyua debug` on a TAP-based test program does
    not currently report the output in real time. The output will only be
    displayed once the test program completes. This is a shortcoming of
    the new parallel execution engine and will be resolved.
  • Removed the external C-based testers code in favor of the new built-in
    implementations. The new approach feels significantly faster than the
    previous one.
  • Fixed the handling of relative paths in the `fs.*` functions available
    in `Kyuafile`s. All paths are now resolved relative to the location of
    the caller `Kyuafile`. `Kyuafile.top` has been updated with these
    changes and you should update custom copies of this file with the new
    version.
  • Changed temporary directory creation to always grant search
    permissions on temporary directories. This is to prevent potential
    problems when running Kyua as root and executing test cases that require
    dropping privileges (as they may later be unable to use absolute paths
    that point inside their work directory).
  • The cleanup of work directories does not longer attempt to deal with
    mount points. If a test case mounts a file system and forgets to unmount
    it, the mount point will be left behind. It is now the responsibility of
    the test case to clean after itself. The reasons for this change are
    simplicity and clarity: there are many more things that a test case can
    do that have side-effects on the system and Kyua cannot protect against
    them all, so it is better to just have the test undo anything it might
    have done.
  • Improved `kyua report --verbose` to properly handle environment
    variables with continuation lines in them, and fixed the integration
    tests for this command to avoid false negatives.
  • Changed the configuration file format to accept the definition of
    unknown variables without declaring them local. The syntax version
    number remains at 2. This is to allow configuration files for newer Kyua
    versions to work on older Kyua versions, as there is no reason to forbid
    this.
  • Fixed stacktrace gathering with FreeBSD's ancient version of GDB.
    GDB 6.1.1 (circa 2004) does not have the `-ex` flag so we need to
    generate a temporary GDB script and feed it to GDB with `-x` instead.
  • Issue #136: Fixed the XML escaping in the JUnit output so that
    non-printable characters are properly handled when they appear in the
    process's stdout or stderr.
  • Issue #141: Improved reporting of errors triggered by sqlite3. In
    particular, all error messages are now tagged with their corresponding
    database filename and, if they are API-level errors, the name of the
    sqlite3 function that caused them.
  • Issue #144: Improved documentation on the support for custom properties
    in the test metadata.
  • Converted the `INSTALL`, `NEWS`, and `README` distribution documents to
    Markdown for better formatting online.

Approved by: bapt (mentor)
Differential Revision: https://reviews.freebsd.org/D4243

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 5 years ago

Commit: 61051bd0ecb5690f90f958d996f3cb4b0f201f97
https://github.com/pcbsd/freebsd-ports/commit/61051bd0ecb5690f90f958d996f3cb4b0f201f97
Author: dbn <>
Date: 2015-12-16 (Wed, 16 Dec 2015)

Log Message:
-----------
sysutils/py-plumbum: update to 1.6.0

Port Changes:
- Add test target using nosetests.
- Switch to GH distribution to get unit tests.
- Add pkg-plist (do not use autoplist generation)

Change Log:
- Added support for Python 3.5, PyPy, and better Windows and Mac support, with
CI testing (#218, #217, #226)
- Colors: Added colors module, support for colors added to cli (#213)
- Machines: Added .get() method for checking several commands. (#205)
- Machines: local.cwd now is the current directory even if you change the
directory with non-Plumbum methods (fixes unexpected behavior).
(#207)
- SSHMachine: Better error message for SSH (#211)
- SSHMachine: Support for FreeBSD remote (#220)
- Paths: Now a subclass of str, can be opened directly (#228)
- Paths: Improved pathlib compatibility with several additions and renames
(#223)
- Paths: Added globbing multiple patterns at once (#221)
- Commands: added NOHUP modifier (#221)
- CLI: added positional argument validation (#225)
- CLI: added envname, which allows you specify an environment variable for a
SwitchAttr (#216)
- CLI terminal: addded Progress, a command line progress bar for iterators and
ranges (#214)
- CLI: add invoke, which allows you to programmatically run applications (#149)
- CLI: add --help-all and various cosmetic fixes: (#125), (#126), (#127)
- CLI: add root_app property (#141)
- Machines: getattr now raises AttributeError instead of CommandNotFound (#135)
- Paramiko: keep_alive support (#186)
- Paramiko: does not support piping explicitly now (#160)
- Parmaiko: Added pure SFTP backend, gives STFP v4+ support (#188)
- Paths: bugfix to cwd interaction with Path (#142)
- Paths: read/write now accept an optional encoding parameter (#148)
- Paths: Suffix support similar to the Python 3.4 standard library pathlib
(#198)
- Commands: renamed setenv to with_env (#143)
- Commands: pipelines will now fail with ProcessExecutionError if the source
process fails (#145)
- Commands: added TF and RETCODE modifiers (#202)
- Experimental concurrent machine support in experimental/parallel.py
- Several minor bug fixes, including Windows and Python 3 fixes (#199, #195)

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 5 years ago

Commit: 61051bd0ecb5690f90f958d996f3cb4b0f201f97
https://github.com/pcbsd/freebsd-ports/commit/61051bd0ecb5690f90f958d996f3cb4b0f201f97
Author: dbn <>
Date: 2015-12-16 (Wed, 16 Dec 2015)

Log Message:
-----------
sysutils/py-plumbum: update to 1.6.0

Port Changes:
- Add test target using nosetests.
- Switch to GH distribution to get unit tests.
- Add pkg-plist (do not use autoplist generation)

Change Log:
- Added support for Python 3.5, PyPy, and better Windows and Mac support, with
CI testing (#218, #217, #226)
- Colors: Added colors module, support for colors added to cli (#213)
- Machines: Added .get() method for checking several commands. (#205)
- Machines: local.cwd now is the current directory even if you change the
directory with non-Plumbum methods (fixes unexpected behavior).
(#207)
- SSHMachine: Better error message for SSH (#211)
- SSHMachine: Support for FreeBSD remote (#220)
- Paths: Now a subclass of str, can be opened directly (#228)
- Paths: Improved pathlib compatibility with several additions and renames
(#223)
- Paths: Added globbing multiple patterns at once (#221)
- Commands: added NOHUP modifier (#221)
- CLI: added positional argument validation (#225)
- CLI: added envname, which allows you specify an environment variable for a
SwitchAttr (#216)
- CLI terminal: addded Progress, a command line progress bar for iterators and
ranges (#214)
- CLI: add invoke, which allows you to programmatically run applications (#149)
- CLI: add --help-all and various cosmetic fixes: (#125), (#126), (#127)
- CLI: add root_app property (#141)
- Machines: getattr now raises AttributeError instead of CommandNotFound (#135)
- Paramiko: keep_alive support (#186)
- Paramiko: does not support piping explicitly now (#160)
- Parmaiko: Added pure SFTP backend, gives STFP v4+ support (#188)
- Paths: bugfix to cwd interaction with Path (#142)
- Paths: read/write now accept an optional encoding parameter (#148)
- Paths: Suffix support similar to the Python 3.4 standard library pathlib
(#198)
- Commands: renamed setenv to with_env (#143)
- Commands: pipelines will now fail with ProcessExecutionError if the source
process fails (#145)
- Commands: added TF and RETCODE modifiers (#202)
- Experimental concurrent machine support in experimental/parallel.py
- Several minor bug fixes, including Windows and Python 3 fixes (#199, #195)

Also available in: Atom PDF