Project

General

Profile

Bug #14334

Avatar?id=14398&size=50x50

QA Testing: Jail operations ares failing with 500 Internal server error

Added by Kris Moore over 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Critical
Assignee:
Erin Clark
Category:
Middleware
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

freenas-jails-fail.png (339 KB) freenas-jails-fail.png FreeNAS 9.3 jails failure page Kris Moore, 03/29/2016 12:51 PM
5481

History

#1 Updated by Jordan Hubbard over 4 years ago

  • Status changed from Unscreened to 15

Ummm. I'm going to have to express great puzzlement here because the jail code has not changed in 9.3 for a very long time, certainly not any time in March (or even this year). I would understand if 9.10 was failing since that's had a whole bunch of changes, but you say that works.

I'm going to have to ask you to check the configuration of the 9.3 machine and make sure something else unrelated to jails has not changed such to break them on the test setup, since again, literally nothing has changed in the jail code in 9.3 for many many releases of 9.3 (possible even going all the way back to 9.3-RELEASE in 2014).

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

Yea, this is bizarre since I figured you guys weren't making big changes to 9.3 anymore. The only thing I can figure is maybe creating the new jail files for 9.10 on the mirrors messed something up? 9.10 still works fine though and its the exact same REST tests being run on both 9.3/9.10.

I'll double check my stuff here, but if you have any specific ideas where to look let me know.

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

5481

Ok, just for kicks I grabbed a copy of the latest FreeNAS 9.3, set it up in a VM and tried to go to the jails page. It fails immediately with a nice error message via the GUI also. (Attached)

There were a couple of commits done that triggered this build, and it looks like this one was the culprit:

https://github.com/freenas/freenas/commit/6025be2466fdb4647cdd63bf603f299ba622c5ac

#4 Updated by Jordan Hubbard over 4 years ago

  • Category changed from 38 to 20
  • Status changed from 15 to Unscreened
  • Assignee changed from Jordan Hubbard to Suraj Ravichandran
  • Priority changed from No priority to Critical

Looks like Suraj broke 9.3 with some networking changes!

#5 Updated by Suraj Ravichandran over 4 years ago

  • Assignee changed from Suraj Ravichandran to Erin Clark

#6 Updated by Suraj Ravichandran over 4 years ago

This happened when erin cherry picked some of my sipcalc changes without the consecutive ones (specifically 44c41ff8dad002b5a6dd0e44d7f6acdef4fe5898)

She has already done so and is currently testing hence giving the bug to her

#7 Updated by Erin Clark over 4 years ago

  • Status changed from Unscreened to 19

Tested sipcalc.py on 9.3-STABLE, reproduced the problem with the version prior to cherry-picking the fix over and confirmed fix after copying it back over, going to put in Build Testing since it hasn't been tested on an actual build yet

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Status changed from 19 to Resolved

Jenkins confirms the fix. Thanks!

#9 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF