Project

General

Profile

Bug #14463

ixgbe kernel panic

Added by Josh Paetzel over 4 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Chris Torek
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

History

#1 Updated by Chris Torek over 4 years ago

  • Status changed from Unscreened to Screened

It's seriously-non-obvious what is happening here.

The ixgbe driver is waiting for a lock (that part is non-controversial :-) ) and it's therefore
waiting on a turnstile so it's trying to bump priority on another thread. To do so it's trying
to lock the other thread:

thread_lock_flags_() at thread_lock_flags_+0x31b/frame 0xfffffe085f553150
propagate_priority() at propagate_priority+0xa9/frame 0xfffffe085f553180
turnstile_wait() at turnstile_wait+0x3fe/frame 0xfffffe085f5531d0
__mtx_lock_sleep() at __mtx_lock_sleep+0x26b/frame 0xfffffe085f553250
ixgbe_setup_receive_structures() at ixgbe_setup_receive_structures+0x7d/frame 0xfffffe085f5532f0

The thread_lock_flags code has to lock td->td_lock (td is the other thread, the one holding the turnstile in this case) and is spinning on that, and timing out. I wonder what other thread this is, we can't see that from the panic itself.

The WITNESS code might give some clues here, if we turned that on (it's kind of expensive CPU-wise and very noisy with all the LORs though).

#2 Updated by Vaibhav Chauhan almost 4 years ago

BRB: is this still an issue or this bug can be closed out ?

#3 Updated by Chris Torek almost 4 years ago

Do we have a reproducer for this?

#4 Updated by Josh Paetzel almost 4 years ago

No. This was a one off. Feel free to close.

#5 Updated by Chris Torek almost 4 years ago

  • Status changed from Screened to Closed: Cannot reproduce

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

#7 Updated by Dru Lavigne almost 3 years ago

  • File deleted (textdump.tar.0.gz)

Also available in: Atom PDF