Project

General

Profile

Bug #14638

Default route not set by DHCP after upgrading to 9.10

Added by Tom H over 4 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
-
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Supermicro A1SAi-2750F | 2 × 8 GB Crucial ECC DDR-1600 SO-DIMM
6 × 2 TB WD Green drives (RAIDZ2) | SanDisk Fit 16 GB USB Stick
SeaSonic SSR-450RM PSU

ChangeLog Required:
No

Description

After updating from 9.3.x to 9.10 (currently FreeNAS-9.10-STABLE-201604111739 896cc83) the default gateway provided by my router via DHCP is not registering in FreeNAS. In the Network -> Network Summary page of the GUI, the "Default route" field is blank.

A symptom of this is that when I restart any of my jails from the FreeNAS GUI, they do not get an IP address. However, I can use the command "dhclient epair[n]" to get an IP via DHCP from the jail's command line. The jails also receive the correct IPs when FreeNAS is [re]booted, it's just on a jail restart after booting that this does not occur.

Here is an example error message when I try to rstart a jail:

Mar 30 00:26:56 nas manage.py: [freeadmin.navtree:621] An error occurred while unserializing from http://192.168.1.206/plugins/crashplan/1/_s/treemenu: No JSON object could be decoded

I can avoid the problem by manually configuring the IPv4 Default Gateway in Network -> Global Configuration but I expect this to be set by DHCP (please tell me if this is not correct).

This network configuration was working prior to 9.10 and the default gateway is set via DHCP on all the other clients on the LAN.

History

#1 Updated by Tom H over 4 years ago

Additionally: I did not delete my jails dataset when I upgraded from 9.3.1, so (I presume) they are using the FreeBSD 9.3 template.

#2 Updated by Jordan Hubbard over 4 years ago

  • Assignee set to Anonymous
  • Target version set to Unspecified

#3 Updated by Anonymous over 4 years ago

  • Assignee changed from Anonymous to Anonymous

#4 Updated by Anonymous over 4 years ago

  • Status changed from Unscreened to Screened

#5 Updated by Brad B. over 4 years ago

My apology for chipping in. Not intending to treat this bug tracking system like a "forums", but I would just like to add that I too have had this issue with the exception that I completely reformatted my OS hardware devices and I did a completely fresh new install using the FreeNAS 9.10 ISO, I didn't upgrade... Hardware as follows; OS Drives: 2 x SSD-DM016-PHI (mirrored), MOBO: Supermoicro X10SRI-F, CPU: Intel Xeon E5-2620v3, Memory: Samsung M393A1G40DB0-CPB 8GB DDR4 2133 ECC x 2 (16Gb total).

#6 Updated by Federico Castagnini over 4 years ago

I am experiencing the same issue, rebooting the server will assign an ip address to every jail, but a restart of the jail will run into the problem again.
Running FreeNAS-9.10-STABLE-201604181743 (74ef270)

This problem is referenced in the tickets 12222, 14979 and 14832

#7 Updated by Anonymous over 4 years ago

  • Status changed from Screened to Investigation

In my case I could see the same ip persisting under Network->Network Summary->Default Router. let me try with jails.

#8 Updated by Anonymous over 4 years ago

  • Status changed from Investigation to Closed: Cannot reproduce

Somehow couldn't observe the jail symptom mentioned here. But every time I update 9.3 to 9.10 I can see default route (Network->Network summary) persists and with no issues accessing internet and intranet.

#9 Updated by Tom H over 4 years ago

Thanks for looking into it.

How strange, I just double checked and the problem still exists for me.

Several people on the FreeNAS forums have mentioned problems with jails and DHCP, would it be helpful to provide some links to those threads?

Otherwise let me know if there's any more debugging info I can provide.

#10 Updated by Anonymous over 4 years ago

I tried this on different hardware as well with different network setup offcourse. Still no issue with default route. Can you please check with different setup(hardware and network) once?

#11 Updated by Marcus S over 4 years ago

Kaustubh Dhokte wrote:

I tried this on different hardware as well with different network setup offcourse. Still no issue with default route. Can you please check with different setup(hardware and network) once?

I'm experiencing the same exact issue on a Lenovo TS140. Brand new install of 9.10. There's a thread where many others are experiencing the same symptom:

https://forums.freenas.org/index.php?threads/jail-not-working-with-dhcp.42310/

#12 Updated by Tom H over 4 years ago

Just to update, discussion has continued in at least two forum threads (https://forums.freenas.org/index.php?threads/jail-not-working-with-dhcp.42310/ and https://forums.freenas.org/index.php?threads/no-ip-from-dhcp-on-jails.43599/) and a new bug report has been opened, where several other users seem to be having the same problem: https://bugs.freenas.org/issues/15718

#13 Updated by Joseph Gorse over 4 years ago

FWIW, I see this default route issue coming from 9.3 to 9.10 on the FreeNAS Mini hardware for a custom jail with static IPv4 configuration.

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF