Project

General

Profile

Bug #14687

API is not adding default IP adress for new Jails

Added by Klaus Deja over 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When creating a new jail via the freenas WebGUI without any data than the jail name, the new jail will get a default IPv4 adress and subnetmask assigned.
When creating a new jail via the API, it won't get this default IP assigned.

I don't know if this is expected behaviour or a bug. I assumed creation of a new jail via API would behave same as in the WebGUI.

Associated revisions

Revision 29c5bb97 (diff)
Added by William Grzybowski almost 3 years ago

fix(api): set ipv4 or dhcp when creating jail

Ticket: #14687

Revision 688c2f5a (diff)
Added by William Grzybowski almost 3 years ago

fix(api): set ipv4 or dhcp when creating jail

Ticket: #14687
(cherry picked from commit 29c5bb97d17b826239df5529acead24c4f9d00a4)

Revision c68dfcd0 (diff)
Added by William Grzybowski almost 3 years ago

fix(api): set ipv4 or dhcp when creating jail

Ticket: #14687
(cherry picked from commit 29c5bb97d17b826239df5529acead24c4f9d00a4)

History

#1 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 49

#2 Updated by Jordan Hubbard over 3 years ago

  • Category changed from Middleware to 38
  • Assignee changed from William Grzybowski to Suraj Ravichandran
  • Target version changed from 49 to Unspecified

BRB: The right fix is to select DHCP by default.

#3 Updated by Suraj Ravichandran about 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Suraj Ravichandran to Anonymous

Over to Neha, to work on, she asked for tickets on slack

@Neha please slack pm me if you have any questions as to how to go about making default jail ip assignment behaviour dhcp and as well as clean up the manual ip setting routines in jail gui code.

#4 Updated by Anonymous about 3 years ago

  • Status changed from Unscreened to Screened

#5 Updated by Anonymous about 3 years ago

  • Status changed from Screened to Fix In Progress

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Target version changed from Unspecified to 9.10.1-U1

#7 Updated by Dru Lavigne almost 3 years ago

Will this PR happen in time to make it into U1?

#8 Updated by Suraj Ravichandran almost 3 years ago

  • Target version changed from 9.10.1-U1 to 9.10.1-U2

@Neha proposed a solution wherein we default to DHCP for all newly created jails henceforth with the option of letting the user manually specify the ip and everything.

This solution would have also satisfied the above ticket however, she discussed with some of us and we all found it ok. I still wanted John's opinion on it since he is primary on Jails & Plugins, and John has some issues with the fix which we are yet to discuss and resolve, so I do not know if we can get this in by U1, thus, moving target to 9.10.1-U2 for now will get it back in U1 if we are done earlier.

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Target version changed from 9.10.1-U2 to 9.10.1-U3

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Category changed from 38 to Middleware
  • Assignee changed from Anonymous to William Grzybowski
  • Target version changed from 9.10.1-U3 to 9.10.2

#11 Updated by William Grzybowski almost 3 years ago

  • Status changed from Fix In Progress to Needs Developer Review

#12 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Suraj Ravichandran

#13 Updated by Suraj Ravichandran over 2 years ago

  • Status changed from Needs Developer Review to Reviewed
  • Assignee changed from Suraj Ravichandran to William Grzybowski

My only suggestion here is to add ipv6 autoconfigure to the API hydrate routine (but discussed this with william and we both went "meh")

Other than that this is pretty straightforward so marking as reviewed.

#14 Updated by Suraj Ravichandran over 2 years ago

  • % Done changed from 0 to 100

#16 Updated by Vaibhav Chauhan over 2 years ago

  • Status changed from Reviewed to Ready For Release

#17 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF