Project

General

Profile

Bug #14691

rsync: did not see server greeting

Added by Jon Speegle over 3 years ago. Updated almost 3 years ago.

Status:
Closed: Behaves correctly
Priority:
No priority
Assignee:
-
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I was directed by dlavigne in a forum post on this issue to create a bug report. was building up a new FreeNAS box today and decided to load up 9.10 for the first time (have been using 9.3). Everything seems to work so far but rsync. I rsynced to the 9.3 box just fine, but when I try to do it to the 9.10 server I get the following errors:

(cwsync on Windows 2012) (command: rsync -v /cygdrive/c/temp/* 10.16.1.245::rsync/test/temp)
rsync: did not see server greeting
rsync error: error starting client-server protocol (code5> at main.c(1648) [sender=3.1.2]

(rsync on Ubuntu 14.04) (command: rsync -v /home/administrator/* 10.16.1.245::rsync/test/temp)
rsync: did not see server greeting
rsync error: error starting client-server protocol (code 5> at main.c(1653) [sender=3.1.0]

I think this has to be a bug as the command works to a FreeNAS 9.3 system. Also I made sure my FreeNAS 9.10 configuration was identical to what I have on 9.3. Attached is my debug from the 9.10 box.

History

#1 Updated by Jordan Hubbard over 3 years ago

  • Assignee set to Suraj Ravichandran

#2 Updated by Suraj Ravichandran over 3 years ago

  • Status changed from Unscreened to Screened
  • Target version set to Unspecified

#3 Updated by Jordan Hubbard over 3 years ago

BRB: Do you happen to know what versions of rsync is on the windows and ubuntu sides?

#4 Updated by Jon Speegle over 3 years ago

ubuntu is 3.1.0 and windows is 3.1.2

#5 Updated by Jon Speegle over 3 years ago

protocol 31 for both

#6 Updated by Alexandre Paradis about 3 years ago

I have the same issue, but between 2 freenas box.

Everything was fine until i upgraded to version FreeNAS-9.10-STABLE-201606072003 (696eba7) on both of them.

log that i have in /var/log/messages :

Jun 21 21:01:39 freenas rsync: rsync: did not see server greeting
Jun 21 21:01:39 freenas rsync: rsync error: error starting client-server protocol (code 5) at main.c(1662) [sender=3.1.2]

#7 Updated by Suraj Ravichandran about 3 years ago

ok let me try and set it up again (rsync transfer between two freenas boxes) on FreeNAS-9.10-STABLE-201606072003 but I will probably not be able to get back before Monday.

#8 Updated by Suraj Ravichandran about 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Suraj Ravichandran to Anonymous

Over to calsoft team

#9 Updated by Anonymous about 3 years ago

  • Assignee changed from Anonymous to Anonymous

#10 Updated by Anonymous about 3 years ago

  • Status changed from Unscreened to Screened

#11 Updated by Anonymous about 3 years ago

  • Status changed from Screened to Investigation

#12 Updated by Anonymous about 3 years ago

  • Status changed from Investigation to 15

Hi Jon, the problem in your case is the module name. So by description, I understand that you are using rsync over module and the section name here is 'rsync/test/temp'. But rsync does not allow you to have '/' character in the section name in your rsyncd config file. You can see it in the source code of rsync https://git.samba.org/rsync.git/?p=rsync.git;a=blob;f=loadparm.c;h=6d75b4dd58264df657886eb1ba1d81d35a384f21;hb=HEAD#775 at line 775.

if (strchr(sectionname, '/') != NULL) {
                rprintf(FLOG, "Warning: invalid section name in configuration file: %s\n", sectionname);
                return False;         
}

I tried with similar module name (in your case 'rsync/test/temp') and see same error

rsync: did not see server greeting

on ubuntu side. And on freenas side(destination) the logs are,

2016/07/07 04:21:02 [76661] Warning: invalid section name in configuration file: mnt/vol1/rsyncdest
2016/07/07 04:21:02 [76661] params.c:pm_process() - Failed. Error returned from params.c:parse().

This confirms that the presence of '/' is the issue.

and if I do removing '/' (in your case 'rsynctesttemp') it works absolutely fine.

I tried this only from Ubuntu.

Jon, can you please try changing the module name in rsyncd.conf and see if it works?
@Alexandre Paradis: Can you too please check if the configuration at your side contains something like this?

If the issue still persists, can you please provide following information.
1. Exact commands used for rsync
2. rsync config file /usr/local/etc/rsyncd.conf
3. Rsync Logs. (you can generate log file by adding "log file = <path to log file>" line to FreenasUI->Services->Rsync Settings-> Auxillay Parameters or by adding it directly to /usr/local/etc/rsyncd.conf and restarting rsync service)

#13 Updated by Vaibhav Chauhan about 3 years ago

  • Target version changed from Unspecified to 9.10.2

moving this to 9.10.2

#14 Updated by Anonymous almost 3 years ago

  • Status changed from 15 to Closed: Behaves correctly

With available information it seems that the issue is occurring because of the slash ('/') (as mentioned in my previous comment) whose validation is already there in freenas rsync module creation form (which also successfully validates and blocks the mentioned module name string 'rsync/test/temp' to go into rsync config) in FreeNAS GUI. Also talked to Suraj about this. Hence closing.

#15 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-freenas0-20160414092613.tgz)

Also available in: Atom PDF