Project

General

Profile

Bug #14706

Error: "kernel: Failed to write core file for process python2.7 (error 14)"

Added by Greg DePasse over 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
No priority
Assignee:
Sean Fagan
Category:
OS
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After applying the 9.3.1-Stable-201604140566 on 2 different machines both became inaccessible via the console, ssh and the webgui. The subject error continuously repeated on the screen. I had to roll back to the previous boot environment (9.3.1-Stable-201604120241) to recover, so I was unable to get any logs or debugging info.

Capture1.PNG (166 KB) Capture1.PNG Greg DePasse, 04/14/2016 01:55 PM
5679

History

#1 Updated by Sean Fagan over 4 years ago

  • Status changed from Unscreened to Screened

grr. sigh. Okay, I haven't seen this, so let's try something that has worked before with something like this:

  1. From the boot selector, select 9.3.1-Stable-201604140566
  2. Boot single-user, press enter when it asks for which shell.
  3. Run "mount -u /; mount /boot/grub"
  4. Then do "beadm activate FreeNAS-9.3.1-Stable-201604120241"
  5. Then "shutdown -r now"

N.B. I am attempting to reproduce this now, just in case.

Meanwhile, other questions to ask are whether you have disk space, and make sure there are no errors with the pool (doing "zpool scrub freenas-boot" from the previous environment, and then "zpool status freenas-boot" to check on it).

The fact that it reproduces on two different machines troubles me greatly.

#2 Updated by Sean Fagan over 4 years ago

Still cannot reproduce.

#3 Updated by John Higham over 4 years ago

Experienced same issue/error after attempting to apply update today. Do not believe update finished successfully? Machine was still displaying update in progress box on web GUI after several hours while Error: "kernel: Failed to write core file for process python2.7 (error 14)" was displayed. Rebooted machine. Machine unresponsive with same error being displayed. Rebooted machine. Reverted to older boot and now performing normally. Ran scrub and status on boot. Negative issues found.

#4 Updated by Sean Fagan over 4 years ago

Right. Let's try something.

Boot into 9.3.1-Stable-201604140566. Normal boot into it (as you've already done, John Higham). After doing this, you'll want to make it the default one, by using "beadm activate FreeNAS-9.3.1-Stable-201604140566". Then let's get rid of the new one, whih should be called FreeNAS-9.3.1-Stable-201604120241 (you can verify with "beadm list"), by doing "beadm destroy -F FreeNAS-9.3.1-Stable-201604120241".

Then we get a bit creative:

rm -rf /var/db/system/update
freenas-update -C /var/db/system/update check
freenas-update -C /var/db/system/update update --reboot

After that, assuming it completes without error, reboot the system.

I'm going to try to reproduce it again, making sure I have the right version to start with.

#5 Updated by Sean Fagan over 4 years ago

If you want to wait until I come back with an additional comment about this, please feel free, I won't feel slighted :).

#6 Updated by Sean Fagan over 4 years ago

Okay! Good thing I mentioned waiting.

So, do everything I said above, except with the -R / --reboot option.

I started with an initial install of 9.3.1-Stable-201604120241, upgraded to 9.3.1-Stable-201604140566, had the reported problem. I have changed the manifest on the update, so re-downloading it again will avoid the problem.

#7 Updated by Greg DePasse over 4 years ago

sorry, I got sidetracked with some other stuff last night. I saw from jkh's forum post that there was an issue with it being "rebootless" or something. After reverting to a previous BE yesterday and applying the new update this morning, all seems to be back to normal.

If you need anymore info for this though, please let me know.

#8 Updated by Sean Fagan over 4 years ago

  • Status changed from Screened to Resolved

Gonna mark this one as resolved, but there's ongoing discussions about it.

#9 Updated by John Higham over 4 years ago

Updated via web GUI to FreeNAS-9.10-STABLE-201604140622 (8781269) from FreeNAS-9.3-STABLE-201604041648. No issues.

#10 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF