Project

General

Profile

Bug #14925

Qlogic 8214 10Gb ethernet fails in in freenas 9.10

Added by hans magnusson over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Important
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Repeated error message after installing 9.10. Version 9.3 worked OK. Ethernet adapter 8214.

qla_dump_buf8: qla_hw_send: wrong pkt dump end
qla_hw_send: (nsegs[1, 427, 0x2<CSUM_IP_UDP>] > Q8_TX_MAX_SEGMENTS)
qla_dump_buf8: qla_hw_send: wrong pkt 0x1ab dump start

History

#1 Updated by Alexander Motin over 4 years ago

  • Status changed from Unscreened to 15
  • Priority changed from No priority to Important
  • Target version set to Unspecified

Unfortunately we have no such hardware and so can not reproduce the bug. From quick code reading it looks like something went wrong with TSO support. I've found one small potentially related commit in FreeBSD stable/10 and merged it to nightly branch (91d0e8e). It would be good if you could try the next nightly build and report whether it helps.

I guess you may also workaround the problem by adding -tso option to the interface configuration. It may increase CPU usage, but hopefully workaround the issue.

#2 Updated by hans magnusson over 4 years ago

I'll be happy to try out the work around. One question about -tso. Does it go in the gui/network/options field or in one of the several /etc/ files?

#3 Updated by Alexander Motin over 4 years ago

hans magnusson wrote:

One question about -tso. Does it go in the gui/network/options field or in one of the several /etc/ files?

Yes, -tso should go into "Options" field of the interface settings form in WebUI. But please, start from updating.

#4 Updated by hans magnusson over 4 years ago

I updated with today 9.10 Nightlies dcdcaad6af8d... In addition I had -tso in the options for the qlogic interface. The symptoms are the same as earlier in 9.3. After spewing lots of messages on the screen the system reboots. I made the assumption that you wanted me to try 9.10 nightly, but the nightly branch 91d0e8e you mentioned I don't know where to find.

#5 Updated by Chad Jannusch over 4 years ago

I'm having the same problem with a similar Qlogic card using the same driver. Neither the -tso nor latest 9.10 nighties fix it. It looks like I'm not seeing the error in the 10 nighties but there are other problems there so for now I'm just going to revert to 9.3. Please let me know if there's any info I can provide to help get this resolved.

#6 Updated by Adam Dake over 4 years ago

I'm also having this error with a Qlogic card after updating to 9.10 from 9.3.

I'm not sure if it's relevant, but I first got the error in 9.3 when I tried to switch one of the ports to 9000 MTU. I tried 4500 MTU, but got the same result. Leaving the MTU at the default 1500 seems to be my only option.

I've reverted to 9.3 for now. The main reason I was updating to 9.10 was for the improved VMWare Snapshot behavior.

#7 Updated by Chad Jannusch over 4 years ago

Hmm. Our MTU is set to 1500 and I was seeing problems. I can't remember what card we have for sure, but I believe it's a Qlogic 8200.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Status changed from 15 to Closed

Timing out

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF