Project

General

Profile

Bug #14934

Minor error in API documentation

Added by Jeff Mueller over 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The documentation states:

Example request:
GET /api/v1.0/storage/snapshot/ HTTP/1.1
Content-Type: application/json

Query Parameters:
offset – offset number. default is 0
limit – limit number. default is 30

The default limit is actually 20.
Overriding the "limit" query parameter works as expected.
A one-character documentation fix is needed :)


Related issues

Is duplicate of FreeNAS - Bug #14980: Reopened - Minor error in API documentationClosed: Duplicate2016-04-26

Associated revisions

Revision f9782d1c (diff)
Added by William Grzybowski over 4 years ago

Default limit is 20 Ticket: #14934

History

#1 Updated by Dru Lavigne over 4 years ago

  • Category changed from Documentation to Middleware
  • Assignee changed from Dru Lavigne to William Grzybowski
  • Priority changed from No priority to Nice to have

#2 Updated by William Grzybowski over 4 years ago

  • Status changed from Unscreened to Ready For Release
  • Target version set to 261

#3 Updated by Vaibhav Chauhan over 4 years ago

  • Target version changed from 261 to 9.10-STABLE-201604261518

#4 Updated by Vaibhav Chauhan over 4 years ago

  • Status changed from Ready For Release to Resolved

#5 Updated by Jeff Mueller over 4 years ago

  • Target version deleted (9.10-STABLE-201604261518)
  • Start date deleted (04/24/2016)
  • Seen in changed from 9.10-STABLE-201604181743 to 9.10-STABLE-201604261518

Please correct me if I'm wrong, but this bug is still not fixed in FreeNAS-9.10-STABLE-201604261518 (881b70d), even though it was in the release notes.

API example (PowerShell):
-------------------------------------------------------------------------------
PS C:\WINDOWS\system32> (Invoke-RestMethod Uri "http://freenas./api/v1.0/storage/snapshot/" -ContentType "application/json" -Method Get -Credential $cred).Count
20
-------------------------------------------------------------------------------

"limit" still says "30" in the documentation:
http://api.freenas.org/resources/storage.html#snapshot

#6 Updated by William Grzybowski over 4 years ago

It was committed, just not updated in the url yet.

#7 Updated by William Grzybowski over 4 years ago

  • Is duplicate of Bug #14980: Reopened - Minor error in API documentation added

#8 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF