Project

General

Profile

Bug #15052

Unable to upgrade, middleware error

Added by Torkil Svensgaard over 4 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Sean Fagan
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Upgrade to either 9.3 latest or 9.10 fails with:

Apr 29 10:16:55 storage1 updated.py: [freenasOS.Update:1279] Update got exception during update: Cannot remove file /home
Apr 29 10:17:04 storage1 manage.py: [middleware.exceptions:37] [MiddlewareError: Cannot remove file /home]
Apr 29 10:20:35 storage1 updated.py: [freenasOS.Update:1279] Update got exception during update: Cannot remove file /home
Apr 29 10:20:45 storage1 manage.py: [middleware.exceptions:37] [MiddlewareError: Cannot remove file /home]
Apr 29 10:20:56 storage1 manage.py: [middleware.exceptions:37] [MiddlewareError: [Errno 22] Invalid argument: '/home']
Apr 29 10:25:40 storage1 updated.py: [freenasOS.Update:1279] Update got exception during update: Cannot remove file /home
Apr 29 10:25:48 storage1 manage.py: [middleware.exceptions:37] [MiddlewareError: Cannot remove file /home]

History

#1 Updated by Torkil Svensgaard over 4 years ago

  • File ixdiagnose.tgz added

#2 Updated by William Grzybowski over 4 years ago

  • Assignee changed from William Grzybowski to Sean Fagan

Thats weird, I didn't know /home was even part of it. Sean?

#3 Updated by Sean Fagan over 4 years ago

  • Status changed from Unscreened to 15

I don't see it in /data/pkgdb/freenas-db on my 9.10-STABLE, 9.10-Nightlies, and 9.3-STABLE systems.

Can you do

sqlite3 /data/pkgdb/freenas-db 'select * from files where path like "/home%"'

and include the output?

#4 Updated by Torkil Svensgaard over 4 years ago

[root@storage1] ~# sqlite3 /data/pkgdb/freenas-db 'select * from files where path like "/home%"'
base-os|/home|slink|470b7c7b2fb58064c9d0ded935c32bc5296edb33f251419553ed14f4a04b5c8d|0|0|0|493
[root@storage1] ~#

#5 Updated by Sean Fagan over 4 years ago

So that's utterly bizarre. However, it looks like /home is a directory and the pkgdb expect it to be a symlink.

Easiest thing to do is

sqlite /data/pkgdb/freenas-db "delete from files where path = '/home'"

I'm guessing that /home got turned into a directory by creating a user? But I don't really know, and this is the first report I've seen of this.

#6 Updated by Josh Paetzel over 4 years ago

There's another bug for this to unify the handling of /home

Depending on whether you are using LDAP, AD, or local users /home can be a symlink or a real directory.

#7 Updated by Sean Fagan over 4 years ago

Yeah, but other than an ISO install, we can't fix that. And we seem to have removed /home from the template for 9.3, 9.10, and 10. Probably for just this reason.

#8 Updated by Torkil Svensgaard over 4 years ago

Sean Fagan wrote:

Easiest thing to do is

sqlite /data/pkgdb/freenas-db "delete from files where path = '/home'"

Thanks, that fixed it. I'm now on 9.10

I'm guessing that /home got turned into a directory by creating a user? But I don't really know, and this is the first report I've seen of this.

I only have LDAP users btw, in regard to the other comments.

#9 Updated by Sean Fagan over 4 years ago

  • Status changed from 15 to Closed: Cannot reproduce

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Seen in changed from Unspecified to N/A

#11 Updated by Dru Lavigne about 3 years ago

  • File deleted (ixdiagnose.tgz)

#12 Updated by Dru Lavigne about 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

Also available in: Atom PDF