Project

General

Profile

Bug #15083

SSL Certificate chains appear to be saving incorrectly

Added by Richard Ward over 4 years ago. Updated about 4 years ago.

Status:
Closed: Duplicate
Priority:
Nice to have
Assignee:
Suraj Ravichandran
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

As mentioned in the forum: https://forums.freenas.org/index.php?threads/ssl-certificate-chains-not-saving.43105/

A chained certificate as entered in the WebUI appears fine on reboot, however in nginx conf, only the first certificate appears to save, subsequent ones appear to have been truncated.
Even manually updating the file through ssh / nano - the behaviour is the same on reboot.


Related issues

Is duplicate of FreeNAS - Bug #9879: Importing a Certificate that includes the full chain causes the wrong certificate to be savedResolved2015-05-20

History

#1 Updated by Suraj Ravichandran over 4 years ago

  • Status changed from Unscreened to Screened

Will investigate today

#2 Updated by Jordan Hubbard over 4 years ago

  • Priority changed from No priority to Nice to have
  • Target version set to 261

#3 Updated by Suraj Ravichandran over 4 years ago

  • Is duplicate of Bug #9879: Importing a Certificate that includes the full chain causes the wrong certificate to be saved added

#4 Updated by Suraj Ravichandran over 4 years ago

  • Status changed from Screened to Closed: Duplicate

#5 Updated by Suraj Ravichandran over 4 years ago

Added @Richard Ward and @Dan Brown as watchers on the original bug that this duplicates.

Note: Found 2 Dan Brown Profiles and added both of them to the watcher list on that bug.

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 261 to N/A

Also available in: Atom PDF