Project

General

Profile

Bug #15135

Fiber Channel issues with 9.10

Added by Matthew Bein over 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Alexander Motin
Category:
OS
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After upgrade to 9.10 iscsi target disappear and ESX is unable to see the datastores. When scanning from the ESX systems a message is appearing on the console

isp_target_put_entry: Request Queue Overflow

Cannot break out of this above error message from the console and a hard reboot is required to get past this issue.

Qlogic Fiber Channel 2532's are being detected and issue seems to be related to the iscsi configuration.

20160503_163430_001.jpg (345 KB) 20160503_163430_001.jpg Matthew Bein, 05/03/2016 04:33 PM
5895

Related issues

Has duplicate FreeNAS - Bug #15134: Fiber Channel iSCSI issues with 9.10Closed: Duplicate2016-05-03

Associated revisions

Revision 5d75be64 (diff)
Added by Alexander Motin over 4 years ago

Fix FCP_CMD LENGTH mask in ATIO7 IOCB. This caused "long IU length (16384) ignored" errors following by others. Ticket: #15135 (cherry picked from commit 151759b71b72333b01ca1c567e20e1bf57f62753)

Revision 5d75be64 (diff)
Added by Alexander Motin over 4 years ago

Fix FCP_CMD LENGTH mask in ATIO7 IOCB. This caused "long IU length (16384) ignored" errors following by others. Ticket: #15135 (cherry picked from commit 151759b71b72333b01ca1c567e20e1bf57f62753)

Revision 4d21c91f (diff)
Added by Alexander Motin over 4 years ago

Fix FCP_CMD LENGTH mask in ATIO7 IOCB. This caused "long IU length (16384) ignored" errors following by others. Ticket: #15135 (cherry picked from commit 151759b71b72333b01ca1c567e20e1bf57f62753) (cherry picked from commit 5d75be6468ec7db125ca6cf71cc0c6fe70952dc9)

Revision 4d21c91f (diff)
Added by Alexander Motin over 4 years ago

Fix FCP_CMD LENGTH mask in ATIO7 IOCB. This caused "long IU length (16384) ignored" errors following by others. Ticket: #15135 (cherry picked from commit 151759b71b72333b01ca1c567e20e1bf57f62753) (cherry picked from commit 5d75be6468ec7db125ca6cf71cc0c6fe70952dc9)

Revision 2da76e41 (diff)
Added by Alexander Motin over 4 years ago

Fix FCP_CMD LENGTH mask in ATIO7 IOCB. This caused "long IU length (16384) ignored" errors following by others. Ticket: #15135 (cherry picked from commit 151759b71b72333b01ca1c567e20e1bf57f62753) (cherry picked from commit 5d75be6468ec7db125ca6cf71cc0c6fe70952dc9)

Revision 2da76e41 (diff)
Added by Alexander Motin over 4 years ago

Fix FCP_CMD LENGTH mask in ATIO7 IOCB. This caused "long IU length (16384) ignored" errors following by others. Ticket: #15135 (cherry picked from commit 151759b71b72333b01ca1c567e20e1bf57f62753) (cherry picked from commit 5d75be6468ec7db125ca6cf71cc0c6fe70952dc9)

History

#1 Updated by Matthew Bein over 4 years ago

  • File debug-nas2-20160503193330.txz added

#2 Updated by Matthew Bein over 4 years ago

5895

#3 Updated by Alexander Motin over 4 years ago

  • Has duplicate Bug #15134: Fiber Channel iSCSI issues with 9.10 added

#4 Updated by Alexander Motin over 4 years ago

  • Status changed from Unscreened to Screened

Do I understand right that reboot solved the problem? At least as I can see in logs messages didn't repeat after reboot.

#5 Updated by Matthew Bein over 4 years ago

The reboot corrects the issue on the console, but the LUN are still not being seen by the ESX system as they were in 9.3.

#6 Updated by Matthew Bein over 4 years ago

The reboot corrects the issue on the console, but the LUNs are still not being seen by the ESX system as they were in 9.3. Seem to appear and then disappear.

#7 Updated by Alexander Motin over 4 years ago

I have the same QLogic card in my test lab and I have no that problem. If that problem with "Request Queue Overflow" is easily reproducible, it could be helpful to enable verbose debugging messages from the isp driver by setting hint.isp.0.debug and hint.isp.1.debug loader tunables to 0x110f value, or may be higher.

#8 Updated by Matthew Bein over 4 years ago

I can try this this afternoon, so set the tunable to debug and I will need to upgrade to 9.10. With Freenas can I just roll back to 9.3 or would I need to reinstall always? Just thinking for ease of testing.

#9 Updated by Alexander Motin over 4 years ago

If you are updating via WebUI (not via ISO), all you need to revert is activate previous boot environment and reboot.

#10 Updated by Vaibhav Chauhan over 4 years ago

  • Priority changed from No priority to Important
  • Seen in changed from Unspecified to 9.10-STABLE-201605021851

#11 Updated by Alexander Motin over 4 years ago

  • Subject changed from iSCSI Fiber Channel issues with 9.10 to Fiber Channel issues with 9.10
  • Category changed from 89 to 129
  • Status changed from Screened to Ready For Release
  • Target version set to Unspecified

I've reproduced and fixed one case in QLogic driver ending up in infinite "Request Queue Overflow" errors. I don't know whether your specific case is the same, but since your logs don't provide additional input data to differentiate, lets assume that was it. :) Please try next FreeNAS update or next nightly build.

#12 Updated by Vaibhav Chauhan over 4 years ago

  • Target version changed from Unspecified to 261

#13 Updated by Matthew Bein over 4 years ago

  • % Done changed from 0 to 100

Issue was corrected with the suggested build. Tested and confirmed working ok now..

#14 Updated by Vaibhav Chauhan over 4 years ago

  • Target version changed from 261 to 9.10-STABLE-201606270534

#15 Updated by Vaibhav Chauhan over 4 years ago

  • Status changed from Ready For Release to Resolved

#16 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-nas2-20160503193330.txz)

#17 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF