Project

General

Profile

Bug #15718

No IP from DHCP on jails

Added by sharky 1337 over 4 years ago. Updated about 4 years ago.

Status:
Closed: Duplicate
Priority:
Important
Assignee:
John Hixson
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hey,

if I'm creating a new jail on 9.10 , the jail does not get an ip address from my dhcp server. If I reboot my server the jail get an ip address after the boot, but this can't be a solution.

Another user from the forum get this as well.

More information https://forums.freenas.org/index.php?threads/no-ip-from-dhcp-on-jails.43599/

If the developers need more logs. Feel free to ask.

History

#1 Updated by aloisio mello over 4 years ago

Add me to the issue.

Happening with four FN boxes I manage for family:

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Assignee changed from Josh Paetzel to John Hixson
  • Priority changed from No priority to Important

#3 Updated by Aaron Anderson over 4 years ago

Same problem here. Fresh install of 9.10 and trying to set up some plugins. Very sporadic.

#4 Updated by aloisio mello over 4 years ago

To help the team, my setup uses pfsense on all three houses I've installed the network for my family. Three different boxes setup (ASRock, Asus, and HP). Will build a test box and connect to a linksys router to isolate my common pfsense setup for troubleshooting purpose.

#5 Updated by aloisio mello over 4 years ago

  • File freenas_9.10_tests.txt added

Some logs and tests

#6 Updated by John Hixson over 4 years ago

  • Status changed from Unscreened to Screened

#7 Updated by Marc Bessière over 4 years ago

I'm affected too.

#8 Updated by Tom H over 4 years ago

I believe this issue could be the same as the one I reported here: https://bugs.freenas.org/issues/14638

#9 Updated by John Hixson over 4 years ago

  • Status changed from Screened to 15
  • Target version set to 261

Can you try installing more plugins and then attach a debug? system->advanced->"save debug".

#10 Updated by John Hixson over 4 years ago

I am unable to reproduce this here. I'd like to get more info, so please attach a debug as soon as possible.

#11 Updated by aloisio mello over 4 years ago

John Hixson wrote:

I am unable to reproduce this here. I'd like to get more info, so please attach a debug as soon as possible.

Debug is ready. How can I send it to you privately? Not sure of the content, so don't want it public.

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Private changed from No to Yes

Aloisio,

I've made the bug private now. You can safely attach the debug file to this ticket.

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Private changed from Yes to No

Aloisio,

If you would, open a new bug report (mark it private, assign to John Hixson and attach your debug file)

Thanks!

#14 Updated by aloisio mello over 4 years ago

Kris Moore wrote:

Aloisio,

If you would, open a new bug report (mark it private, assign to John Hixson and attach your debug file)

Thanks!

Kris - Ok, let me build a fresh test box later today and try to replicate. Will open a ticket and post debud in case I can duplicate. Will communicate if it's working also.

P.S. Saw that you've changed the ticket to private for me to upload the old file - thanks. I didn't receive that communication via e-mail and after that I wasn't able to read it, so also didn't see your post.

#15 Updated by John Hixson over 4 years ago

I'll need a debug before I can proceed any further here. If you don't want to attach to the ticket, you can send it to me privately. Please let me know what you would like to do.

#16 Updated by John Hixson over 4 years ago

Please see https://bugs.freenas.org/issues/15817 for progress on this issue.

#17 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

  • Status changed from 15 to Closed: Duplicate

#18 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 261 to N/A

#19 Updated by Dru Lavigne over 2 years ago

  • File deleted (freenas_9.10_tests.txt)

Also available in: Atom PDF