Project

General

Profile

Bug #15972

Error deleting Jail Template

Added by Edvard Filistovic over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Vaibhav Chauhan
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Crete Jail Template to for Debian using this URL: http://download.freenas.org/jails/9.2/x64/linux-debian-7.1.0.tgz
Install Debian ... then decide to delete. Jail deleted successfully, binaries delete successfully, but when I try to delete jail template, I am getting an error.

Request Method: GET
Request URL: http://192.168.10.100/admin/jails/jailtemplate/delete/18/
Software Version: FreeNAS-9.10-STABLE-201606072003 (696eba7)
Exception Type: ValueError
Exception Value:
The JailTemplate could not be changed because the data didn't validate.
Exception Location: /usr/local/lib/python2.7/site-packages/django/forms/models.py in save_instance, line 80
Server time: Wed, 15 Jun 2016 20:34:06 +0300

Environment:

Software Version: FreeNAS-9.10-STABLE-201606072003 (696eba7)
Request Method: GET
Request URL: http://192.168.10.100/admin/jails/jailtemplate/delete/18/

Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
105. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
156. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
22. return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in wrapper
209. return self._admin.admin_view(view)(*args, **kwargs)
File "/usr/local/lib/python2.7/site-packages/django/utils/decorators.py" in _wrapped_view
99. response = view_func(request, *args, **kwargs)
File "/usr/local/lib/python2.7/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
52. response = view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py" in inner
142. return view(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in delete
791. mf = mf(data=request.POST, instance=instance)
File "/usr/local/www/freenasUI/../freenasUI/jails/forms.py" in init
973. obj = self.save(commit=False)
File "/usr/local/lib/python2.7/site-packages/django/forms/models.py" in save
446. construct=False)
File "/usr/local/lib/python2.7/site-packages/django/forms/models.py" in save_instance
80. " validate." % (opts.object_name, fail_message))

Exception Type: ValueError at /admin/jails/jailtemplate/delete/18/
Exception Value: The JailTemplate could not be changed because the data didn't validate.


Related issues

Copied to FreeNAS - Bug #16346: Error deliting Jail TemplateResolved2016-06-15

Associated revisions

Revision 1e14eaf3 (diff)
Added by John Hixson over 5 years ago

Allow jail templates to be deleted Ticket: #15972

Revision cdea3d63 (diff)
Added by John Hixson over 5 years ago

Allow jail templates to be deleted Ticket: #15972 (cherry picked from commit 1e14eaf3c11a020838608a4c948be97b7adfc6bf)

Revision 7e72557a (diff)
Added by John Hixson over 5 years ago

Allow jail templates to be deleted Ticket: #15972 (cherry picked from commit 1e14eaf3c11a020838608a4c948be97b7adfc6bf)

Revision 6be05702 (diff)
Added by John Hixson over 5 years ago

Allow jail templates to be deleted Ticket: #15972 (cherry picked from commit 1e14eaf3c11a020838608a4c948be97b7adfc6bf)

Revision 9702d5e9 (diff)
Added by John Hixson over 5 years ago

Allow jail templates to be deleted Ticket: #15972 (cherry picked from commit 1e14eaf3c11a020838608a4c948be97b7adfc6bf)

Revision 9831397f (diff)
Added by John Hixson over 5 years ago

Allow jail templates to be deleted Ticket: #15972 (cherry picked from commit 1e14eaf3c11a020838608a4c948be97b7adfc6bf)

History

#1 Updated by John Hixson over 5 years ago

  • Status changed from Unscreened to 15

Can you please attach a debug? system->advanced->save debug

#2 Updated by Edvard Filistovic over 5 years ago

  • File debug-nas0-20160617132500.tgz added

John Hixson wrote:

Can you please attach a debug? system->advanced->save debug

done

#3 Updated by John Hixson over 5 years ago

  • Target version set to 261

#4 Updated by Vaibhav Chauhan over 5 years ago

where is the commit hash ?

#5 Updated by John Hixson over 5 years ago

  • Status changed from 15 to Investigation

I can reproduce this. I'll update when I know why and have a solution.

#6 Updated by John Hixson over 5 years ago

Vaibhav Chauhan wrote:

where is the commit hash ?

There isn't a fix yet.

#7 Updated by John Hixson over 5 years ago

  • Status changed from Investigation to 19

I have committed a fix. It needs to be tested and reviewed.

#8 Updated by Edvard Filistovic over 5 years ago

John Hixson wrote:

I have committed a fix. It needs to be tested and reviewed.

OK, how I can get this fix?

#9 Updated by John Hixson over 5 years ago

  • Status changed from 19 to Needs Developer Review

#10 Updated by Vaibhav Chauhan over 5 years ago

  • Target version changed from 261 to 9.10.1

Looks good to me and merged FIX-15972 to 9.10-STABLE, FIX-TN-15972 needs to be created.

#11 Updated by John Hixson over 5 years ago

  • Copied to Bug #16346: Error deliting Jail Template added

#12 Updated by John Hixson over 5 years ago

  • Assignee changed from John Hixson to Vaibhav Chauhan

#13 Updated by Vaibhav Chauhan over 5 years ago

  • Status changed from Needs Developer Review to Ready For Release
  • Priority changed from No priority to Important

FIX-TN-15972 and FIX-15972 were merged with TN-9.10-STABLE and 9.10-STABLE branch.

#14 Updated by Dru Lavigne about 5 years ago

  • Subject changed from Error deliting Jail Template to Error deleting Jail Template

#15 Updated by Vaibhav Chauhan about 5 years ago

  • Status changed from Ready For Release to Resolved

#16 Updated by Dru Lavigne almost 4 years ago

  • File deleted (debug-nas0-20160617132500.tgz)

Also available in: Atom PDF