Project

General

Profile

Bug #15984

Bug in GUI or Jails-DHCP problem

Added by Matt Kessler over 3 years ago. Updated about 3 years ago.

Status:
Closed: Not To Be Fixed
Priority:
Expected
Assignee:
John Hixson
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Any help would ge great, as this is a wild one and I don't know where to start debugging,
as the GUI is providing — what seems to me — conflicting information/options.

There seems to be some problem in the GUI, when it comes to changing DHCP/IP options.
And the status of a Plugin is not the same as the status of the jail it's in!?

I was not able to start any plugin, after I updated to the 2016 06 07 release.
They normally ran over DHCP and when I figured this was not working I tried switching them to static IPs, with no luck either.
Only after unticking DHCP in the "Default Jails Configuration" I was able to get static IPs to work.
Is this by design??

As I prefer DHCP, I went back and turned DHCP on again in the "Default Jails Configuration" and sure thing, I can not restart the plugin.

After a server reboot though, I can turn it on/off no problem, but I can not reach it by it's hostname.
I need to use http://192.168.178.32:8096 instead of http://emby:8096

[root@freenas] ~# arp -a | grep 02:e1:14:00
? (192.168.178.32) at 02:e1:14:00:0a:0b on epair0a expires in 47 seconds [ethernet]
? (192.168.178.32) at 02:e1:14:00:0a:0b on bge0 permanent [ethernet]

From the reboot log with some timestamp problems *

Jun 16 18:24:02 freenas smbd: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1
Jun 16 18:24:03 freenas smbd: dnssd_clientstub ConnectToServer: connect()-> No of tries: 2
Jun 16 18:24:03 freenas root: /etc/rc: WARNING: failed precmd routine for vmware_guestd
Jun 16 18:24:04 freenas smbd: dnssd_clientstub ConnectToServer: connect()-> No of tries: 3
Jun 16 18:24:05 freenas smbd: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mdnsd Socket:35 Err:-1 Errno:2 No such file or directory
Jun 16 18:24:08 freenas mDNSResponder: mDNSResponder (Engineering Build) (Jun  7 2016 20:26:10) starting
Jun 16 18:24:08 freenas mDNSResponder:   8: Listening for incoming Unix Domain Socket client requests
Jun 16 18:24:08 freenas mDNSResponder: mDNS_AddDNSServer: Lock not held! mDNS_busy (0) mDNS_reentrancy (0)
Jun 16 18:24:08 freenas mDNSResponder: CheckNATMappings: Failed to allocate port 5350 UDP multicast socket for PCP & NAT-PMP announcements
Jun 16 18:24:15 freenas mDNSResponder: mDNS_Register_internal: ERROR!! Tried to register AuthRecord 0000000801406D60 freenas.local. (Addr) that's already in the list
Jun 16 18:24:15 freenas mDNSResponder: mDNS_Register_internal: ERROR!! Tried to register AuthRecord 0000000801407180 42.178.168.192.in-addr.arpa. (PTR) that's already in the list
*Jun 16 16:24:20 freenas devd: Executing '/etc/pccard_ether bridge0 start'*
Jun 16 18:24:20 freenas bridge0: Ethernet address: 02:fb:08:8b:a5:00
*Jun 16 16:24:20 freenas devd: Executing '/etc/pccard_ether epair0a start'
*Jun 16 16:24:20 freenas devd: Executing '/etc/pccard_ether epair0b start'
*Jun 16 16:24:20 freenas devd: Executing '/etc/rc.d/dhclient quietstart epair0a'*
Jun 16 18:24:20 freenas kernel: bridge0: link state changed to UP
Jun 16 18:24:20 freenas kernel: bridge0: link state changed to UP
Jun 16 18:24:20 freenas kernel: bge0: promiscuous mode enabled
Jun 16 18:24:20 freenas epair0a: Ethernet address: 02:ff:20:00:05:0a
Jun 16 18:24:20 freenas epair0b: Ethernet address: 02:ff:70:00:06:0b
Jun 16 18:24:20 freenas kernel: epair0a: link state changed to UP
Jun 16 18:24:20 freenas kernel: epair0a: link state changed to UP
Jun 16 18:24:20 freenas kernel: epair0b: link state changed to UP
Jun 16 18:24:20 freenas kernel: epair0b: link state changed to UP
Jun 16 18:24:20 freenas kernel: epair0a: promiscuous mode enabled
Jun 16 18:24:20 freenas kernel: ng_ether_ifnet_arrival_event: can't re-name node epair0b
Jun 16 18:24:20 freenas kernel: ng_ether_ifnet_arrival_event: can't re-name node epair0b
*Jun 16 16:24:25 freenas devd: Executing '/etc/pccard_ether epair1a start'
*Jun 16 16:24:25 freenas devd: Executing '/etc/pccard_ether epair1b start'
*Jun 16 16:24:25 freenas devd: Executing '/etc/rc.d/dhclient quietstart epair1a'
Jun 16 18:24:25 freenas epair1a: Ethernet address: 02:ff:20:00:06:0a
Jun 16 18:24:25 freenas epair1b: Ethernet address: 02:ff:70:00:07:0b
Jun 16 18:24:25 freenas kernel: epair1a: link state changed to UP
Jun 16 18:24:25 freenas kernel: epair1a: link state changed to UP
Jun 16 18:24:25 freenas kernel: epair1b: link state changed to UP
Jun 16 18:24:25 freenas kernel: epair1b: link state changed to UP
Jun 16 18:24:25 freenas kernel: epair1a: promiscuous mode enabled
Jun 16 18:24:25 freenas kernel: ng_ether_ifnet_arrival_event: can't re-name node epair1b
Jun 16 18:24:25 freenas kernel: ng_ether_ifnet_arrival_event: can't re-name node epair1b
*Jun 16 16:24:30 freenas devd: Executing '/etc/pccard_ether epair2a start'
*Jun 16 16:24:30 freenas devd: Executing '/etc/pccard_ether epair2b start'
Jun 16 18:24:30 freenas epair2a: Ethernet address: 02:ff:20:00:07:0a
Jun 16 18:24:30 freenas epair2b: Ethernet address: 02:ff:70:00:08:0b
Jun 16 18:24:30 freenas kernel: epair2a: link state changed to UP
Jun 16 18:24:30 freenas kernel: epair2a: link state changed to UP
Jun 16 18:24:30 freenas kernel: epair2b: link state changed to UP
Jun 16 18:24:30 freenas kernel: epair2b: link state changed to UP
Jun 16 18:24:30 freenas kernel: epair2a: promiscuous mode enabled
Jun 16 18:24:30 freenas kernel: ng_ether_ifnet_arrival_event: can't re-name node epair2b
Jun 16 18:24:30 freenas kernel: ng_ether_ifnet_arrival_event: can't re-name node epair2b
Jun 16 16:24:30 freenas devd: Executing '/etc/rc.d/dhclient quietstart epair2a'

ifconfig

[root@freenas] ~# ifconfig
bge0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=c0099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,VLAN_HWTSO,LINKSTATE>
        ether 34:64:a9:9a:d3:98
        inet 192.168.178.42 netmask 0xffffff00 broadcast 192.168.178.255
        nd6 options=9<PERFORMNUD,IFDISABLED>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
bge1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=c019b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,VLAN_HWTSO,LINKSTATE>
        ether 34:64:a9:9a:d3:99
        nd6 options=9<PERFORMNUD,IFDISABLED>
        media: Ethernet autoselect (none)
        status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
        inet 127.0.0.1 netmask 0xff000000
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 02:fb:08:8b:a5:00
        nd6 options=1<PERFORMNUD>
        id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
        root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
        member: epair2a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 7 priority 128 path cost 2000
        member: epair1a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 6 priority 128 path cost 2000
        member: epair0a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 5 priority 128 path cost 2000
        member: bge0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 1 priority 128 path cost 20000
epair0a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 02:ff:20:00:05:0a
        nd6 options=1<PERFORMNUD>
        media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
        status: active
epair1a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 02:ff:20:00:06:0a
        nd6 options=1<PERFORMNUD>
        media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
        status: active
epair2a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 02:ff:20:00:07:0a
        nd6 options=1<PERFORMNUD>
        media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
        status: active

Cheers

1-Bug_Gui-Jails-DHCP.png (193 KB) 1-Bug_Gui-Jails-DHCP.png Sorry, put together from 4 browser tabs Matt Kessler, 06/16/2016 11:44 AM
2-Bug_Gui-Jails-DHCP-AfterServerReboot.png (66.1 KB) 2-Bug_Gui-Jails-DHCP-AfterServerReboot.png Matt Kessler, 06/16/2016 11:44 AM
6370
6371

Related issues

Related to FreeNAS - Bug #15817: Plugins not obtaining an IP from DHCPClosed: Not To Be Fixed2016-06-06
Has duplicate FreeNAS - Bug #16202: GUI: Edit Jail dialog is not working correct, when DHCP is ticked in Jails -> ConfigurationClosed: Not To Be Fixed2016-07-05

Associated revisions

Revision e8830b0f (diff)
Added by John Hixson over 3 years ago

Fix dhcp button for new jail dialog (cherry picked from commit e3a792a6acf1f2fff8f713912ae15ffccdfe422d) Ticket: #15984

Revision 2821137b (diff)
Added by John Hixson over 3 years ago

Fix dhcp button for new jail dialog (cherry picked from commit e3a792a6acf1f2fff8f713912ae15ffccdfe422d) Ticket: #15984

History

#1 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to 15

I have no clue, DHCP has been working for me. Can you attach debug from System -> Advanced after you have experienced the problrm?

Thanks

#2 Updated by Matt Kessler over 3 years ago

Thanks William

Could you have a look over here, please?
https://bugs.freenas.org/issues/14638#note-6

I've found more people having Jails/DHCP problems…
Bug #15817
Bug #15718

I started to rebuild my freenas, as it was too nuts :(
Cheers

#3 Updated by William Grzybowski over 3 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from William Grzybowski to John Hixson

Hi John,

I see you have recently fixed jail DHCP bugs, o you mind taking this one as well? Maybe it was fixed by you already.

Thanks!

#4 Updated by John Hixson over 3 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 261

#5 Updated by John Hixson over 3 years ago

  • Status changed from Screened to 15

This seems to be at least partially related to this bug: https://bugs.freenas.org/issues/16202 , which currently is waiting to be reviewed. I am not convinced it is related to being able to access by hostname, however. If you could apply the fix in the ticket and see if it works for you, that would be fantastic. If you need help doing so, I can help you with that as well.

#6 Updated by Matt Kessler over 3 years ago

Hi John
I sort of branched this bug into #16202 as soon as I figured out the JS problem and could reproduce and explain the exact problem.
I can't see a fix for #16202, only that you copied it to #16310, but no fix there either. Could you upload the JS file there, or was the fix somewhere else?
Anyway, I'll be gone for 3 weeks soon, so sorry can't test any new releases then.

And, I agree this will most likely not be related to the DHCP problem in jails…

#7 Updated by John Hixson over 3 years ago

Matt Kessler wrote:

Hi John
I sort of branched this bug into #16202 as soon as I figured out the JS problem and could reproduce and explain the exact problem.
I can't see a fix for #16202, only that you copied it to #16310, but no fix there either. Could you upload the JS file there, or was the fix somewhere else?
Anyway, I'll be gone for 3 weeks soon, so sorry can't test any new releases then.

And, I agree this will most likely not be related to the DHCP problem in jails…

The fix was pushed out in the last update. Have you applied the latest update?

#8 Updated by John Hixson over 3 years ago

  • Status changed from 15 to Needs Developer Review
  • Assignee changed from John Hixson to Vaibhav Chauhan

#9 Updated by Dru Lavigne over 3 years ago

Is this scheduled for -U1?

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 261 to 9.10.1-U1

#11 Updated by Matt Kessler over 3 years ago

@Kris
As per my note#6 I'd say, just close this one.

@John
Have updated now, but there are still things to be resolved.
Where do you want me post #16202 or the copy #16310?
In short… I think looking at the "default Configuration" should only happen, when the jail is created.
Once the jail is up, the user needs to be able to make changes at any time and place.

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from Needs Developer Review to Resolved

#13 Updated by Vaibhav Chauhan over 3 years ago

  • Related to Bug #15817: Plugins not obtaining an IP from DHCP added

#14 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Resolved to Unscreened

reopening this bug as this problem still exists

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

VB, you re-opened this. Is this something you are looking at? John wont be available until post -U1, so we may need to change the target to -U2 if it needs more code changes.

#16 Updated by Vaibhav Chauhan over 3 years ago

  • Assignee changed from Vaibhav Chauhan to John Hixson
  • Target version changed from 9.10.1-U1 to 9.10.1-U2

kris, I am not looking at this bug, I observed that there were problems in my home setup for jails in 9.10.1, so I think I will need this punted to U2, and setting up john as bug assignee.

#17 Updated by John Hixson over 3 years ago

  • Status changed from Unscreened to Screened

#18 Updated by Vaibhav Chauhan over 3 years ago

  • Has duplicate Bug #16202: GUI: Edit Jail dialog is not working correct, when DHCP is ticked in Jails -> Configuration added

#19 Updated by John Hixson over 3 years ago

  • Status changed from Screened to 15

The fix is in a branch (FIX-15984). I would really like to get confirmation from anyone that this fixes their issue. A diff can be seen in this ticket if the git link is followed. I have like 20 other bugs with this same issue, so can someone please verify? Manual patching is required unless a nightly is used.

#20 Updated by Matt Kessler over 3 years ago

As I do not see any links to git I can only guess you mean: https://github.com/freenas/freenas/commit/296a220df1473387548a52420f62dbf13c1fd346

From my above note-11 Aug 18…

Have updated now, but there are still things to be resolved.
In short… I think looking at the "default Configuration" should only happen, when the jail is created.
Once the jail is up, the user needs to be able to make changes at any time and place.

And this one needs fixing too:
https://bugs.freenas.org/attachments/6806/uiDhcpSettingsInJails_bug01.png

(PS: I do PHP testing/debugging on LAMP using xdebug, cachegrind… for ~14 years… as well as a lot of UI/CSS/JS/jQuery debugging…
is there anywhere, where I could read up on how to set up an equivalent testing environment for freenas, python, django, nginx )

#21 Updated by John Hixson about 3 years ago

Matt Kessler wrote:

As I do not see any links to git I can only guess you mean: https://github.com/freenas/freenas/commit/296a220df1473387548a52420f62dbf13c1fd346

From my above note-11 Aug 18…
[...]

And this one needs fixing too:
https://bugs.freenas.org/attachments/6806/uiDhcpSettingsInJails_bug01.png

(PS: I do PHP testing/debugging on LAMP using xdebug, cachegrind… for ~14 years… as well as a lot of UI/CSS/JS/jQuery debugging…
is there anywhere, where I could read up on how to set up an equivalent testing environment for freenas, python, django, nginx )

If you look at the "associated revisions" section of this ticket, you will see the commits I am referring to.

https://bugs.freenas.org/projects/freenas/repository/revisions/e8830b0f103c4754e5a37b0a7aca7154aa17e72a

Let me know if this works for you or not.

#22 Updated by Matt Kessler about 3 years ago

Sorry John,
all I'm getting is

Bug Tracking System
403

You are not authorized to access this page.

Back

Anyway. Looking at https://github.com/freenas/freenas/commit/e8830b0f103c4754e5a37b0a7aca7154aa17e72a?diff=split

This will only work, if one writes DHCP in the field manually! The clickfunktion(toggle) on the check-box above the input-field does not do this!
Please have a look at: https://bugs.freenas.org/attachments/6806/uiDhcpSettingsInJails_bug01.png

#23 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 9.10.1-U2 to 9.10.1-U3

#24 Updated by Dru Lavigne about 3 years ago

Is there anything to fix here for U3? Note that the referred to bug is private so the OP can't see it.

#25 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 9.10.1-U3 to 9.10.2

#26 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Status changed from 15 to Closed: Not To Be Fixed

Closing this now. We are working hard a new jail implementation for 9.10.3 (hopefully) which will change a lot of this functionality.

Also available in: Atom PDF