Project

General

Profile

Bug #16148

dtrace goo for volume import stopped working

Added by Josh Paetzel about 4 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Important
Assignee:
Josh Paetzel
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

dtrace -qn 'zfs-dbgmsg{printf("%s", stringof(arg0))}'
dtrace: invalid probe specifier zfs-dbgmsg{printf("%s", stringof(arg0))}: "/usr/lib/dtrace/psinfo.d", line 37: failed to copy type of 'pr_uid': Type information is in parent and unavailable

I confirmed this works on 9.10-STABLE based systems.

uname -a
FreeBSD freenas.tcbug.org 10.3-STABLE FreeBSD 10.3-STABLE #2 65e281a(freebsd10): Tue Jun 28 04:00:51 PDT 2016 :/tank/home/nightlies/build-freenas9/_BE/objs/tank/home/nightlies/build-freenas9/_BE/trueos/sys/FreeNAS.amd64 amd64

[root@freenas] ~# cat /etc/version
FreeNAS-9.10-MASTER-201606281057 (6730608)

[jpaetzel@liquid] ~/git/trueos% git diff origin/freebsd10 origin/9.10-STABLE | wc -l
211909

History

#1 Updated by Josh Paetzel about 4 years ago

  • Status changed from Unscreened to Investigation
  • Assignee changed from Jordan Hubbard to Josh Paetzel

We have confirmed this isn't a result of merges into freebsd10 branch.

#2 Updated by Josh Paetzel about 4 years ago

  • Status changed from Investigation to Closed: Cannot reproduce

Mysterious unreproducable FreeBSD build issues.

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Seen in changed from to N/A

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF