Project

General

Profile

Bug #16239

Resilvered disks set to incorrect block size of 512B instead of 4096 like rest of pool

Added by Seth - about 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Important
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

FreeNAS-9.10-STABLE-201606270534 (dd17351)

After replacing and resilvering two disks in a four disk zfs pool I noticed that the block size for the resilvered disks does not match the rest of the pool.

NAME                                            STATE     READ WRITE CKSUM
files ONLINE 0 0 0
raidz1-0 ONLINE 0 0 0
gptid/285e9b9e-17c2-11e6-8af4-d8d385b3ae72 ONLINE 0 0 0 block size: 512B configured, 4096B native
gptid/4c7c67e3-2475-11e6-b5f3-d8d385b3ae72 ONLINE 0 0 0
gptid/63a4fb1b-1ad2-11e6-8af4-d8d385b3ae72 ONLINE 0 0 0 block size: 512B configured, 4096B native
gptid/e8d101c5-2b4a-11e2-9357-d8d385b3ae72 ONLINE 0 0 0

The pool was originally created using block size of 4096 for all drives.
The resilvered drives have a block size of 512B. There was no option to choose the block during the resilvering process as best I can recall.

Please add a feature where the block size for resilvered disks will automatically match the oldest disk in the pool


Related issues

Is duplicate of FreeNAS - Bug #16819: 9.10 non-native block size errorClosed: Duplicate2016-08-13
Is duplicate of FreeNAS - Bug #16893: 4k alignmentClosed: Duplicate2016-08-17

Associated revisions

Revision 76c9fef4 (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): set vfs.zfs.vdev.larger_ashift_minimal accordingly

Use pool ashift to set this sysctl.
If this sysctl is set to 1 on pools with ashift 9 it will not work.
If it is set to 0 on pools with ahsift 12 you will get:
gptid/63a4fb1b-1ad2-11e6-8af4-d8d385b3ae72 ONLINE 0 0
0 block size: 512B configured, 4096B native

Ticket: #16239

Revision bb1cd4be (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): set vfs.zfs.vdev.larger_ashift_minimal accordingly

Use pool ashift to set this sysctl.
If this sysctl is set to 1 on pools with ashift 9 it will not work.
If it is set to 0 on pools with ahsift 12 you will get:
gptid/63a4fb1b-1ad2-11e6-8af4-d8d385b3ae72 ONLINE 0 0
0 block size: 512B configured, 4096B native

Ticket: #16239
(cherry picked from commit 76c9fef49b6e56cf6468c9688472905ebdaadfc9)

Revision c5a23e1a (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): set vfs.zfs.vdev.larger_ashift_minimal accordingly

Use pool ashift to set this sysctl.
If this sysctl is set to 1 on pools with ashift 9 it will not work.
If it is set to 0 on pools with ahsift 12 you will get:
gptid/63a4fb1b-1ad2-11e6-8af4-d8d385b3ae72 ONLINE 0 0
0 block size: 512B configured, 4096B native

Ticket: #16239
(cherry picked from commit 76c9fef49b6e56cf6468c9688472905ebdaadfc9)

Revision 8baa7263 (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): try to get ashift from vdev of disk being replaced

Ticket: #16239

Revision 092ffd2d (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): try to get ashift from vdev of disk being replaced

Ticket: #16239
(cherry picked from commit 8baa72638ac54ba732920ed38ab98724af56cf64)

Revision 68a398f2 (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): try to get ashift from vdev of disk being replaced

Ticket: #16239
(cherry picked from commit 8baa72638ac54ba732920ed38ab98724af56cf64)

Revision c8c45555 (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): use libzfs instead of stupid zdb parsing

Ticket: #16239

Revision c4dd4085 (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): use libzfs instead of stupid zdb parsing

Ticket: #16239
(cherry picked from commit c8c455559976753995d6fe3ba3689faeb61d49ce)

Revision 45fd968d (diff)
Added by William Grzybowski almost 3 years ago

fix(gui): use libzfs instead of stupid zdb parsing

Ticket: #16239
(cherry picked from commit c8c455559976753995d6fe3ba3689faeb61d49ce)

Revision e8e0f4b2 (diff)
Added by William Grzybowski almost 3 years ago

fix(build): lazy import libzfs

Ticket: #16239

Revision 7b8d33f0 (diff)
Added by William Grzybowski almost 3 years ago

fix(build): lazy import libzfs

Ticket: #16239
(cherry picked from commit e8e0f4b2539ac20c30527b411940e76c007d52ef)

Revision 4854f5a4 (diff)
Added by William Grzybowski almost 3 years ago

fix(build): lazy import libzfs

Ticket: #16239
(cherry picked from commit e8e0f4b2539ac20c30527b411940e76c007d52ef)

History

#1 Updated by Jordan Hubbard about 3 years ago

  • Project changed from 9 to FreeNAS
  • Category changed from 181 to 76

#2 Updated by Vaibhav Chauhan about 3 years ago

  • Assignee changed from Alexander Motin to William Grzybowski
  • Target version set to 9.10.2

BRB: Assigning to william, match the block size to 4k during resilvering.

#3 Updated by William Grzybowski about 3 years ago

  • Status changed from Unscreened to Screened

#4 Updated by William Grzybowski about 3 years ago

  • Is duplicate of Bug #16819: 9.10 non-native block size error added

#5 Updated by William Grzybowski about 3 years ago

#6 Updated by William Grzybowski about 3 years ago

  • Is duplicate of deleted (Bug #16893: 4k alignment)

#7 Updated by William Grzybowski about 3 years ago

#8 Updated by William Grzybowski almost 3 years ago

  • Category changed from 76 to 2
  • Status changed from Screened to Needs Developer Review
  • Priority changed from No priority to Important

#10 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Josh Paetzel

#11 Updated by Josh Paetzel over 2 years ago

  • Status changed from Needs Developer Review to Reviewed
  • Assignee changed from Josh Paetzel to William Grzybowski

#12 Updated by Vaibhav Chauhan over 2 years ago

  • Status changed from Reviewed to Ready For Release

#13 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF