Project

General

Profile

Bug #16602

CIF home share not accessible on Windows 10 if capitol letter in user name

Added by Christopher Shaker about 4 years ago. Updated about 4 years ago.

Status:
Closed: Cannot reproduce
Priority:
Expected
Assignee:
Erin Clark
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

AMD Turion(tm) II Neo N40L Dual-Core Processor
HP ProLiant N40, 16 GB RAM

ChangeLog Required:
No

Description

On FreeNAS 9.10, build FreeNAS-9.10-STABLE-201606270534 (dd17351), if I create a user with capitols in the name, as in "Lauri", the home directory is not accessible from a Windows 10 machine. However, if I delete that user, and create a new user "lauri", I can access the home network share from Windows 10.

Testing_error.jpg (90.1 KB) Testing_error.jpg Error message when attempting to open Testing share Christopher Shaker, 09/12/2016 12:36 AM
homes_error.jpg (89.3 KB) homes_error.jpg Error message when attempting to open homes share Christopher Shaker, 09/12/2016 12:36 AM
7047
7048

History

#1 Updated by Vaibhav Chauhan about 4 years ago

  • Assignee changed from Jakub Klama to Jan Stevenson
  • Priority changed from No priority to Expected
  • Target version set to 9.10.1-U1

BRB: Jan to triage this.

#2 Updated by Jan Stevenson about 4 years ago

  • Status changed from Unscreened to Screened

#3 Updated by Vaibhav Chauhan about 4 years ago

any update on this ?

#4 Updated by Dru Lavigne about 4 years ago

Will this be ready for U1?

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Due date set to 09/19/2016

#6 Updated by Vaibhav Chauhan about 4 years ago

BRB: jan, will there be a resolution for this bug before due date ?

#7 Updated by Vaibhav Chauhan about 4 years ago

can you please update with your findings ?

#8 Updated by Christopher Shaker about 4 years ago

7047
7048

I updated to FreeNAS-9.10.1 (d989edd), and created a new user named 'Testing'. I went to my Windows 10 machine, and created a new user named 'Testing', with the same password as on FreeNAS. Opened File Explorer, and clicked on Network. Clicked on my FREENAS machine. I've got shares named 'archive' and 'backup', which user Testing CAN access just fine.

When I attempt to open the folder named 'homes', or the folder named 'Testing', it fails with Error code 0x80070043 The network name cannot be found.

Chris Shaker

#9 Updated by Christopher Shaker about 4 years ago

I gave the user 'Testing' Samba group membership. Forgot to put that down...

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee changed from Jan Stevenson to William Grzybowski

Looks like this is a confirmed thing. Over to William for diagnosis.

#11 Updated by William Grzybowski about 4 years ago

Shouldn't this go to someone with more experience in Samba?

I can certainly try to look at this but I am sure it will take a lot more time since I have no knowledge about this and still have to setup all the infrastructure to test this, including Windows.

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee changed from William Grzybowski to Erin Clark

William, yea you are right. Sorry about that! Over to Erin

#13 Updated by Dru Lavigne about 4 years ago

Will this make it into U1 or should it be pushed to U2?

#14 Updated by Erin Clark about 4 years ago

Christopher: could you show me the contents of /usr/local/etc/smb4.conf?

Dru: I am not sure I can make this one for U1, I just got this bug a couple days ago and I've been trying to hammer other things down for it

#15 Updated by Vaibhav Chauhan about 4 years ago

  • Target version changed from 9.10.1-U1 to 9.10.1-U2

#16 Updated by Jan Stevenson about 4 years ago

I am unable to reproduce this issue. I took a Windows 10 VM and mapped a network share to a test FreeNAS box here and authenticated with user "Lauri" and was able to read and write in the network share without issue.

Christopher: I see from your screenshots that you're accessing your smb share from the "Network" option in the left panel on the Windows 10 UI. What's happens if you simply Map a Network Share (accessible from "This PC" -> "Computer" -> and then "Map a Network Drive" from the ribbon) and authenticate with a user account with a capital letter?

Also, could you create debug file and attach it to this ticket please (FreeNAS UI -> System -> Advanced -> Save Debug).

#17 Updated by Vaibhav Chauhan about 4 years ago

  • Status changed from Screened to Closed: Cannot reproduce

Also available in: Atom PDF