Project

General

Profile

Bug #16720

Avatar?id=14398&size=22x22

Mirrored boot broken after 9.10.1 update from WebUI 9.10

Added by Nikita Ozerov about 4 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Kris Moore
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Motherboard: SuperMicro X11SSM-F-O
Boot Drive: 2x16Gb Transcend JetFlash 710

ChangeLog Required:
No

Description


as you can see both devices are healthy

fixed by manual update from liveusb but screen is broken in VGA output and IPMI (blackscreen with no info)

screen.jpg (12.9 KB) screen.jpg Nikita Ozerov, 08/06/2016 08:49 AM
screen2.jpg (49 KB) screen2.jpg Nikita Ozerov, 08/06/2016 08:50 AM
6670
6672

History

#1 Updated by Nikita Ozerov about 4 years ago

  • Description updated (diff)

#2 Updated by Sean Fagan about 4 years ago

  • Assignee changed from Sean Fagan to Kris Moore

As far as I know we didn't change grub. Maybe changed the video defaults in the cfg file, but that was about it I thought.

#3 Updated by Nikita Ozerov about 4 years ago

  • Hardware Configuration updated (diff)

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Status changed from Unscreened to Screened

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

So, we didn't change anything except a few variables related to video output (may be the issue you mentioned with black screen?)

Are you installed via UEFI by any chance? You said it was fixed by manual insatall from USB, can you get me a debug file, or the /boot/grub/grub.cfg file from this system?

#6 Updated by Nikita Ozerov about 4 years ago

Kris Moore wrote:

So, we didn't change anything except a few variables related to video output (may be the issue you mentioned with black screen?)

Are you installed via UEFI by any chance? You said it was fixed by manual insatall from USB, can you get me a debug file, or the /boot/grub/grub.cfg file from this system?

how can i give you this?(what commands bring me to this file)

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Status changed from Screened to Investigation

Go to system -> advanced -> Save Debug (and attach the file to this ticket)

I'm not sure how helpful this will be with the mirrored boot issue, but the video one is most likely related to #16700

#8 Updated by Nikita Ozerov about 4 years ago

  • File debug-freenas-20160808163241.tgz added

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Private changed from No to Yes

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee changed from Kris Moore to Sean Fagan

Ok, so #16700 will fix your video issue.

As for the original problem, going to have to bump to Sef on this, since my python-foo is very weak:

https://github.com/freenas/freenas/blob/master/gui/middleware/notifier.py#L5989

Sef, it looks like he was installed with mirrored disks using UEFI. Looking at the above code, I think its DTRT. I.E. mounts /boot/efi (msdos) and umounts it after doing grub-install. Does it do this for both disks in a mirror though? Or is this only run when adding new disks, I.E. not when doing upgrades? I'm looking through his debug file, does this process get logged anywhere as well?

While I'm wishing for things, would be nice to get grub.cfg included in the debug file in its entirety as well ;)

#11 Updated by Sean Fagan about 4 years ago

  • Assignee changed from Sean Fagan to Kris Moore

The post-upgrade script for base-os has

for disk in $(sysctl -n kern.disks); do
if gpart show ${disk} | grep -q bios-boot; then
/usr/local/sbin/grub-install --modules="zfs part_gpt" /dev/${disk}
elif /bin/kenv | fgrep -q 'grub.platform="efi"' && gpart show ${disk} | grep -q efi; then
if mount -t msdos /dev/${disk}p1 /boot/efi; then
/usr/local/sbin/grub-install --efi-directory=/boot/efi --removable --target=x86_64-efi /dev/${d
isk}
umount -f /boot/efi
fi
fi
done

Remember, I still don't have working UEFI systems. Or even VMs. I didn't make those changes.

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Status changed from Investigation to Closed: Cannot reproduce

Nikita,

Any other details on this? Two of us in the office have setup mirrored boot UEFI systems, and can't get it to fail as you described. If you can provide some method of reproducing this, I'll be happy to take another look.

#13 Updated by Nikita Ozerov about 4 years ago

Kris Moore wrote:

Nikita,

Any other details on this? Two of us in the office have setup mirrored boot UEFI systems, and can't get it to fail as you described. If you can provide some method of reproducing this, I'll be happy to take another look.

Intalling 9.10 and upgrade to 9.10.1 gave no result? Bootmode in BIOS set as DUAL dunno what else can i provide…

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

Yea, this is a tough one to diagnose without reproducing. Maybe with the next update can you do it via the command-line instead of GUI? Take note and send us any errors in particular?

#15 Updated by Nikita Ozerov about 4 years ago

I think, you can close the bug cause of no updates for 9.10.1 and soon FREENAS10 Beta.

#16 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20160808163241.tgz)

#17 Updated by Dru Lavigne about 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

Also available in: Atom PDF