Project

General

Profile

Bug #16775

Jails & Plugins Unusable with 9.10.1 upgrade

Added by Leigh Rogers about 4 years ago. Updated about 3 years ago.

Status:
Closed: Not To Be Fixed
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Freenas 9.10 user for many months - everything works fine. Updated to 9.10.1 and experienced irreversable damage to permissions in jails, as per thread here: https://forums.freenas.org/index.php?threads/wtf-bigger-issue-causes-plugins-mysql-to-stop-working.45203/#post-305284

Reverted back to 9.10. Deleted & recreated jails, reconfigured plugins, confirmed all fully working.

Configuration includes the following:

1 Custom Jail, running the following:
  • sabnzbd-1.0.3-amd64
  • sickrage-autoupdate.9_1-amd64
  • couchpotato-autoupdate.9_5-amd64

2nd Jail running MySql.
Both jails, all services and permissions perfect.

As soon as I then upgrade to 9.10.1 and reboot the following happens:
  • Jails & Plugins not visible un GUI
  • Plugins are running and accesssible, but saturated with a variety of permissions errors, such as unable to access\create directories.
    & MySql not accessible

Selected 9.10 in boot & restarted = Working configuration restored.

F1 - Permission Errors.jpg (120 KB) F1 - Permission Errors.jpg Leigh Rogers, 08/10/2016 10:08 AM
F2 - Plugins Not Listed.jpg (178 KB) F2 - Plugins Not Listed.jpg Leigh Rogers, 08/10/2016 10:08 AM
6719
6720

History

#1 Updated by Leigh Rogers about 4 years ago

  • File debug-Freenas-20160810114725.txz added

#2 Updated by Jordan Hubbard about 4 years ago

  • Category changed from 1 to 38
  • Assignee changed from Sean Fagan to John Hixson

#3 Updated by John Hixson about 4 years ago

  • Status changed from Unscreened to 15
  • Target version set to 9.10.2

Can you provide a debug for the borked version? Nothing should be touching permissions during an upgrade.

#4 Updated by John Hixson about 4 years ago

Well, after reading your forum post, the problem is very clear. Your PAM file permissions are 777 when they should be 644. PAM is very picky about that. I'm willing to bet other permissions are borked too. Did you do something like a chmod -R 777 * ?

#5 Updated by John Hixson about 4 years ago

I see duplicate ARP entries as well

#6 Updated by Leigh Rogers about 4 years ago

6719
6720

On Thursday morning, everything was working fine. I updated to 9.10.1 and had a variety of problems as mentioned. It's possible that at this point I may have made some permission changes to try and rectify the original problem, but this wouldn't have been the cause of the problems - only an attempt to fix.

Regardless, I think we can safely disregard those. I've since deleted the entire dataset and recreated everything - with no permission changes other than those created by default. Everything works wonderfully now, until I update...

As requested, I've set version to 9.10.1 and rebooted. The same problems have re-occured and I've uploaded a debug & a couple of screenshots.

#7 Updated by Leigh Rogers about 4 years ago

  • File Output for CustomPlugin Jail.txt added
  • File Output for Kodi Jail.txt added

Outputs for ls -al /etc/pam.d/ in both jails also uploaded.

#8 Updated by Leigh Rogers about 4 years ago

Update - I deleted 9.10.1 from the system->boot list and then pressed update, allowing FreeNas to re-download and install 9.10.1, which it did without error.

I'm not running 9.10.1 with no plugin errors. They show in the GUI as they should and appear to be fully functional.

Is it possible it was a damaged download? Seems odd I didn't get any errors throughout the install and problems were just limited to plugins if that was the case?

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Seen in changed from Unspecified to 9.10.1

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee changed from John Hixson to Suraj Ravichandran

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 9.10.2 to 9.10.2-U1

#12 Updated by Suraj Ravichandran almost 4 years ago

  • Status changed from 15 to Screened

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U1 to 9.10.2-U3

#14 Updated by Suraj Ravichandran over 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Suraj Ravichandran to Brandon Schneider

Over to @Bradon to either investigate to incorporte fix in his jails architecture or close as already fixed in it.

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from Unscreened to Closed: Not To Be Fixed
  • Target version changed from 9.10.2-U3 to N/A

New jail work has begun to land which will replace this broken functionality

#16 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-Freenas-20160810114725.txz)

#17 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-Freenas-20160810180354.tgz)

#18 Updated by Dru Lavigne about 3 years ago

  • File deleted (Output for CustomPlugin Jail.txt)

#19 Updated by Dru Lavigne about 3 years ago

  • File deleted (Output for Kodi Jail.txt)

#20 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF