Project

General

Profile

Bug #16870

netatalk map acls = mode

Added by John Hixson about 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Important
Assignee:
William Grzybowski
Category:
Services
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

There should be an option in the AFP configuration to allow this to be configured. The afp generation script should do the right thing. I have confirmed this works when done correctly. I know what needs to be done and can do it. This allows AFP, Windows and ZFS to all work in harmony. The AD UI will also need some tweaking for this (User and Group OU specification, which has been a requested feature for some time anyhow).


Related issues

Related to FreeNAS - Bug #18390: when map acls = mode, do the right thing with ACL's on macResolved2016-10-19

Associated revisions

Revision 8a4c0356 (diff)
Added by John Hixson about 4 years ago

NFSv4 ACL's for AFP - maps acls = mode Ticket: #16870

Revision 72f465eb (diff)
Added by John Hixson about 4 years ago

Encode GUID as string Ticket: #16870

Revision 019069c2 (diff)
Added by John Hixson about 4 years ago

Usa sAMAccountName for group attribute Ticket: #16870

Revision df5ffaed (diff)
Added by John Hixson about 4 years ago

Filter user and group base by object class Ticket: #16870

History

#1 Updated by John Hixson about 4 years ago

  • Status changed from Unscreened to Screened

#2 Updated by John Hixson about 4 years ago

While doing this, it would be nice investigate and get working AD kerberos auth for AFP so that Macs joined to AD don't require a password for accessing AFP shares (like SMB currently does).

#3 Updated by Vaibhav Chauhan about 4 years ago

BRB: so are how are we going to get this FIX in ? Do we have a deadline you would like to present ?

#4 Updated by Dru Lavigne about 4 years ago

Will this be merged in and tested in time for U1? If so, the doc team needs to know in time to doc it.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from 9.10.1-U1 to 9.10.1-U2

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee changed from John Hixson to Erin Clark

#7 Updated by John Hixson about 4 years ago

  • Assignee changed from Erin Clark to John Hixson

I'm taking this one back since it is related directly to my work with Marvel (and I created it ;-))

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 9.10.1-U2 to 9.10.1-U3

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

BRB: John, is this something you are still actively hacking on? Can it get wrapped up maybe by end of next week for -U3?

#10 Updated by Dru Lavigne almost 4 years ago

Will this make it into U3?

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 9.10.1-U3 to 9.10.2

#12 Updated by Vaibhav Chauhan almost 4 years ago

John, can you take a look at this ticket and please let us know if your fixes will be able to make into 9.10.2 Freenas release

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

John: Ping! Did you still have ongoing work to get this in? Any chance we can get it in for 9.10.2 by end of next week, or should we push it to 9.10.2-U1?

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 9.10.2 to 9.10.2-U1

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U1 to 9.10.2-U2

#16 Updated by John Hixson over 3 years ago

  • Target version changed from 9.10.2-U2 to 9.10.3

#17 Updated by John Hixson over 3 years ago

  • Target version changed from 9.10.3 to 9.10.4

I will revisit this for freenas 11. The code is in place to setup map acls = mode for AFP when AD is enabled for now.

#18 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.4 to 11.1

#19 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Target version changed from 11.1 to 11.1-U1

#20 Updated by Dru Lavigne almost 3 years ago

  • Related to Bug #18390: when map acls = mode, do the right thing with ACL's on mac added

#22 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.1-U1 to 11.2-BETA1

Pushing to next feature release.

#23 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Target version changed from 11.2-BETA1 to 11.3

#24 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Screened to Not Started

#25 Updated by John Hixson over 2 years ago

  • Assignee changed from John Hixson to Timur Bakeyev

#26 Updated by John Hixson over 2 years ago

  • Assignee changed from Timur Bakeyev to John Hixson

#27 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Target version changed from 11.3 to Backlog

#28 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 2 years ago

  • Severity set to New

#29 Updated by John Hixson about 2 years ago

  • Category changed from OS to Services

#31 Updated by John Hixson about 2 years ago

  • Severity changed from New to Low Medium

#32 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from John Hixson to William Grzybowski

#33 Updated by William Grzybowski almost 2 years ago

  • Status changed from Not Started to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Not Applicable

Partial code was already added long ago for `map acls`.

If anything else is missing a new ticket should be made. No reason to hold on to a ticket for 2+ years.

Also available in: Atom PDF