Project

General

Profile

Bug #17016

9.10.1-U2 Jail Cannot Have DHCP Selected

Added by Matt Witkowicz almost 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Critical
Assignee:
Suraj Ravichandran
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After upgrading to 9.10.1 cannot select DHCP for jails IPv4. Checkbox quickly unselects itself.

After changing back to 9.10 issue was no longer present.


Related issues

Has duplicate FreeNAS - Bug #17015: 9.10.1 Jail Cannot Select DHCPClosed: Duplicate2016-08-25
Is duplicate of FreeNAS - Bug #18742: IPv4 DHCP unselectable when creating new jail in 9.10-U2Closed: Duplicate2016-11-05

Associated revisions

Revision da11a245 (diff)
Added by Suraj Ravichandran over 2 years ago

Allow to create DHCP jails again!

Ticket: #17016

Revision 35320fb8 (diff)
Added by Suraj Ravichandran over 2 years ago

s/isspace/startswith("DHCP") D'OH!

Ticket: #17016

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Seen in changed from Unspecified to 9.10.1

#2 Updated by Vaibhav Chauhan almost 3 years ago

  • Has duplicate Bug #17015: 9.10.1 Jail Cannot Select DHCP added

#3 Updated by John Hixson almost 3 years ago

  • Status changed from Unscreened to Screened

#4 Updated by David Dyer-Bennet almost 3 years ago

  • ChangeLog Entry updated (diff)

This works as a workaround for me: After creating the new jail, edit it and enter "DHCP" for the IPv4 address, save it, edit again in advanced mode, and I find I can now check the DHCP box. (I do have to go back and set the default netmask.)

This has worked on multiple test jails, seems to be reliable at least for me.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Assignee changed from John Hixson to Suraj Ravichandran

#6 Updated by Joe Schmuck almost 3 years ago

  • Subject changed from 9.10.1 Jail Cannot Have DHCP Selected to 9.10.1-U1 Jail Cannot Have DHCP Selected
  • Seen in changed from 9.10.1 to 9.10-U1
  • ChangeLog Entry updated (diff)

This problem is present in 9.10.1-U1 (ff51a5d) and I too cannot select DHCP when creating a jail. This was on a clean install of FreeNAS 9.10.1-U1 in ESXi. The system was minimally configured and using a DHCP address for the FreeNAS GUI.

#7 Updated by Vaibhav Chauhan almost 3 years ago

  • Seen in changed from 9.10-U1 to 9.10.1-U1

#8 Updated by Vaibhav Chauhan almost 3 years ago

  • Status changed from Screened to Closed: Duplicate

#9 Updated by Vaibhav Chauhan almost 3 years ago

  • Status changed from Closed: Duplicate to Screened

#10 Updated by George S almost 3 years ago

  • Subject changed from 9.10.1-U1 Jail Cannot Have DHCP Selected to 9.10.1-U2 Jail Cannot Have DHCP Selected
  • Seen in changed from 9.10.1-U1 to 9.10.1-U2

Confirmed this bug still exists in 9.10.1-U2. David's workaround sitll works.

#11 Updated by Suraj Ravichandran over 2 years ago

  • Status changed from Screened to Needs Developer Review
  • Priority changed from No priority to Critical
  • Target version set to 9.10.2
  • % Done changed from 0 to 90

Finally got around to finding this bug and fixing it.

#12 Updated by Suraj Ravichandran over 2 years ago

  • Assignee changed from Suraj Ravichandran to William Grzybowski
  • % Done changed from 90 to 100

WIlliam please review https://github.com/freenas/freenas/commit/da11a2452e658b6ec980d4ccb712f19a0026630b.

Note: there is no fix branch since we will be cutting 9.10.2-STABLE off of master so....

#14 Updated by William Grzybowski over 2 years ago

  • Status changed from Needs Developer Review to Reviewed
  • Assignee changed from William Grzybowski to Suraj Ravichandran

#15 Updated by William Grzybowski over 2 years ago

  • Is duplicate of Bug #18742: IPv4 DHCP unselectable when creating new jail in 9.10-U2 added

#16 Updated by Vaibhav Chauhan over 2 years ago

  • Status changed from Reviewed to Ready For Release

#17 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF