Project

General

Profile

Bug #17056

I cannot select DHCP for IPv4 on Jails

Added by Marcelo Ruiz over 3 years ago. Updated over 2 years ago.

Status:
Closed: Not To Be Fixed
Priority:
Important
Assignee:
John Hixson
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I am trying to create a new Jail and I cannot check the DHCP box for IPv4. I can see that is selected for a very short time and goes back to unselected.
I am using 9.10.1 (d989edd) on a FreeNas Mini


Related issues

Is duplicate of FreeNAS - Bug #15817: Plugins not obtaining an IP from DHCPClosed: Not To Be Fixed2016-06-06

History

#1 Updated by Marcelo Ruiz over 3 years ago

  • File debug-freenas-20160826214537.txz added

#2 Updated by Jordan Hubbard over 3 years ago

  • Assignee set to John Hixson

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Priority changed from No priority to Important
  • Target version set to 9.10.1-U1
  • Seen in changed from Unspecified to 9.10.1

#4 Updated by Marcelo Ruiz over 3 years ago

Actually, I found that if you type DHCP on the IPv4 address field the check appears. Somehow it seems the behavior is the reverse as I would expect...

#5 Updated by Dru Lavigne over 3 years ago

Does this need a fix, and if so, will it be in for U1?

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from John Hixson to Suraj Ravichandran

GUI Bug, something you can look at?

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Due date set to 09/19/2016

#8 Updated by Vaibhav Chauhan over 3 years ago

  • Is duplicate of Bug #15817: Plugins not obtaining an IP from DHCP added

#9 Updated by Vaibhav Chauhan over 3 years ago

  • Assignee changed from Suraj Ravichandran to John Hixson
  • Target version changed from 9.10.1-U1 to 9.10.1-U2

#10 Updated by John Hixson over 3 years ago

  • Status changed from Unscreened to Screened

#11 Updated by Marcelo Ruiz over 3 years ago

Is this bug really a duplicate of Bug #15817: Plugins not obtaining an IP from DHCP added? My jails do obtain IPs from DHCP with no problem if I type "DHCP" on the IPv4 Address text box.

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 9.10.1-U2 to 9.10.1-U3

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

BRB: Ping, something we can still get in for -U3?

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 9.10.1-U3 to 9.10.2

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Status changed from Screened to Closed: Not To Be Fixed

Closing this now. We are working hard a new jail implementation for 9.10.3 (hopefully) which will change a lot of this functionality.

#16 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-freenas-20160826214537.txz)

#17 Updated by Dru Lavigne over 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF