Project

General

Profile

Bug #17433

Plugins Wont Load in GUI

Added by John Ramsden about 4 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Suraj Ravichandran
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My plugin interface will not load plugin install options, or existing plugins. I have 5 installed plugins running, they all have static IPs and are connected to the internet. My FreeNAS is on a static IP with the default gateway and nameserver set.

The pbi url is http://download.freenas.org/plugins/9/x64/pbi-meta/pbi-repo.rpo

Occasionally if I wait a long time the plugins that are installed will show up, but sometimes takes 10 minutes for them to load. I didn't used to have this problem so I'm not sure what's going wrong. I am on an up-to-date FreeNAS-9.10.1 (d989edd).

I attached screenshots.

20160908-174834.png (220 KB) 20160908-174834.png John Ramsden, 09/08/2016 06:06 PM
20160908-174618.png (257 KB) 20160908-174618.png John Ramsden, 09/08/2016 06:06 PM
7030
7031

Related issues

Is duplicate of FreeNAS - Bug #17945: After upgrade to "FreeNAS-9.10.1-U1 (ff51a5d)" the UI is unable to display plugin statusClosed: Not To Be Fixed2016-10-02

History

#1 Updated by John Ramsden about 4 years ago

  • File debug-Lilan-20160908180611.txz added

#2 Updated by John Ramsden about 4 years ago

7030

#3 Updated by John Ramsden about 4 years ago

7031

#4 Updated by Heather Ownby about 4 years ago

  • Assignee set to William Grzybowski

#5 Updated by William Grzybowski about 4 years ago

  • Assignee changed from William Grzybowski to John Hixson

I think John knows more about that piece of code.

#6 Updated by John Hixson about 4 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 9.10.2

#7 Updated by John Hixson about 4 years ago

What is the output of the following command:

find /var/db/pbi -print

#8 Updated by John Hixson about 4 years ago

  • Status changed from Screened to 15

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee changed from John Hixson to Suraj Ravichandran

#10 Updated by John Ramsden about 4 years ago

~# find /var/db/pbi -print
/var/db/pbi
/var/db/pbi/repos
/var/db/pbi/repo-icons
/var/db/pbi/.hashdirty.last
/var/db/pbi/.hashqueue
/var/db/pbi/mirrors
/var/db/pbi/index
/var/db/pbi/.hashdirty
/var/db/pbi/installed
/var/db/pbi/keys

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 9.10.2 to 9.10.2-U1

#12 Updated by Suraj Ravichandran almost 4 years ago

  • Status changed from 15 to Closed: Duplicate

Marking this as a duplicate of #17945 as it seems to be the same issue.

#13 Updated by Suraj Ravichandran almost 4 years ago

  • Is duplicate of Bug #17945: After upgrade to "FreeNAS-9.10.1-U1 (ff51a5d)" the UI is unable to display plugin status added

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U1 to N/A

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Seen in changed from Unspecified to N/A

#16 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-Lilan-20160908180611.txz)

#17 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF