Project

General

Profile

Bug #17552

When a homedir is on a dataset with Windows permissions set, trying to change permissions on the homedir fails silently

Added by Anonymous about 4 years ago. Updated over 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Expected
Assignee:
John Hixson
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

To reproduce:

1. Create a dataset and give it Windows permissions
2. Create a user and put the user's homedir on the dataset
3. Attempt to change the user's homedir permissions

The window will close, but the homedir permissions will not change (check this by viewing the user's settings again.

This is expected behavior based on how Windows permissions work. However, the silent failure is undesirable. Please add some indication that the homedir permissions cannot be set in this situation.

History

#1 Updated by Bonnie Follweiler about 4 years ago

  • Assignee set to Josh Paetzel

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Assignee changed from Josh Paetzel to Erin Clark
  • Priority changed from No priority to Expected
  • Target version set to 9.10.2

#3 Updated by Erin Clark about 4 years ago

  • Status changed from Unscreened to Screened

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

Erin - You set this to screened two months ago. Can you still get this in for 9.10.2?

#5 Updated by Erin Clark almost 4 years ago

  • Target version changed from 9.10.2 to 9.10.2-U1

This does not appear to be as easy as I was hoping it would be to accomplish, not sure I can get it done for 9.10.2

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U1 to 9.10.2-U2

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Erin Clark to John Hixson
  • Target version changed from 9.10.2-U2 to 9.10.3

#8 Updated by John Hixson over 3 years ago

  • Status changed from Screened to 15

I am unable to reproduce this. Can you provide exact steps to repeat issue? Your steps as described don't describe if you are trying to change the permissions from the UI or the command line. I repeated the provided steps all from the UI and everything works as expected.

#9 Updated by John Hixson over 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.3 to N/A

Also available in: Atom PDF