Project

General

Profile

Bug #17758

Avatar?id=14398&size=22x22

Jumbo frames crash

Added by Chris Casanova almost 4 years ago. Updated about 3 years ago.

Status:
Closed: Third party to resolve
Priority:
Nice to have
Assignee:
Kris Moore
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After enabling or disabling mtu 9000 on lagg0 and both interfaces in the lagg, freenas will reboot.

History

#1 Updated by Chris Casanova almost 4 years ago

  • File debug-freenas-20160925105820.txz added

#2 Updated by Chris Casanova almost 4 years ago

  • File textdump.tar.4.gz added

#3 Updated by Bonnie Follweiler almost 4 years ago

  • Assignee set to Josh Paetzel

#4 Updated by Josh Paetzel almost 4 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Important

It reboots and then works fine?

#5 Updated by Chris Casanova almost 4 years ago

Yes. Specifying 'mtu 9000' as an option on each interface and the lagg works fine. Confirmed 9k packets being sent and received on the wire, no reboot. Previously had issues of random reboots while option enabled, not sure if this is involved with the 9k mtu or not. Had turned off mtu 9000 for 3 weeks with no reboot for this duration, turned back on on the 23rd. I am going to leave this option on permanently now and will include any debug/crash logs I can going forward if present.

#6 Updated by Josh Paetzel almost 4 years ago

Ok, I'll keep this ticket open for now.

It looks like the jail vnet stuff is interacting poorly with the mtu change/lagg restart. That may take a while to fix, but if you are getting panics at run time once it's running and configured let me know.

#7 Updated by Vaibhav Chauhan almost 4 years ago

  • Target version set to 9.10.1-U3

#8 Updated by Josh Paetzel almost 4 years ago

  • Priority changed from Important to Nice to have

#9 Updated by Dru Lavigne almost 4 years ago

Will this make it into U3 or should it be punted to .2?

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Target version changed from 9.10.1-U3 to 9.10.2-U1

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U1 to 9.10.2-U2

#12 Updated by Josh Paetzel over 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Josh Paetzel to Kris Moore

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Status changed from Unscreened to Closed: Third party to resolve

The VNET stuff got an overhaul in FreeBSD 11.0, which we will grab when we re-base on FreeBSD 11 here in future. I suspect it will fix this issue.

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 9.10.2-U2 to N/A

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Seen in changed from Unspecified to N/A

#16 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20160925105820.txz)

#17 Updated by Dru Lavigne about 3 years ago

  • File deleted (textdump.tar.4.gz)

#18 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF